[WHMIS] Teabag Magee Apr 9, 2013 @ 4:46pm
Age of Empires 2 hd edition crashes
my copy of aoe 2 hd will load and start up and play but after various amounts of time the game will crash and say that there is another copy running and will prompt and error report to be sent, just wondering if there is a fix for this and if others are experiencing this same problem
Showing 1-15 of 22 comments
< >
Odins Auge Apr 12, 2013 @ 11:20pm 
i've the same problem on 2 different computers
Ng Mui Maton Apr 13, 2013 @ 12:39pm 
Same problem with 3 different computers
BothEyesShut Apr 13, 2013 @ 2:05pm 
Yeah my AoE2 HD starts and immediately crashes. None of my other 40 games has this problem.
Key Oh! Apr 17, 2013 @ 7:59am 
I got the exact same problem... Is there any fix for that?
marleymarley627 Apr 20, 2013 @ 3:53am 
Me too...........exact the same problem !!!!!!!!
BothEyesShut Apr 20, 2013 @ 7:35pm 
I read somewhere that AoE2 HD doesn't have WinXP support, so I stopped trying to fix it. Sad, though.
[WHMIS] Teabag Magee Apr 21, 2013 @ 5:26pm 
kinda basically what ive done :(
miragemasaki Apr 26, 2013 @ 11:01pm 
My game instantly crashed when starting past the launch screen.

I fixed mine by:

Right clicking the game in the library.
Select properties
Click Select Launch Options
in the new window that pops up input -nostartup
click Ok
start up the game.
BothEyesShut Apr 28, 2013 @ 12:45am 
I will try that, thx.
Computer Apr 28, 2013 @ 5:59am 
Any plans on fixing this.. kind of a waste of $20 if not.. dam.
kamster99 Apr 28, 2013 @ 9:10am 
I try launching the launcher and for me large parts of the launcher are white (you can't select anything). The game actually used to work on this computer but then it stopped working shortly before launch. I've tried the various fixes I've found on here, including one that bypasses the launcher, but nothing has worked. When I get into the game it crashes.

I've also tried reinstalling all of my drivers, updating windows, and reinstalling the game/verifying its cache. No good! I'm running Windows 7 64 bit edition.
Last edited by kamster99; Apr 28, 2013 @ 9:11am
Nanex May 1, 2013 @ 6:07pm 
Same problem, miragemasaki's fix didn't work for me either.. Windows 7 64 bit. Sad, really, because I have the old AoE 2 here and got it to run on Win7 but thought the HD version would improve it with multiplayer and better grafic. Hope there will be a patch or some workaround soon.

EDIT: For any one who still has this problem, I got it to work with deinstalling (deleting local content in Steam), running CCleaner and reinstalling.
Last edited by Nanex; Jun 18, 2013 @ 1:41pm
mycroft143 May 24, 2013 @ 5:02pm 
AoE2 HD great game when it works. But like a lot of ppl mine crashes too or the graphics mess up looking like a jigsaw puzzle. My workaround (single player anyway) works for the short time, but I have a lot of time. Right click of the game in libarary, click on delete local contient ( it will not delete saved games so no worry there) DOWNLOAD game again, that is the worst part. Start a new game...make a save then log out and LOAD the saved game. Some times I can play 2 hours after doing that sometimes have to LOAD the saved game a couple of times. I also have learned to save alot. I am sure that steam well get this game fixed before long.
oldEmmi Sep 2, 2013 @ 9:52pm 
Hey guys I had the same problem and did the following. I am not sure whether all these are needed though:
1- Did the following which did not fix the problem.

Originally posted by miragemasaki:
My game instantly crashed when starting past the launch screen.

I fixed mine by:

Right clicking the game in the library.
Select properties
Click Select Launch Options
in the new window that pops up input -nostartup
click Ok
start up the game.

The above just skips the intro video etc. It was not good alone, but might be good with the combination of the following which I just wanted to give it a try.

2- Right click on the Launcher.exe file in the Age of empires folder, and under the properties made compatibility change to xp3 compatible, and launch as administrator.(This is i think pretty standard for older games. Did the same for simcity4 and max payne 2. max payne under steam wouldn't run until i did this change.)

3- I took backup of the game in steam application by right click -> local files -> backup. (Cause I did not want reinstall again using the internet. I was planning to uninstall and reinstall after the above in case it wouldn't work)

Then when i started the game it made an upgrade. Still not sure whether this has anything to do with the things i did above. Then I clicked play.

I haven't had any problems afterwards.
Last edited by oldEmmi; Sep 2, 2013 @ 9:53pm
AlexPej79 Sep 3, 2013 @ 1:30pm 
The game wouldn't load, I erased the game and re-installed from steam. It loads now but I didn't discover any new problems.
Showing 1-15 of 22 comments
< >
Per page: 15 30 50