MS Ryz0n  [developer] Apr 5, 2013 @ 1:08pm
Multiplayer Issues
If you are experiencing experiencing issues with the multiplayer, lets try to keep it tuned into this thread so we're able help take a look at / address them best. If you are experiencing one of these issues please feel free to post below, or describe the issue you're seeing below.

Remember we are using Steam's multiplayer tech. It's always advisable to ensure the necessary ports are forwarded: Steam Port Lists (*updated to include all matchmaking related ports on Steam, not just the p2p ones*)

UDP 27000 to 27015 inclusive
UDP 27015 to 27030 inclusive
UDP 4380
UDP 3478 (Outbound)
UDP 4379 (Outbound)

1) issues when doing quick matches. Some players have been reporting game crashes when attempting to start a quick-match game.

2) Multiplayer network connectivity issues. (not related to player ping). - please describe the issue you're seeing, # of players in match, if you're seeing other issues, etc.
Last edited by MS Ryz0n; Apr 5, 2013 @ 1:40pm
Showing 1-15 of 630 comments
< >
Helo Apr 5, 2013 @ 1:14pm 
Major issue finding a connectable game. basicly it times out at the . if you dont join game within 15 second press esc. spot.

was first thinking it was port issue but i guess ure using steam tech now so shouldnt be that i guess

Mach make crash happens for me too
ReDTerraN Apr 5, 2013 @ 1:15pm 
game crash and all people dc'es when ingame statistics are being shown next to the minimap. any player can do this and the game crashes not just host.

windows vista 32 bit
Wizzcameron Apr 5, 2013 @ 1:17pm 
This is the current config of the proxy network. It needs to be better configured which I hope they are working on. It took a long time to get working perfect on Zone and there were a fair few racks full of gear and routing equipment. There also needs to be an official word on port forwarding to bypass the proxy network which will fix latency issues for people complaining.
astralis Apr 5, 2013 @ 1:17pm 
If someone disconnects during a game and the remaining players have to chose whether to wait or continue the game, the game won't resume even if ALL the remaining players have chosen "Continue game".
sothys Apr 5, 2013 @ 1:19pm 
Horrible lagging to the point of unplayable :(
i wish you good luck, cant wait to play my favorite game when it does run smoothly ! :)
EDIT: crash on quick match FFA
windows 7 64bit
Tanooki Apr 5, 2013 @ 1:21pm 
astralis, I played a game and someone dropped, and it continued. It seems much improved over what it was in AOC, didn't have to wait forever for them to drop, etc...
maxxuss [AiRe] Apr 5, 2013 @ 1:22pm 
If you chose anything other than random civ on quickmatch you either get a loading screen forever or you crash, test with the following parameters:
Random Map
FFA
Turks
Wizzcameron Apr 5, 2013 @ 1:23pm 
Originally posted by astralis:
If someone disconnects during a game and the remaining players have to chose whether to wait or continue the game, the game won't resume even if ALL the remaining players have chosen "Continue game".

This is as per the orignal, but should be fixed. @ES_Cameron
Groupers Apr 5, 2013 @ 1:24pm 
How would we even know if the issues are related to multiplayer ping? There isn't any way to see it in the game.
efficientdirect Apr 5, 2013 @ 1:27pm 
Problems:

1) Quick match always results in game crashing
2) Outrageously bad lag - not bad framerate - in every single game I've played
3) Before the map starts around 20%-60% players will have dropped out; gets stuck on loading screen, when in the old game it took like 10 seconds
4) Lobby is generally really poor - option to filter by player would be better - not really a major issue though!
5) Whenever I can't join a game takes me back to the main menu - why!??
6) Out of sync issues occuring throughout the game, at least every few minutes, if not more so.
4) This is the worst: randomly dropping out of the game half-way through, with no warning, and taking me back to the main menu!

Can I just add that it is really appalling to have even considered releasing, pre-releasing or whatever you may term in, in the game's current state. It is borderline unplayable and it's somewhat cheeky to demand money to play a game in its current form. I say this with the greatest of respect. Please fix asap!
Gogo Apr 5, 2013 @ 1:29pm 
My issue with multiplayer is that apparently is region locked, now in the lobby I can only see 4 games.

Why cant I browse games fron Europe or NA?

There wasnt any type of warning about the game being region locked, and in the original version of the game, there wasnt any type of region lock.


Is this going to change?
Gman is GOD Apr 5, 2013 @ 1:30pm 
The problem i was having is that when in a game with myself and two others, the game would work for a good ~10 minutes. After that, we would all lag, and finally the game would freeze with that screen that gives us three options, to continue, wait, or save and exit. Even though we all click continue nothing happens.
MS Ryz0n  [developer] Apr 5, 2013 @ 1:31pm 
Originally posted by Gogo:
My issue with multiplayer is that apparently is region locked, now in the lobby I can only see 4 games.

Why cant I browse games fron Europe or NA?

There wasnt any type of warning about the game being region locked, and in the original version of the game, there wasnt any type of region lock.


Is this going to change?
Steam's lobby list by default will return the nearest games to you. It isn't region locked however, we've accepted game invites from people half way around the world.
Tanooki Apr 5, 2013 @ 1:33pm 
The issues I see in the game I played a 4v4 all players were <200 ping, it worked ok, not great, but did not affect gameplay, was easily able to pull boar, build, at the beginning. The biggest thing I noticed was scrolling seems a little slow, but it continued to slow down gradually over time, at about 30-35 minutes it was very difficult and frustrating to play, trying to do things like grab a vil and build several houses quickly, or clicking on several buildings to create units would cause the game to respond very slowly, it'd do what I say, but I'd finish clicking to build houses, and watch for the next 30 seconds or so as they show up, which was quite frustrating, as I'd have to try to slow myself down, or remember what I did. If I did things in one area, this made it impossible to switch back to the area where I was being attacked to move my units.

Windows 7, i7 quad core, 16GB RAM, SSD, ATI 6670 so I don't think it's my computer. Hoping to get some people over to try on a lan and see if it works better tonight. Very excited about the game, hoping the lag issues are resolved quickly, but have yet to see a game that doesn't have some problems on launch.
[W4]SchakL Apr 5, 2013 @ 1:33pm 
I wanted to play a 3-player game with two friends. But we can't start a Multiplayer Match. They can join the lobby but game hangs in loading screen. If someone quits while loading screen by ALT+F4 (it doesn't matter who, except the host) the game starts normally and the two remaining players can play. Starting only a two-player game works with everyone.
Showing 1-15 of 630 comments
< >
Per page: 15 30 50