MS Ryz0n  [developer] Dec 5, 2013 @ 10:49am
Patch 3.1 Sync Discussion
Updated 12/12

We've pushed a recent update to address some sync issues players have been experiencing, as well as add additional logging to further identify remaining issues. Please see the following thread to identify and paste your steam OOS log.
http://steamcommunity.com/app/221380/discussions/0/648814300375679739/
Last edited by MS Ryz0n; Dec 12, 2013 @ 11:32am
Showing 1-15 of 62 comments
< >
Sir Jasper Trund Dec 5, 2013 @ 11:26am 
Experiencing OOS in under a minute every time under the following circumstances:

- The Forgotten active
- Unranked, no spectator lobby set to 'Friends filter'
- 2-3 human players, 1-2 AI set to Moderate or Hard
- Humans team 1, AI Team 2
- At least one of the Human players using a new civ (generally Italians or Slavs), and another using Base civ (generally Teutons). Incas sometimes in play for third player.
- AI civ set to Random
- Black Forest, Coastal or Lombardia
- Map size giant
- 200 pop cap
- No treaty
- Conquest victory
- Teams not locked
- Team Together active
- Record game not active (see below)
- Game speed: Normal
- Starting Age and Resource both Standarrd/Normal

With the *exact* same settings, but with 'Record game' ON, we have been able to play an entire game (2-3 hours) on more that one occasion. Tested this multiple times on multiple occasions, before and after today's patch. Have seen other players reporting this, and some saying this does not work for them. Possibly it's to do with having AI in the game?

Same OOS problem does not occur when playing HD Edition only.

Any light shed on this would be great, thanks.
Last edited by Sir Jasper Trund; Dec 5, 2013 @ 11:32am
GodsKnight Dec 5, 2013 @ 11:57am 
Its not the settings, ive tried everything, ive dont really close area matches. and worldwide.. I've done all the settings i can think of. I can play DM and CS games, but i cant play RM games :(
-Dare Devil/x/ Dec 5, 2013 @ 1:31pm 
Originally posted by GodsKnight:
Its not the settings, ive tried everything, ive dont really close area matches. and worldwide.. I've done all the settings i can think of. I can play DM and CS games, but i cant play RM games :(

-RM is a setting. This is helpful!
Aztek Paladin Dec 5, 2013 @ 2:14pm 
@Sir Jasper Trund

Thanks for all the info. I know you've provided almost all the info in the game settings, but can you please post a screen shot as well? :) You can take screenshots in Steam with F12 (however, this also brings up the save game dialog by default, so you have to make sure you change the save game hotkey mapping)

Also, what languages do you and your friends play in?

Thanks so much,
Aztek

-Dare Devil/x/ Dec 5, 2013 @ 4:31pm 
-Hey mate, here are my settings.

-Out of sync in less than five minutes (ws about to get boar).

-Vanilla.

-http://i44.tinypic.com/szgykz.png.
Last edited by -Dare Devil/x/; Dec 5, 2013 @ 4:31pm
RAWRINGTIGER Dec 5, 2013 @ 8:40pm 
Out of Sync within 4 mins into the game of the forgotten expansion.
It actually came up with a box saying something along the lines of one or more players [Rawringtiger] has gone out of sync.

2vs2 Regular match with 3.1 patch. I was playing as Incas. Record game, locked teams were checked. Game speed normal.
I'm running on a Dell XPS
Windows 7 Home Premium OS 64-bit SP1
Intel Core i7-2600 CPU @ 3.40GHz, 8.0 GB RAM
Nvidia Geforce GT 530

Last edited by RAWRINGTIGER; Dec 5, 2013 @ 8:41pm
MasterCD Dec 5, 2013 @ 9:54pm 
OOS HDFE about 2 minutes in. Giant 8player all human black forest. Every game since 3.0 I was having OOS. Heres a sync log from the most recent game, I'm p7:

http://pastebin.com/gWiAVtiu
Sir Jasper Trund Dec 6, 2013 @ 12:16am 
Originally posted by Aztek Paladin:
@Sir Jasper Trund

Thanks for all the info. I know you've provided almost all the info in the game settings, but can you please post a screen shot as well? :) You can take screenshots in Steam with F12 (however, this also brings up the save game dialog by default, so you have to make sure you change the save game hotkey mapping)

Also, what languages do you and your friends play in?

Thanks so much,
Aztek

Willl do so this evening, thanks. And we're all playing in English.
[GoH]Aurelius Dec 6, 2013 @ 2:05pm 
Maybe I am way late about this, and you have known this for weeks, but I just want to point it out:
- Everyone I know who has had Sync-issues have been able to solve them by unsubscribing all their mods from the workshop, verify the game cache, and then reinstall the ones they want.

There might be other causes to, but this solved it for the guys I've been playing with.

EDIT: And I am NOT talking about weird mods that should crash the game, I see that you have added some check for that. I am talking about mods like ♥♥♥♥♥wood and grids, that shouldn't affect other players at all.
Last edited by [GoH]Aurelius; Dec 6, 2013 @ 2:08pm
tangibleLime Dec 6, 2013 @ 5:23pm 
I suggest that, to help combat the out-of-sync problems, have the game write out to a file a bunch of information about the game and its environment/settings when the out-of-sync occurs. This could be anything from match settings, to internal variable values, to what operating system is being used. This would allow us to simply paste the conetns of that file and instantly provide more details than we would normally be able to.
Last edited by tangibleLime; Dec 6, 2013 @ 6:11pm
jakuppetur Dec 6, 2013 @ 6:10pm 
As thrilled I am about playing the game again (just bought it a few days ago), I'm really sad that it runs this poorly. I've even got 5-6 friends to buy it as well, and we've been playing some games together. We've all got new computers, good connections, and can play any games together. But this game lags terribly, SO many OOS (seems even worse after 3.1, we only managed to finish one game (a 2v2) out of 5-7 tries. And that game really, really lagged. Would be so nice to get a working version out? Or just playable?
MS Ryz0n  [developer] Dec 6, 2013 @ 6:30pm 
Originally posted by Lime:
I suggest that, to help combat the out-of-sync problems, have the game write out to a file a bunch of information about the game and its environment/settings when the out-of-sync occurs. This could be anything from match settings, to internal variable values, to what operating system is being used. This would allow us to simply paste the conetns of that file and instantly provide more details than we would normally be able to.
We regularly have advanced dev builds for testing purposes, however some of the logging requires some debugging content we can't push to release builds. But yes you are thinking along similar lines to us, the process isn't just always as simple as we'd like :)
DutchSoldierBoy95x Dec 7, 2013 @ 1:49am 
I tried all the fixes on the internet but I can't play any RMs, I will get an OOS after about 2-4minutes.

This started for me about 1-2 months ago, before that I used to play a lot of RM's.
Last edited by DutchSoldierBoy95x; Dec 7, 2013 @ 1:50am
Eagle King Dec 7, 2013 @ 1:53am 
Last day I got OOS <10sec of every game.. Googled it said to verify my game catch witch didn't work and my game was fixed only when I deleted my local files and installed the game again.
DutchSoldierBoy95x Dec 7, 2013 @ 2:13am 
I tried verifying and deleting my game files about 5+ times and still doesn't work.
Showing 1-15 of 62 comments
< >
Per page: 15 30 50
Date Posted: Dec 5, 2013 @ 10:49am
Posts: 62