boothdom Jun 10, 2013 @ 12:40am
Achievements not unlocking
Hello there! First post on here so bear with me...

I'm about 75% through this game (and loving it btw) but I haven't had a single achievement pop. I'm pretty sure I've been collecting all the level specific ones and I think I've jumped a tonne, so it seems really odd to have nothing. Also the counter seem a bit odd too. The main game progress one is showing 100/100 and I think I'm only on level 75ish.

Looking through the forum here I found one other person with this issue, but there wasn't really a solution, and it was quite a while ago...

I've submitted a ticket to steam to see if they know anything about it, but I thought it wouldn't hurt to ask here too.

Any help will be greatly appreciated.

Thanks,

Dom
Showing 1-15 of 34 comments
< >
boothdom Jun 11, 2013 @ 4:26am 
No one? :(

I've finished the game now and it's still showing 0/35. Heard nothing back from steam either.

Shame.

Thanks,

Dom
Last edited by boothdom; Jun 11, 2013 @ 4:26am
SkAyt3r Jun 12, 2013 @ 1:40am 
Having the same problem, finished the game and found a bunch of the diamonds hidden in the levels, but the achievements still show 0/35
Rudie Jun 12, 2013 @ 8:41pm 
Same here. I've finished the game and found a couple of the diamond things but no achievements.
Last edited by Rudie; Jun 12, 2013 @ 8:41pm
Padicus Jun 16, 2013 @ 7:42am 
I had the same problem but one day all the achievements I should have gotten showed up. Now I'm pretty sure I finished 100% of them but I'm still missing the ones I got after the first bunch.
Tricky Ninja Jun 16, 2013 @ 1:06pm 
all of the achievments showed up for me from day one
psyfive Jul 25, 2013 @ 10:38pm 
I just finished the game. Great game by the way. But I'm still getting a 0/35 achievements. It's pretty annoying, but oh well I enjoyed the game.
/LGND Aug 2, 2013 @ 7:48pm 
i have the same problem, achievements such as the jumping achievement and game completion achievement wont register i have 3/35 i don't understand why i cant get them.
atomos.pro Aug 18, 2013 @ 11:07pm 
same problem. i think achievments mechanism is broken :(
Webhuck Aug 20, 2013 @ 8:32am 
I started getting them, but now I'm not. Even my "played" time isn't showing the last 2 days of play. According to my profile, I didn't play yesterday or the day before (where I cleared 2 levels).
Chris Aug 21, 2013 @ 6:21pm 
How is this still broken?
atomos.pro Aug 22, 2013 @ 2:54am 
Originally posted by Chris:
How is this still broken?
yep.
autom8on Aug 25, 2013 @ 4:33am 
I'm seeing the same problem here. Got lots of the level-specific achievements - but steam is showing 0/35 overall. All the jump-related ones are showing as 0/X. It's weird - 'cause the level specific ones are showing as 1/1 even for levels I haven't done yet. Have gone back and re-played earlier levels to confirm that the collectables aren't there any more. Tried uninstalling and reinstalling at the advice of a friend - but that made no difference at all. Have played multiple sessions all of which I was definitely online for (as I was chatting with friends). Not sure what else to try - is this just fundamentally broken, or is there some trick I'm just missing to get the game to register them? Is this something to do with getting the game through humble-bundle rather than buying it off steam directly??
Trade-01 Aug 25, 2013 @ 4:48am 
Same here, achievements don't work. Got the game from Humble Bundle.
92Arash Aug 25, 2013 @ 6:03am 
I too had this achievement-problem. After playing the game for a while and unlocking several achievements, I notiticed that Steam did not show my progress.
A simple restart of the Steam-Client (log out, close steam, re-open steam, log in), solved this problem for me! :)

I hope this will work for you guys as well. Let me know. ^^
autom8on Aug 25, 2013 @ 9:23am 
Originally posted by 92Arash:
I hope this will work for you guys as well. Let me know. ^^
Nope - still no joy here. Logged out, restarted client and logged back in - and still the same thing. Played the game for another 20 minutes and found another one of the in-game achievements - but it still isn't updating. I too bought the game via Humble Bundle - and also have it on the PS3 (not that I think that is in any way relevant to the achievement issue).

Anyone else got any ideas??
Showing 1-15 of 34 comments
< >
Per page: 15 30 50