Mechanic Centipede May 31, 2013 @ 5:59am
Game crashes constantly on Win7
I've already played 5 times. The game will let me play for 2-5 levels, then freeze and then crash. Anyone getting the same prob?
Showing 1-15 of 19 comments
< >
Aimath May 31, 2013 @ 8:57am 
+ I have the same problem on Win 7 64 - GF 560. Game crash from 2 to 10 minutes after I start
Lupus Inculta May 31, 2013 @ 11:11am 
I get the same problem. The game crashes 2 - 5 minutes after I start it.
Jak May 31, 2013 @ 11:23am 
Same problem here. The crashes after a few minutes of playing.
Shinooby May 31, 2013 @ 11:31am 
In the same boat. Win7 and I get the error message "GetThreadContextFailed"
Last edited by Shinooby; May 31, 2013 @ 11:31am
calebnray May 31, 2013 @ 11:43am 
I think the developers are trying to work out this bug soon. For right now, the only solution is to set the game to compatibility mode for windows 98/window ME. Find the executable for the game by going into the folder for the game (C drive, program files (x86), Steam, steamapps, common, thomaswasalone folder). Right click on the app, go to properties. In the compatibility tab, select the option for windows 98/windows ME and click apply. After you do that you can play the whole game through steam without errors. The only difference you might notice is that the audio might be glitchy when loading levels (very minor).
toddestroy May 31, 2013 @ 12:16pm 
I'm having the same error, also Windows 7
Chadream Jun 1, 2013 @ 2:07pm 
Oh man, this sucks, this game seems to be very good but I can't play it properly D:
Jak Jun 1, 2013 @ 5:04pm 
The compatibility trick works for me, thaks.
Mechanic Centipede Jun 2, 2013 @ 11:40am 
Originally posted by calebnray:
I think the developers are trying to work out this bug soon. For right now, the only solution is to set the game to compatibility mode for windows 98/window ME. Find the executable for the game by going into the folder for the game (C drive, program files (x86), Steam, steamapps, common, thomaswasalone folder). Right click on the app, go to properties. In the compatibility tab, select the option for windows 98/windows ME and click apply. After you do that you can play the whole game through steam without errors. The only difference you might notice is that the audio might be glitchy when loading levels (very minor).

Thanks, it's good to know they're working on it. And thanks for the trick too
Krang Jun 2, 2013 @ 4:34pm 
I had the same problem and compatability mode didn't help, I did find that setting the affinity to 1 core on launch fixed it for me.
Michael Jun 4, 2013 @ 11:27am 
I've got the same problem too.
Steeve Jun 5, 2013 @ 11:28am 
Mine seemed to freeze/crash only when the blocks got stuck on the side of a wall or something similar.
Dmeyez Jun 5, 2013 @ 11:31pm 
Thanks compatibility mode worked for me
Pink gun Jun 6, 2013 @ 7:05pm 
same problem here, gonna try out that compatibility thing thought. If you dont hear from me again that means im to busy playing the game!
Zaso Jun 8, 2013 @ 8:05am 
Originally posted by scarletdragonfist:
I had the same problem and compatability mode didn't help, I did find that setting the affinity to 1 core on launch fixed it for me.
Worked for me! Thank you!
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: May 31, 2013 @ 5:59am
Posts: 19