SamBlueBox May 29, 2013 @ 9:58am
Fatal Crash on Windows? "GetThreadContext failed"
THe game keeps crashing randomly and keeps telling me "GetThreadContext failed".

Does anyone know how to fix this ive already redownloaded and changed some settings to see if it would fix it. Please help.
Showing 1-11 of 11 comments
< >
Captn Failbob May 29, 2013 @ 10:04am 
Workaround by Mike Bithell [developer] 3 hours ago
"Yep, interim solution (until Unity fix) is to turn on Win Me / 98 compatibility mode for the game executable :) "
Z3R0CO01 May 29, 2013 @ 11:15am 
This is the same problem I'm running into :/
Captn Failbob May 29, 2013 @ 11:20am 
Hellooooho, the solution is RIGHT ABOVE YOUR POST. Geez...
Z3R0CO01 May 29, 2013 @ 11:23am 
I was coming back to thank you for it actually working. You don't need to be rude about it.
Captn Failbob May 29, 2013 @ 11:43am 
Sorry for that :) Have fun with the game, its excellent.
BrutalBourn3 May 29, 2013 @ 1:44pm 
When is this Unity fix going to happen?
SamBlueBox May 29, 2013 @ 3:50pm 
Thank you so much. :)
Thomas_杨 Jun 1, 2013 @ 5:47pm 
Same problem, and thanks a lot : )
Gabi1239 Jun 21, 2013 @ 2:16pm 
Originally posted by Captn Failbob:
Workaround by Mike Bithell [developer] 3 hours ago
"Yep, interim solution (until Unity fix) is to turn on Win Me / 98 compatibility mode for the game executable :) "
How do you do that?
Styxx Jun 22, 2013 @ 3:59am 
Here's the solution:

Right click the game in steam.
Click "Properties" from the drop down (last thing to click).
Click the "Local Files" tab.
Click "Browse local files.
Right click the "ThomasWasAlone" executable.
Click "Properties" from the drop down menu.
Click the "Compatibility" tab.
Check the box that says "Run this program in compatibility mode for:"
From the drop down, select "Windows 98 / Windows Me".

No more error. The game will have short spurts of lag, but at least you can play it without quitting every two levels.
Gabi1239 Jun 22, 2013 @ 4:29am 
Originally posted by Styxx_N_Stones:
Here's the solution:

Right click the game in steam.
Click "Properties" from the drop down (last thing to click).
Click the "Local Files" tab.
Click "Browse local files.
Right click the "ThomasWasAlone" executable.
Click "Properties" from the drop down menu.
Click the "Compatibility" tab.
Check the box that says "Run this program in compatibility mode for:"
From the drop down, select "Windows 98 / Windows Me".

No more error. The game will have short spurts of lag, but at least you can play it without quitting every two levels.
I Absolutely love you! Thanks!
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: May 29, 2013 @ 9:58am
Posts: 11