Mike Bithell  [developer] May 29, 2013 @ 6:55am
Note from Dev: Linux bugs
Hello folks,

So.. this is my first Linux release, and I'm learning a few lessons about the fun of crazy distros :)

There's good news and bad news.

Good news is that I'm dedicated to fixing as much of this as I can guys. I use Unity middleware, so that limits my capacity to do certain things, but I'll do what I can, and get Unity to fix the rest.

Bad news is that I'm away from my Linux machine for a couple of days, so my capacity to fix is limited. I'd suggest anyone on the fence about buying Linux Thomas waits for me to get back and sort it out, and I apologise to those I'm keeping waiting.

Thanks, and please feel free to comment with any issues you're finding, and I'll add them to my list. We'll get there, and thanks for your patience.
Showing 1-15 of 65 comments
< >
A duck! May 29, 2013 @ 8:36am 
For some reason the music kept playing as I progressed from one chapter to the next. By the end, it was a horrible cacophony of overlapping tones as the game played pretty much all the tracks at once. Relaunching fixes this.

Once or twice going through the shifters didn't work.

The collision detection is broken in places - you can sometimes press your quadrilateral against a side of a moving surface which renders him immune to gravity (not that I'm biased against those whom gravity affects in different ways. Sorry James).

Archlinux x86_64

Thomas was alone is pretty good, although I must say, the puzzles quickly became more tedious than challenging and the only thing keeping me from quitting was the excellent narration. There is so much character in these tiny rectangles and the writing really shines there.

Thanks for bringing Thomas to linux!

Oh, one more thing: wouldn't it be better if switching between the rectangles moved the focus to the previous/next one along the X axis instead of on the fixed, predetermined list? The current implementation was bearable as long as the protagonist were colorful; when the game introduced the gray set of rectangles, the legend in the lower right corner ceased to be helpful in any way.

I played with the xbox pad and had the switch character buttons assigned to left/right bumpers - it really irks we the wrong way when after pressing the left button, camera jumps to the right. But this spatial disconnection might be just a gamepad thing.
Last edited by A duck!; May 29, 2013 @ 8:54am
ODDity May 29, 2013 @ 9:33am 
Hi Mike, top class entertainment this one and your hanging out here to answer questions is a nice touch, thank you.

Only thing that affected me was the Dual monitor "bug" where it started on the right hand monitor half way out the screen so, could not get to the options to make it windowed. Perhaps simply making it start windowed by default could be an option if this is a Unity bug that can't be solved by some other simple means.

this was solved for me and others by dash.Koscum in other thread.

manually edit the "prefs" file that is located in "~/.config/unity3d/Mike Bithell/Thomas Was Alone/". setting "Screenmanager Is Fullscreen mode" to 0 and using whatever values are the best for "Screenmanager Resolution Height" and "Screenmanager Resolution Width".

Thank you for being awesome, keep it up champ.
Last edited by ODDity; May 29, 2013 @ 9:36am
julroy67 [FR] May 29, 2013 @ 9:50am 
Hi Mike,
Nice to keep linux gamers informed and really nice job. The game runs really great, but as far as I know, the only bug I saw is that the mouse pointer doesn't fade away, I have to put it at the border of the screen to enjoy the game. Hope you can make something.
Ozymandias May 29, 2013 @ 10:57am 
Just wanted to say thank you for both an amazing game, and for doing an amazing Linux port. Most games steal my keyboard and don't want to support my monitors correctly, but yours worked perfectly without any user intervention. Great job! (Archlinux x86_64 w/ DWM)
Last edited by Ozymandias; May 29, 2013 @ 10:57am
izimsi May 29, 2013 @ 11:24am 
I've got a doublescreen setup, and the game launches just on the second screen and shows a half of the game. It's unplayable.
Dangerous Beans May 29, 2013 @ 12:41pm 
Small detail: Changing the screen resolution does not work for me. It does not offer any options except the native resolution (1080p). Switching between fullscreen and window mode works, but any attempt to change the resolution changes back to fullscreen. Manually editing the config file did the trick.

Thanks for bringing this beautiful game to Linux!
Saeblundr May 29, 2013 @ 8:05pm 
i wanted to play this game so much, but i had forgotten that i did ... humble bundle 8 meant i grabbed it instantly, and linux support means that i will be playing through it in a week worth of lunchtimes, savoring the fantastic script and voice acting.

I problem i have noticed, ESC always exits the game, no pause menu. quite frustrating, instinct is to hit escape when someone interrupts me ... thankfully rerunning the game and pressing 'Resume' takes me back to the level i left off.
d10sfan May 29, 2013 @ 10:24pm 
This game has issues with dual monitors on Linux for me. It keeps setting the resolution to 3600x1080, which I'd rather it be 1920x1080 (my first monitor). Changing the config file had no effect
J. May 30, 2013 @ 7:59am 
Right at the end, when the cutscene thing plays, the music volume is at 100% even if you set it lower.
Kppqju77 May 30, 2013 @ 9:14am 
Thanks ODDity for the tip with the screen resolution!
Works like a charm with my archlinux X64 dual head setup and XFWM!

d10fan : have you changed Screenmanager Resolution Width & resolutionWidth?
This did the trick for me.
Last edited by Kppqju77; May 30, 2013 @ 9:18am
Gecks May 30, 2013 @ 9:50am 
Jus wanna say thanks for a great game with some brilliant dialogue:D also nice Han solo voice btw #mikebithell
Last edited by Gecks; May 30, 2013 @ 9:51am
Koscum May 30, 2013 @ 10:07am 
Aside from the display/resolution issue on multi-monitor setups, which is really just a Unity3D bug, I only have the one where game exits when Escape key is pressed. It isn't game breaking, but it was annoying when I had to restart the game just so I could reset or change a level.


~~~~

I did some more testing on changing resolution through config and it seems that the hack around the issue that worked for Splice only partially applied to Thomas Was Alone. The trick is that there are two independant flags for fullscreen mode, as well as two independant values for both width and height. "Screenmanager Is Fullscreen mode" controls whether or not the game runs in fullscreen mode (on GNOME Shell, which I use, this is actually a borderless, top-level window in native resolution), but "fullscreen" flag further down in the config determines how it actually runs in fullscreen mode. If "fullscreen" is set to to 0, the game will render everything in 800x400, but that will be stretched to whatever's the resolution of primary monitor is.
Contrary to what I originally wrote, "Screenmanager Resolution Height" and "Screenmanager Resolution Width" don't seem to be playing a major role at all here (at least not the one that I can see on Debian 7 with GNOME Shell 3.4). If the "fullscreen" flag is set to 1, "resolutionHeight" and "resolutionWidth" fields near the end of config kick in and determine the size of the rendered area, This is where things get interesting, mostly because of the way displays and resolutions seem to be handled in Unity 3D.
I tested quite a few resolution combinations, where some provided some rather weird results (and not so weird if you do all the math behind them), and came to the following conclusion:
1) Make sure that "resolutionWidth" is not greater than the primaty monitor's width unless you want to play on another sceen and your desktop environment lets you move fullscreen apps between monitors (GNOME Shell does support this, but, again, this seems to be true because it looks like it's treated as a window in native resolution). I'd get into what happens if you exceed native resolution, but this is long enough as it is.
2) Make sure that "resolutionHeight" is native height as well. If it's less than native monitor height, but still greater than "resolutionWidth" / 2, the game will be stretched vertically. If you make it less than "resolutionWidth" / 2, the game will be vertically stretched to monitor native, and squeezed horizontally to maintain "resolutionWidth" : "resolutionHeight" = 2 : 1 ratio. If you make it greater than monitor native height, the game will be offset vertically.
Setting "Screenmanager Is Fullscreen mode" to 0 will enable windowed mode, but "fullscreen" flag still affects it. If it's set to 0, the game will always run in 800x400 window (at least it did for me; "Screenmanager Resolution Height/Width" had no effect for me here after all). Setting "fullscreen" to 1 allows you to use "resolutionHeight" and "resolutionWidth" to control the window size. As far as the behaviour goes, pretty much the same rules apply as with fullscreen mode, except it will resize the window to maintain the 2:1 display ration as close as desktop environment allows it to.

So, TL;DR version:
- "Screenmanager Is Fullscreen mode" toggles between fullscreen and windowed mode.
- "fullscreen" allows setting custom resolution/window size.
- "resolutionWidth" determines horizontal resolution in fullscreen mode and width in windowed mode.
- "resolutionHieght" determines vertical resolution in fullscreen mode and height in windowed mode.
- Try to keep the between 2:1 and whatever your monitor's native aspect ratio is, and don't make them greater than actual resolution of your monitor.
-
Last edited by Koscum; May 30, 2013 @ 11:08am
neph May 30, 2013 @ 11:53am 
Originally posted by dash.Koscum:
Aside from the display/resolution issue on multi-monitor setups, which is really just a Unity3D bug...
Nope, also a problem on KDE with KWin and LightDM...

Dangerous Beans May 30, 2013 @ 12:01pm 
Originally posted by neph:
Originally posted by dash.Koscum:
Aside from the display/resolution issue on multi-monitor setups, which is really just a Unity3D bug...
Nope, also a problem on KDE with KWin and LightDM...

Unity3D is the game engine used to build Thomas Was Alone, not Ubuntu's desktop environment.
harpaj May 30, 2013 @ 12:27pm 
Thank you so much for bringing Thomas and his friends to linux!
The game works nearly flawlessly on my Ubuntu PC. The only problem I noticed is the "Escape"-Button one people reported above.
Showing 1-15 of 65 comments
< >
Per page: 15 30 50