rusby_h Dec 16, 2012 @ 12:28pm
GIANTS Engine stopped working
Basically, everytime I start up Farming Simulator 2013 the program stops working and the error message "GIANTS Engine stopped working" appears. Any help would be appreciated! Thanks in advance
Showing 1-13 of 13 comments
< >
buggsbmw3000 Dec 16, 2012 @ 2:19pm 
Go to http://farming-simulator.com/ and repot this in the tech support forum Giants want to know about ANY big problems like this for the next patch!!!
BongoSableGmail Jun 24 @ 2:07pm 
I have tha same problem and I did repored it, but they haven't reply me for 3 days yet... :/
Thaltrad Jun 24 @ 4:39pm 
You might want to check your My Documents/my games/farmingsimulator2013/log.txt to see if there are any errors to be found.

It also wouldn't hurt to reinstall/repair your DirectX9 (it could be that some files are corrupted). You can find this in /your steam folder/steamapps/common/farming simulator 2013/dxsetup/

If you have installed any mods you might want to backup and remove these from your mod directory.
BongoSableGmail Jun 25 @ 2:35am 
I don't have any mods, cause I never have launched this game succuesfully :/

I was trying to solve this by doing the followings:
1. Completly deleting my Graphics Card drivers
2. Installing drivers to Graphics Card from CD, which was given by producer of this card
3. Installing latest drivers to Graphics Card from nVidia site
4. Installing latest DirectX drivers (DirectX 11) + this one from game folder
5. Reinstalling the game, on different hard drive partition
6. Changing resolution and some of options by editing "game.xml"

My computer specyfication:

Motherboard - GA-970A-DS3
Graphics Card - gigabyte nvidia GeForce gtx 650
Processor -AMD Phenom II x4 965 (4x3,4Ggz)
Power Supply - OCZ 550W ZS series
OS - Windows 7 64bit


What is interesting - the game runs on my previous computer with worse components and on my friends computer, who have the same Graphics Card that I have.

I was either trying downloading pirate, cracked copy of this game from internet (Farming simulator 2013 + titanium) and... it runs without any problems... Please help me to solve this problem. There is my log file:


GIANTS Engine Runtime 5.0.1 (build date: Mar 31 2014)
Copyright (c) 2008-2012, GIANTS Software GmbH (www.giants-software.com), All Rights Reserved.
Copyright (c) 2003-2012, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: FarmingSimulator2013
Main System
Cpu Name: AMD Phenom(tm) II X4 965 Processor
Cpu Core(s): 4 @ 3.4 GHZ
OS: Windows NT 6.1 64-bit
Physics System
Driver: NVIDIA PhysX Runtime
Version: 2.8.4
Thread(s): 2
Input System
Keyboard enabled
Mouse enabled
Gamepad/Joystick disabled
Force Feedback disabled
Sound System
Driver: OpenAL
Version: 1.1
Device: Generic Software
Max. sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 650/PCIe/SSE2
Version: 4.4.0
max_texture_layers: 8
OpenGL initialization successful
Hardware Profile
Level: Low (forced)
View Distance Coeff: 0.750000
Shadow Quality: 0.000000
Skip Mipmaps: 1
LOD Distance Coeff: 0.750000
Terrain LOD Distance Coeff: 0.750000
Foliage View Distance Coeff: 1.000000

I can't see any eroors
Thaltrad Jun 25 @ 6:17pm 
When you reinstalled, did you also remove the documents/my games/farmingsimulator folder?

Have you tried verifying game cache files?
Have you modified "game.xml" in your in your documents folder?
If you did, have you tried to set fullscreen to false?
Have you triend running FarmingSimulator2013Game.exe in administrator mode?
BongoSableGmail Jun 26 @ 12:19am 
1. I did it about 3 days ago, about 3 times and on different disk drive, and yes, I did removed this folder
2. Yes, it's saying, that it's ok
3. Please read my previous post, I did write about it.
4. Yes, no difference
5. Yes, I did and in addition, I tried FarmingSimulator2013 from x64 folder, as administrator and in compability mode too, all 3 files .exe of this game. Still not working :/
Last edited by BongoSableGmail; Jun 26 @ 12:20am
Thaltrad Jun 26 @ 6:06am 
Ok I am out of ideas myself. There is still one last thing you can try, which is to contact the support @ http://www.farming-simulator.com/contact.php?lang=en
BongoSableGmail Jun 26 @ 8:12am 
I wrote to the support, but they haven't reply me for one week yet. I lost my hope, that they will write to me anyway, but I still have hope, that I will fix that, or next patch will fix that error. Thank you for your help anyway :) If anyone have still have any ideas, please help.
Unforgiven Jun 26 @ 11:16am 
I dont know if you have any mods, but what I did when i got this error was goning trough the log file and delete all mods that had any sort of error. And now it works.
Log file: My Documents/my games/farmingsimulator2013/log.txt
Mods: My Documents/my games/farmingsimulator2013/mods
Last edited by Unforgiven; Jun 26 @ 11:16am
BongoSableGmail Jun 26 @ 11:19am 
I did write, that my game was just installed and I didn't add any mod yet, becouse I can't run it at all :(
BongoSableGmail Jun 30 @ 9:58am 
Hi everybody! I found a solution! :) Two days ago I bought Garry's Mod and have nearly the same problem - when I did run a game it says "Engine error" and stopped working. I was searching and I found a solution - which was closing the "Gigabyte OC Guru II" program. This did help me either with Garry's Mod and Farming Simulator 2013 too. Thanks to you guys, which was trying to help me, and please dont delete this topic, so that other people will find the solution too.
Thaltrad Jul 1 @ 5:35am 
Ah who would have guessed that OC Guru could cause problems. Well at least you're able to play now. Good for you. Don't forget to feed the
littlewonder46 Jul 1 @ 4:53pm 
im having the same problem it was working fine then all of a sudden it is quiting on me how do i find that to close it
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Dec 16, 2012 @ 12:28pm
Posts: 13