Far Cry® 3 > General Discussions > Topic Details
HOAX sandyhook Jan 24, 2013 @ 2:51am
Crossfire stutter.
Is anybody else getting stutter with crossfire enabled in this game?

Rig:
7850x2
3570k
8bg ram
Showing 1-8 of 8 comments
< >
Power Jan 24, 2013 @ 9:40am 
humor yourself and check out the 44 page long thread about the microstutter over at the ubi forums.......

http://forums.ubi.com/showthread.php/730854-Micro-stuttering-Forums

then notice how not one developer has bothered to even comment or acknowledged the problem exists........then do a google search on "far cry 3 micro stutter" and be greeting over 100 pages of results about it as well as lots of youtube videos about it.

If you purchased from amazon yesterday demand a refund, they will grant it. This game plays like garbage for pretty much everyone when on DX11.

I'm running it on 3 HD6970's in trifire and a 2600K at 4.8ghz....... absolutely unplayable microstutter, gives me motion sickness. Your only option is to lower every single setting to low, turn off crossfire and run in DX9.......that's the only way you will get any resemblance of a playable game and even then the micro stutter is pretty bad. This game was made to play at 30fps max on a console, that's all the devs care about, be sure to remember this the next time you consider supporting ubisoft with your hard earned dollars.
Last edited by Power; Jan 24, 2013 @ 9:45am
HOAX sandyhook Jan 25, 2013 @ 12:09am 
Originally posted by *FMJ*Power:
humor yourself and check out the 44 page long thread about the microstutter over at the ubi forums.......

http://forums.ubi.com/showthread.php/730854-Micro-stuttering-Forums

then notice how not one developer has bothered to even comment or acknowledged the problem exists........then do a google search on "far cry 3 micro stutter" and be greeting over 100 pages of results about it as well as lots of youtube videos about it.

If you purchased from amazon yesterday demand a refund, they will grant it. This game plays like garbage for pretty much everyone when on DX11.

I'm running it on 3 HD6970's in trifire and a 2600K at 4.8ghz....... absolutely unplayable microstutter, gives me motion sickness. Your only option is to lower every single setting to low, turn off crossfire and run in DX9.......that's the only way you will get any resemblance of a playable game and even then the micro stutter is pretty bad. This game was made to play at 30fps max on a console, that's all the devs care about, be sure to remember this the next time you consider supporting ubisoft with your hard earned dollars.
Thank you for your reply.
I did indeed get it from amazon. I'll take it up with their support.
I now know that its not my rig, but the game.
apixel1234 Feb 17, 2013 @ 1:41pm 
Like many with crossfire issues, I've been reading different things all over the place. Since this is the first discussion that comes out on steam, I just want to add my solution. If I buffer 2 frames ( on the setting before the GPU buffering ) I don't have any microstuttering. At first, this was leaving me at 30fps with all settings except AA maxed out. Then I read somewhere that I should run in windowed borderless mode instead of full screen, and sure enough, my average is now 50fps, up from the 30 fps. This is with CF 7850's.
HOAX sandyhook Feb 17, 2013 @ 2:06pm 
Originally posted by apixel1234:
Like many with crossfire issues, I've been reading different things all over the place. Since this is the first discussion that comes out on steam, I just want to add my solution. If I buffer 2 frames ( on the setting before the GPU buffering ) I don't have any microstuttering. At first, this was leaving me at 30fps with all settings except AA maxed out. Then I read somewhere that I should run in windowed borderless mode instead of full screen, and sure enough, my average is now 50fps, up from the 30 fps. This is with CF 7850's.
I have heard from a lot of places that crossfire is an issue with farcry 3. Buffering does help though.
I think what window borderless does, is it turns off crossfire. Because anything that is not fullscreen doesn't work with crossfire. I've tried borderless, but rivatuner says that the second card is at 0% usage, meaning crossfire is off.

This game is just really unoptimized for crossfire.
apixel1234 Feb 17, 2013 @ 9:48pm 
I doubt cf is off on borderless because I just got my second card a week ago and could not get those frame rates with all that buffering. But I guess I was always playing full screen on a single card. Either way, borderless seems to increase performance one way or another. No doubt something's up, though - as all other games are performing way better with cf.
apixel1234 Feb 17, 2013 @ 9:53pm 
You are right - no crossfire in widowed, but I definitely get better performance than full screen. Odd.
Burbs May 21, 2013 @ 6:50pm 
I had the same issue with 2x 7850s. Just decided to take one out and hopefully sell it to buy a single better card :/
HOAX sandyhook May 21, 2013 @ 7:38pm 
Lol, this is a 3 month old thread.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jan 24, 2013 @ 2:51am
Posts: 8