Far Cry® 3 > General Discussions > Topic Details
Mr.E Thaden Dec 26, 2012 @ 8:09am
Far Cry 3 crash on startup
I recently bought this game for $50 on Christmas and when it was done downloading i launched the game through steam, entered my cd key, clicked the play button in Uplay and after about 5-10 seconds of a black screen the game crashes and brings me back to the Uplay menu. Im hoping that this is just a bug and there trying to fix it but if anyone can help please do.
Showing 1-8 of 8 comments
< >
Burnt Sienna (Tmiller501) Dec 26, 2012 @ 8:31am 
Thank god someone else has this problem, i'm sorry but I can't really help, but just know you're not alone here.
Zakalwe Dec 26, 2012 @ 8:36am 
There are two .exe files in your main Farcry install folder. Try running each of these.
小微笑 De Chubby Chinese Man Dec 26, 2012 @ 8:41am 
I have the same problem D=
Zakalwe Dec 26, 2012 @ 8:43am 
Logic, did you read my post?
小微笑 De Chubby Chinese Man Dec 26, 2012 @ 8:45am 
I tried it, then it asks for the key thing and if i put mine in it says its already in use
Zakalwe Dec 26, 2012 @ 8:54am 
Did you try running it using each off the .exe files? There are two in the folder.
小微笑 De Chubby Chinese Man Dec 26, 2012 @ 8:55am 
Yes ive tried both and they do the same thing, it says its already in use because i used it when i opened far cry 3 from steam. But then when i launch Uplay normally non through steam it says i dont have far cry 3
Mr.E Thaden Dec 26, 2012 @ 10:01am 
I have tried launching from the other 2 .exe in the main far cry 3 folder and each one opens up uplay. The only problem is that each one asks for the key that i entered during the steam installation and when i enter it it says its invalid even though im on the same uplay account that the steam version is on.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Dec 26, 2012 @ 8:09am
Posts: 8