Far Cry® 3 > General Discussions > Topic Details
Gull Dec 24, 2012 @ 8:37am
far cry 3 has stopped working
someone has to fix this issue, "far cry 3 has stopped working" Always shows up at the start. ive tried everything on the inertnet and on this forum. i think it has something to do with a "d3d11exe" file. I have a nvidia gtx 570, intel core i7-960 3.20 Ghz, msi x58-gd45 motherboard, win7 64bit. i played the game 11 hours, then this problem occured, i think it came after the 1.04 patch was installed, but i have no way of telling if that patch is even installed. ive reloaded it numerous times. ive verified the integrity of the game cache-- each time i do that they download a file that doesnt solve the problem, and the file is downloaded each time i verify game cache.
Showing 1-15 of 20 comments
< >
J3BU5Z Dec 24, 2012 @ 8:44am 
Ive got the same issue i was able to play about 20 hours worth though until it crashed my computer and then this issue came up now i can't play it. This game has to many bugs
Zakalwe Dec 24, 2012 @ 8:47am 
Have you tried running it using the dx9 .exe in the main folder?
Zakalwe Dec 24, 2012 @ 8:51am 
I've played 23 hours, not one bug in single player so far. i5 2500k, gtx670, 8gigs ram, Windows 7 64. Aside from a single, brief moment where artifacts appeared, the game runs smoothly on very high settings.
J3BU5Z Dec 24, 2012 @ 9:12am 
ive tried pretty much everything possible updated my grahics card and all that stuff but still no
Mr.Cube Dec 24, 2012 @ 10:39am 
I have 40 hours in the game, same graphic card as you and 64 bit OS I didn't even crash once. Have you updated your drivers?
lamberta12 Dec 24, 2012 @ 7:38pm 
i have the same probleme i just create a discussion please help
Gull Dec 24, 2012 @ 11:57pm 
eternal core i tried the things on the ubi.com forum, none of them worked. i called the the number in the read me files and that guy told me it was a steam problem and that i should delete the steam program, which i foolishly did. do not delete ths steam program, it doesnt work and wastes time. i cant find the dx9.exe in any main folder zakalwe but if i do i give it a try. mr.cube my game was running too, the thing was working, and now its not. trying these suggestions on the forums is like playing russian roulette with my computer, i would prefer an expert from either ubisoft or steam to find out through research what the problem is and come up with a patch. ive played most recently dishonored, which gave me no problem at all at high settings. maybe ubisoft should do some quality assurance and stop letting the customer be their cleanup crew.
EternalCore Dec 25, 2012 @ 12:50am 
@Gull: Then Submit a Support Ticket here: https://support.steampowered.com/newticket.php
Gull Dec 25, 2012 @ 4:49am 
ticket submitted
Zakalwe Dec 25, 2012 @ 4:58am 
Gull, there are two .exe. The dx9 one is the one that doesn't have dx11 in the name. Not at my pc so can't show exact, but there are only two .exe files to choose from...

Just for some perspective, there are just as many people who had game breaking issues with dishonored. You're just one of the unlucky ones who has a conflict with Farcry, and it could easily be a problem with the way your hardware is set up.
Last edited by Zakalwe; Dec 25, 2012 @ 5:02am
pmumberson Feb 17, 2013 @ 8:31am 
Same here. Crashed my puter and now I get "Farcry 3 has stopped working" during the load screen for the game. Tried all of the above and no joy.
pmumberson Feb 17, 2013 @ 12:06pm 
Ok I got it working again by uninstalling uplay and reinstalling everything but its just crashed again. Played for a few hours then It crashes but not just a back to windows crash. Kills everything. As if the power had been turned off to my puter.
Gull Feb 20, 2013 @ 2:25pm 
Originally posted by pmumberson:
Same here. Crashed my puter and now I get "Farcry 3 has stopped working" during the load screen for the game. Tried all of the above and no joy.
what worked for me is this:
go to documents... go to My Games ... delete the far cry 3 folder
J3BU5Z Feb 25, 2013 @ 5:27pm 
http://gyazo.com/e13affa139db040b52753761be98f724

That is a picture of what i was told to do by the Ubisoft support guy. And that fixed my issue

Hope it helps.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Dec 24, 2012 @ 8:37am
Posts: 20