Far Cry® 3 > General Discussions > Topic Details
Jack_Sice Dec 14, 2012 @ 10:18pm
Far Cry 3 Freezes and Black Screen?!?!
When I launch the game it goes to UPlay and then play game I goes to far cry the it goes to a black screen?
I have an alienware laptop so I don't know why It's not working?
Showing 1-13 of 13 comments
< >
YouBaconMeCrazy Dec 18, 2012 @ 7:38am 
I have the same problem. I tried Ubisoft Support and it was like talking to a brick wall. Could someone please help? I spent $50 on this thing and it doesn't even work!
patrickrapson Dec 18, 2012 @ 2:34pm 
are you using the 12.11 beta driver, that caused my alienware to crash as well
FetteRobbe Dec 22, 2012 @ 4:02pm 
same here - I've found a simple workaround...simply press STRG+ALT+DEL and then ESC. Far Cry will launch in windowed mode. Now you may set it again into fullscreen mode in the options and have fun playing. Until you start it again *mad*
samgee500 Dec 27, 2012 @ 6:35pm 
Originally posted by KillDingeling:
same here - I've found a simple workaround...simply press STRG+ALT+DEL and then ESC. Far Cry will launch in windowed mode. Now you may set it again into fullscreen mode in the options and have fun playing. Until you start it again *mad*

hmm, I tried that but it dosent seem to go into windowed mode, the screen is still black. I also have an Alienware laptop. Mine is an m14x r1 i7 3gb gt 555m with the latest 310.70 nvidia drivers. I'm starting to get really annoyed, I payed $60 for this game and now I can't play it. I have the exact same problem with Far Cry 1, and Unreal Tournament 3: Black Edition. Far Cry 2 plays just fine though. If anyone can help us that would be awesome.
Black Jan 1, 2013 @ 8:50am 
I have the exact same issue!
The thing is, I torrented Far Cry 3 earlier in order to test if it would work on my PC, and if I'd like it enough to buy it - which I now have.

The torrent worked without flaw, So I know my Pc can handle Far Cry 3 excelently.
Now that I try to run it trough steam, it's the exact same thing as you guys - it won't even get to the f-ing menu... >.<
Black Jan 1, 2013 @ 9:15am 
And I was just about to try downloading Far Cry 3 via Uplay - but even tough I have redeemed my code, I can't find it in my game list
And any attempt in trying to access Far Cry 3 via their site = in no success...
Even as I try klicking on their "View all titels in the Far Cry Universe", I get Assasins Creed instead... >.<

Their services are pathetic, unstable and undependable.
Clear lack of knowledge and rushing their unfinished services just to try and compete with steam, which also have a decent amount of flaws, I might add!

It's fun how the game companies have less stability, then if I were to torrent their game - and yet they blame all the torrenters for playnig their games for free when we sometimes can't play them, using the services they provide...

I am gonna try and find a torrent and see if that will allow me to plug in my cd-key and play the game, rather then using steam or Uplay.
For right now I have spent enough hours trynig to find away to play a GAME THAT I HAVE PAID FOR, AND SPENDING HOURS SEARCHING FOR FIXES TO THEIR OWN PRODUCTS!

This is becomnig so bothersome, and also more frequent I am affraid. :(
I ate your fries :3 Jan 1, 2013 @ 9:24am 
what the heck is STRG+ALT+DEL? what is strgt key?
Black Jan 1, 2013 @ 9:45am 
@Masta Blasta
it's Ctrl-key for the german keyboard.
Cyfoz Jan 5, 2013 @ 5:26am 
NVIDIA FIX ONLY!


Oki try this out guys... i had the same problem on my computer...

First off all i have to let you know that i have to disable something called CUDA - GPUs on my Nvidia GeForce 570. to be able to play "All Points Bulletin" (if i dont the game might crash my rig, an i have to reboot)

but if you go into the Nvidia settings ---> 3D Settings ---> Global Settings ---> then on the list find CUDA - GPUs, it will pop up a little window showing all your grafic cards CUDA GPUs... if they are disabled for FC3 you might end up with a Black Screeen right after the first loading screen (before getting to the Menu)... Just enable that on all your grafic cards. or if that is already activated try disable it..

but then i finally got into the Menu.. i pressed Story... an i watched a movie i couldnt skip in any ways... the movie was playing with all sounds (Music,Voices an other sounds)... but then it kinda stopped an faded over into the game.. but all of a sudden i didnt have any Voices from anyone... i could only read a text of what they was saying.. but i could still hear music an other sounds. just not the voices.. so i exitted the game again. went into my sounds settings an reconfigured my sound card down from 5.1 channels --> to 2.0 channels ( 2 speakers only)


i launced the game... an this time it ALL WORKED...

i really hope this help out some of you guys..
Last edited by Cyfoz; Jan 5, 2013 @ 5:35am
samgee500 Oct 24, 2013 @ 3:48pm 
Hey guys, I solved the problem, at least for me. You have to have V-sync on by default or nothing will display on my laptop screen. It will however display on an external monitor without V-sync and that was how I was able to navagate the menus to set it to the default. I've had this same problem with Crysis 3 and Saints Row:The Third as well. Most games seem to work just fine without V-sync on my computer though.
Campkom Oct 30, 2013 @ 1:30am 
Ok
Nantes Jun 28 @ 11:44pm 
Sorry mods for thread necro, but I have a novel solution that will benefit those who find this thread using Google (which is my case also).

I have solved this issue by going to the UPlay settings and disabling the checkboxes (I imagine just the overlay one will suffice, but I disabled them all anyway). I figured their overlay was conflicting with Steam's.
Last edited by Nantes; Jun 28 @ 11:47pm
Showing 1-13 of 13 comments
< >
Per page: 15 30 50