DaveTheTentacle 2013. nov. 30. @ du. 11:22
Blank Black Screen at startup
I'm trying to play this on Mac and the game starts okay and reaches the main screen and plays music. However, as soon as the little steam icon pops up in the corner to says "press SHIFT TAB to access the steam community...", the screen goes blank. Music carries on but I can't click anywhere or press any keys. I then have to force quit the application. Weird thing is, if I find the app location on my disk and try to run it directly (not via steam) it works fine. Anyone know why this may happen?
111/11 megjegyzés mutatása
< >
Axe Cop 2013. nov. 30. @ du. 11:30 
FiftyPence eredeti hozzászólása:
I'm trying to play this on Mac and the game starts okay and reaches the main screen and plays music. However, as soon as the little steam icon pops up in the corner to says "press SHIFT TAB to access the steam community...", the screen goes blank. Music carries on but I can't click anywhere or press any keys. I then have to force quit the application. Weird thing is, if I find the app location on my disk and try to run it directly (not via steam) it works fine. Anyone know why this may happen?
Hmm that is a very random bug, Have you emailed anyone
http://www.youtube.com/watch?v=zgrPWh12msg
Filliokkus 2013. dec. 1. @ de. 7:30 
Same thing just happened to me on my macbook pro retina. Seems to a problem with the Steam Community In-Game.

Solution: Right click the game from your steam library, choose properties and uncheck the "Enable Steam Community In-Game" button.
Henrik_Englund  [Fejlesztő] 2013. dec. 6. @ du. 12:04 
Ohh, that something we have to look in to. Thanks for reporting.
elimagoy 2013. dec. 29. @ du. 6:16 
The same bug just happend tu me! on my macbook! great music anyways =) i hope there is a fix soon.
Zero Chan 2014. okt. 20. @ du. 5:43 
Another mac user here with the same problem. (MacBook Pro)
theowaern  [Fejlesztő] 2014. okt. 22. @ du. 12:19 
Hey guys, does the solution above solve your problem?
blitzbite 2014. okt. 30. @ de. 12:56 
theowaern eredeti hozzászólása:
Hey guys, does the solution above solve your problem?


Unfortunately for me no. I'm on Ubuntu Linux btw
plugz 2014. dec. 18. @ de. 4:40 
Same problem for me, seeing that the thread is one year old, I guess nothing was made to correct the bug, I suggest you don't advertise a game running on a mac, if it does not.
kingstone426  [Fejlesztő] 2014. dec. 18. @ de. 6:47 
Hey guys sorry for the slow reply, didn't notice this thread was back to life.

You appear to be experiencing the same problem that was discussed in this thread on the TJD2 board. It seems the dual-gfxcard settings on the latest line of MBPr causes problems for some applications.

  • Try turning off "Automatic graphics switching" in System Preferences (Energy Saver).

If that still doesn't help, I've found a number of other Steam games that have known problem on MBPr here, here, here and here.

Based on the resonse from those threads I recommend you:

  • Disable the Steam Overlay in game preferences.
  • Find the game in your mac and go right click -> get info. Check the "Run on low resolution"

Sorry for the hassle and thanks for helping me pinpoint this problem. I can't reproduce the black screen myself because I'm developing TJD on a dirt-old laptop :P

Legutóbb szerkesztette: kingstone426; 2014. dec. 18. @ de. 6:48
Sergey Bessarab ápr. 6. @ de. 9:15 
2015, OS 10.10.2 and the same problem... Switching off Steam overlay helped, but i thought it was only temporary solution...
bobsson máj. 16. @ du. 9:37 
I also had this or a very similar problem, but I'm on a old Mac Pro tower with a NVIDIA GeForce 8800 GT, not a laptop with integrated graphics.

There's another game I have a similar problem with (ToME), and turning off the Steam Overlay helped there. I'm about to try that here, and I'll update with the result. It helped here, too. No issues at all with the overlay off.
Legutóbb szerkesztette: bobsson; máj. 16. @ du. 10:15
111/11 megjegyzés mutatása
< >
Laponként: 15 30 50