World of Goo

World of Goo

View Stats:
World of Goo > General Discussions > Topic Details
Blootrix Dec 28, 2013 @ 5:34am
Guide to Changing Resolution (Updated with Mac Instructions as well)
Hello,

This is a simple guide on how to change your resolution, as the game does not allow you to do this from any settings menu.
(If you'd just like to change it to a Windowed Mode, then hold Alt and press Enter)

PC

-Right click on World of Goo
-Click Properties
-Click Local Files
-Click Browse Local Files
-Open "properties"
-Open "config" with notepad

-You should now see this. (Ignore the message left by the Sign Painter, it's there as a joke)

<!-- IMPORTANT WARNING: If you edit this file, your computer will probably explode. Your friend, the High Resolution Sign Painter -->
<config>

<param name="language" value="en"/>
<param name="screen_width" value="800"/>
<param name="screen_height" value="600"/>
<param name="refreshrate" value="60" />
<param name="ui_inset" value="10"/>

</config>

-Now change "screen_width" and "screen_height" to your resolution. 1080p would be

<param name="screen_width" value="1920"/>
<param name="screen_height" value="1080"/>

-I have two computers running this game, one at 1080p and one at 1440p and both are running fine.
Please post here if this worked for you.


MAC (Courtsey of Regi524)

1. Open a new finder window.
2. Goto your users folder.
3. Open 'Library' and find 'Application Support'.
4. Once in Application Support, find Steam.
5. Once in, goto 'SteamApps', 'common', 'World of Goo'.
6. RIGHT click on World of Goo.app(or just simply called World of Goo) and click "Show package contents".
7. Open Contents
8. Open Resources, game and then properties.
8. Open config.txt with textedit or another text editing software.

From this point on, refer to the PC guide.

Again, please post here if this worked for you.
Thanks.
Last edited by Blootrix; Jul 16, 2014 @ 2:26am
< >
Showing 1-15 of 64 comments
Prometheus Dec 28, 2013 @ 6:06am 
Had a black/flashing screen, because there was a conflict both with resolution and with refresh rate. This works.
[GO]Skywalker13 Dec 28, 2013 @ 6:45am 
Thanks for this guide but note that the bitmaps use a low resolution. It looks better with a low resolution but windowed.
Last edited by [GO]Skywalker13; Dec 28, 2013 @ 6:45am
Blootrix Dec 28, 2013 @ 7:34am 
Originally posted by GOSkywalker13:
Thanks for this guide but note that the bitmaps use a low resolution. It looks better with a low resolution but windowed.

I've been playing this at 2560x1440 and it looks fantastic. Although I've tweaked the colour settings of my monitor, so just about everything looks good.
nugget lmao Dec 28, 2013 @ 9:11am 
Thanks for this, worked like a charm. Is there any way to edit the config file to run it in a window, though? Still opens in fullscreen for me.
MadChicken Dec 28, 2013 @ 9:16am 
Thanks for the info Proxish!

At first i tried to change the resolution to 1920x1200, but with those settings i was missing a part of the screen on the right side.

Now i changed it to 1920x1080 and everything seems to work fine.
Last edited by MadChicken; Dec 28, 2013 @ 9:32am
Blootrix Dec 28, 2013 @ 9:22am 
Originally posted by Steelworker:
Thanks for this, worked like a charm. Is there any way to edit the config file to run it in a window, though? Still opens in fullscreen for me.

If you'd just like to change it to a Windowed Mode, then just hold Alt and press Enter.
nugget lmao Dec 28, 2013 @ 9:28am 
Originally posted by Proxish:
Originally posted by Steelworker:
Thanks for this, worked like a charm. Is there any way to edit the config file to run it in a window, though? Still opens in fullscreen for me.

If you'd just like to change it to a Windowed Mode, then just hold Alt and press Enter.
Welp, that worked. Didn't even think to try it (since a lot of games I try it with, don't work). Thanks!
Narayan Dec 28, 2013 @ 9:37am 
Thanks for this. The super low default resolution was a little annoying.

At first I tried 1920x1200 (cause that's my native resolution), but somehow the left and right edges were cut out. It was visible especially in menu when choosing the world, cause all the text on the right would be cut after the first half.

Then I switched to 1920x1080 and it looks fine now. Although strange, cause it's re-scaled for my 16:10 / 1920x1200 monitor. Anyway, much better than default, so thank you. :)
5UPP0RT- Dec 28, 2013 @ 10:21am 
Works.
CouizZz Dec 28, 2013 @ 3:17pm 
Doesn't work at 2560x1080 but fine at 1920x1080, thanks
BORN_TO_DIE Dec 28, 2013 @ 3:36pm 
thanks
TheGoatKing Dec 28, 2013 @ 10:35pm 
Thanks, working great @ 1440x900
PE4 Dec 29, 2013 @ 2:49am 
Quick question: if I change the resolution do I see more of the level?
Annie_CZ Dec 29, 2013 @ 5:37am 
Thank you, works fine :)
Blootrix Dec 29, 2013 @ 8:05am 
Originally posted by PE4:
Quick question: if I change the resolution do I see more of the level?

I've not tested it, I would assume not, but why not run a few tests and post back here and let everyone know?
< >
Showing 1-15 of 64 comments
Per page: 15 30 50

World of Goo > General Discussions > Topic Details