Half-Life 2 > General Discussions > Topic Details
Gman_ Sep 2, 2013 @ 1:10pm
HL2 keeps crashing
Okay. So I bought Half Life 2 a couple of weeks ago and I am loving it. But I have one problem, it keeps crashing in the chapter anticitizen one in the courtyard after the consoling couple. This has never happened before. I tried closing all background programs. I even turned down the graphics a bit.
There's no pop-up saying "HL2.EXE has shut down" so I can't provide a picture. Sometimes it just freezes for a couple of minutes or it just closes. I've been unable to figure out what the cause is. And I'm not even sure if it's just point in the game where it crashes or I got a limited amount of time before it crashes. So I hope you can help me fix it. And thanks.
Showing 1-8 of 8 comments
< >
Rubuck blocky hooves Sep 4, 2013 @ 12:05am 
I bought this game two or more years ago. Never got round to completing it...again. Played it on low and high PC hardware. Never had it had trouble with sound skipping, closing out of game, or suit zoom errors. Or what the other users on this forum said when that Half Life 2 update did this some time ago. Guess they never fixed it.

Edit
Hmm it didn't crash again, and the suit zoom thing stopped happening when I launched the game again.
Last edited by Rubuck blocky hooves; Sep 4, 2013 @ 1:14am
Rubuck blocky hooves Sep 4, 2013 @ 11:58am 
Right they have screwed this game up. Its crashed again. This time Windows said it crashed.
Gman_ Sep 4, 2013 @ 2:52pm 
Well I went around and searched awhile and found that I just need to restart the chapter. I'll try it and come back tell about the results.
Gman_ Sep 4, 2013 @ 3:00pm 
well I cant start at the beginning of the chapter i have to start at entanglement which is far too long to do again. I tryed loading up a save game nope that didnt work either. I'll try loading up other save games some time.
Rubuck blocky hooves Sep 4, 2013 @ 3:05pm 
They've screwed up the game files somewhere. Its their problem. Never have I had a save that would not load before.
Gman_ Sep 4, 2013 @ 3:31pm 
Okay i seemed to have fixxed i had to open a save rom Dr. Kleiners Lab so i wasnt too far from where i left off but I noclip-ed. I mean i already did the part why should i have to do it again?
So I'm gonna keep this thread open to anyone else who has this problem or until Valve fixxes it.
Good bye!
^1SS^8TopGUN Sep 4, 2013 @ 3:37pm 
go to properties in steam after right clicking half life and then click verify game cache should do the trick
Rubuck blocky hooves Sep 4, 2013 @ 3:38pm 
Originally posted by ^1SS^8TopGUN:
go to properties in steam after right clicking half life and then click verify game cache should do the trick

Nope.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Sep 2, 2013 @ 1:10pm
Posts: 8