Half-Life 2 > General Discussions > Topic Details
1singur Jul 17, 2013 @ 1:07pm
Problem: player moving slow
Across all Half-Life 2 games the player, or "Gordon", is moving too slow since a few days, and it's getting on my nerves. I tried the game and the episodes on various settings, and it's still slow across all axes, which is even when it jumps it kind of glides a bit. The other elements in the game work just fine, including the aim or weapon switch (which are releated to the player), but the enemies get the advantage of being faster than me on their normal speed. When sprinting, I get up to the regular walking speed, but still feels slo-mo.
Anyone having any idea as to what is this about?
Showing 1-15 of 31 comments
< >
Playa Jul 17, 2013 @ 1:26pm 
Use this command:
sv_alternateticks 0
Last edited by Playa; Jul 17, 2013 @ 1:46pm
1singur Jul 17, 2013 @ 2:05pm 
It works, but what happened? I'm on pc, btw, and I have a controller plugged in, but it is not enabled on the Mouse tab in game settings. This behavior is quite recent, probably caused by the conversion of the game files n a recent update.
Playa Jul 17, 2013 @ 11:39pm 
May config files have error after update. I'll downloaded HL2, HL2EP1 and EP2 after update and it works great (but at first run HL2 runs at dx8 mode, i fixed it already)
1singur Jul 18, 2013 @ 8:20am 
I run it in Dx81 anyway, because I have crappy video cards, so there's that.
Can that command be added to the game start-up shortcut? Or: if I redownload the game, will it be fixed?
And since you're the advanced user, I'll ask you something else: what's with some maps being all lighted up? I mean they make the game easier, but I feel like a cheater for it and it certainly kills the atmosphere. Most probably it's a hardware problem (GeForce FX5500, 256mb) and maybe running on -directx 81.
Playa Jul 18, 2013 @ 9:39am 
If you want to game auto-starts in dx8 mode and with normal movement speed, add this startup command: +mat_dxlevel 81 -sv_alternateticks 0.
Spookwagen is God Jul 18, 2013 @ 10:43am 
I looked and it helped me too thanks Jeka!
sarck0fag0s Jul 18, 2013 @ 11:30am 
how can i use the command? should i used in the console?
1singur Jul 18, 2013 @ 11:43am 
Originally posted by sarck0♥♥♥0s:
how can i use the command? should i used in the console?
it is better to modify the game shortcut, so you won't need to enter it in the console everytime. however, i think it might affect the jump (length and height).
sarck0fag0s Jul 18, 2013 @ 11:46am 
when i install the game i didn't make it a shortcut.
Playa Jul 18, 2013 @ 12:06pm 
Make it!!!
1singur Jul 18, 2013 @ 12:18pm 
You don't need to make a shortcut outside Steam, just modify the one in your games library. Right-click on Half-Life 2, select Properties at the very bottom of the menu, and in the first tab click on "Set Launch Options". Right there you'll have to paste the commands given above (you should Copy them from here first).
Note that the slow-movement bug affects all the games in Half-Life 2 series (and probably other Source games?). You'll have to enter the commands for each game separately. Fixing just Half-Life 2 this way won't fix the episodes, for example.
sarck0fag0s Jul 18, 2013 @ 12:21pm 
ok i'll try that, thank you.
Playa Jul 18, 2013 @ 12:22pm 
dont copy +mat_dxlevel 81, copy mat_dxlevel 95
1singur Jul 18, 2013 @ 12:43pm 
Originally posted by JekaPinsk:
dont copy +mat_dxlevel 81, copy mat_dxlevel 95

Since you are the "command-wizard" around here, do you know any command that would fix the Portal 2 problem? You can see it in my screenshots, basically a shader error, though my video card apparently meets the minimum specifications.
Last edited by 1singur; Jul 18, 2013 @ 12:44pm
Playa Jul 18, 2013 @ 1:02pm 
Portal 2 didnt support dx8, shaders will be buggy at you videocard
Showing 1-15 of 31 comments
< >
Per page: 15 30 50
Date Posted: Jul 17, 2013 @ 1:07pm
Posts: 31