Half-Life 2 > General Discussions > Topic Details
woop Jul 11, 2013 @ 7:19am
stuck on directx 8 [FIXED]
i was happy as hell when this came on sale and all so i bought it. then i opened the game, went to videooptions to max all the settings (8 gb ram, gt 640, core i5 3.40ghz) and i see color correction impossible to enable. motion blur impossible to emable. directx suck on 8. ive tried downloading dx9 from the web, not working. i play fc3 blood dragon maxed out on dx11 goddammit! HELP
EDIT: TF2 works perfectly on DX9. it actually says DirectX 9+
Last edited by woop; Jul 12, 2013 @ 2:08am
Showing 1-15 of 18 comments
< >
Ted ✯BF4✯ Jul 11, 2013 @ 7:23am 
I have the same case with you on this 1.
VaderGeist Jul 11, 2013 @ 7:31am 
Originally posted by UNIX:
To fix this, try the launch parameter "dxlevel", e.g. -dxlevel 95. I think you need DX9 to be able to set shadow quality to high or to enable color correction. Note that using this launch parameter will reset video options for the game every time you launch it.

More info about it:
Valve wiki page (Ctrl+F, search for dxlevel)
Source issue #540 on GitHub[github.com]
VaderGeist Jul 11, 2013 @ 7:35am 
I researched this info about dxlevel from the wiki mentioned above:

-dxlevel <level>
===========

- Forces a specific DirectX version when launching the engine. This is useful if your graphics card is DirectX 9 capable, but a lot faster using only DirectX 8 (e.g. NVidia GeForce FX 5200). Multiply the desired DirectX version to use with ten. E.g. for DirectX 8.0 you would use -dxlevel 80. For DX9 there are three possible values depending on the Shader Model the graphics card supports. See mat_dxlevel.

mat_dxlevel
=========

mat_dxlevel [DirectX version]
mat_dxlevel 70
mat_dxlevel 80
mat_dxlevel 81
...
mat_dxlevel 90 - DX9 with Shader Model 2
mat_dxlevel 95 - DX9 with Shader Model 3



https://developer.valvesoftware.com/wiki/Command_Line_Options#Command-line_parameters
Murray Landrew Jul 11, 2013 @ 8:07am 
My Garry's Mod is also stuck on DirectX 8, and I don't know why!
Sir Whiskeyngton Jul 11, 2013 @ 9:20am 
Go to your steam library, right click on hl2, click on "properties", go to the "general" tab and click on "set launch options". In the box that appears type -dxlevel 90. Click OK, and then start the game. Just remember to remove this from the launch options after you start the game once for it will because otherwise it will cause all the video settings to reset everytime you start the game.
ChamFEAR(ru) Jul 11, 2013 @ 10:20am 
windows xp
woop Jul 11, 2013 @ 10:42am 
FIXED!

Originally posted by Sir Whiskeyngton:
Go to your steam library, right click on hl2, click on "properties", go to the "general" tab and click on "set launch options". In the box that appears type -dxlevel 90. Click OK, and then start the game. Just remember to remove this from the launch options after you start the game once for it will because otherwise it will cause all the video settings to reset everytime you start the game.
VaderGeist Jul 11, 2013 @ 10:52am 
Yes Thanks for the step by step Sir Whiskeyngton. I just tried it successfully.
Fatality Jul 11, 2013 @ 10:57am 
Oh... Thanks, it really works.
DriveCruncher Jul 11, 2013 @ 11:11am 
why does this happen, exactly?
VaderGeist Jul 11, 2013 @ 11:17am 
Might be a residual dating thing, Somewhat similar to the theory of Y2k. Rather than progress to the next set of digits with higher value it regresses to a lower setting as the equation for Directx= (value)
may turn out to return (0) which in turn sets it to directx8 thinking there is a directx <= 8....

I may be returning value of 10 or 11 and have the automatic register as 00 which defaults to pre directx 8.

Just my theory.
VANDERSEXXX Jul 11, 2013 @ 12:42pm 
Half-Life 2 and Episode 1 runs only in directx 8 for me... Even if i set -dxlevel95/96/etc, it works only on first launch, I can enable hdr, high detailed shadows and other unavailable options, but it resets on next game launch even with this -dxlevel command.

Episode 2 and Lost Coast are working fine, showing 9.0c+ in menu. Valve really need to fix it...
VANDERSEXXX Jul 11, 2013 @ 1:10pm 
Found the solution: "-autoconfig".
Ted ✯BF4✯ Jul 11, 2013 @ 1:13pm 
Directx 8 = Simple shading quality but game runs on faster performance.
Directx 9.0c = better shading quality but could eat up performance.

In a nutshell, every action has consequences.
vmfa122 Jul 11, 2013 @ 5:11pm 
FIXED Thanks man :D
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Jul 11, 2013 @ 7:19am
Posts: 18