Half-Life 2 > General Discussions > Topic Details
Unix Jun 28, 2013 @ 4:07am
Hardware DirectX level stuck at v8.0
To fix this, try the launch parameter "dxlevel", e.g. -dxlevel 95. I think you need DX9 to be able to set shadow quality to high or to enable color correction. Note that using this launch parameter will reset video options for the game every time you launch it.

More info about it:
Valve wiki page (Ctrl+F, search for dxlevel)
Source issue #540 on GitHub[github.com]

To stop video settings from resetting:
Originally posted by edenist:
Just run it once, exit, then remove the launch option, it will keep dx9 and your settings
Last edited by Unix; Jul 11, 2013 @ 2:25pm
Showing 1-15 of 16 comments
< >
Quaker*** Jun 28, 2013 @ 5:06am 
Thanks a lot dude! It works perfectly with HL2, EP 1 and EP 2. :)
Ashpool Jul 1, 2013 @ 6:44pm 
This worked for me. Still, sucks that it resets every time. Thanks for the help though.
edenist Jul 2, 2013 @ 1:52am 
Just run it once, exit, then remove the launch option, it will keep dx9 and your settings
ZaxWaffles Jul 2, 2013 @ 7:21am 
Oh great. i thought i had some issues with my new gpu. Good to see i'm not alone here :).
[Lady].Crystalee♠ Jul 2, 2013 @ 7:40am 
Try to update to newest 320.49 Nvidia driver. It worked for me.
edenist Jul 3, 2013 @ 6:16am 
It occurs on AMD graphics also, so it doesn't seem to be a driver issue
koyboy Jul 10, 2013 @ 9:49pm 
perfect
gamer812 Jul 10, 2013 @ 11:07pm 
Thanks for this.
Unix Jul 11, 2013 @ 2:28pm 
Originally posted by edenist:
Just run it once, exit, then remove the launch option, it will keep dx9 and your settings
Thanks, it worked for me. I included your message in my post.
Aaron Rodgers Jul 11, 2013 @ 2:55pm 
So I can set the DX level. Still can't set the AA level to what it was.
Quaker*** Jul 13, 2013 @ 3:24am 
Problem fixed since the last NVIDIA driver for me
KiLLeR, eh Jul 13, 2013 @ 6:52pm 
ATI HD 4850, last drivers that were made for that series and I needed the fix. Thanks. Stupid Valve breaking a thing that worked and still hasn't fixed at least 2 months later in a public release.
direlog Jul 15, 2013 @ 7:13am 
Fantastic, thanks.
Moonrayker Jul 15, 2013 @ 8:19am 
Thanks for tip!
PiccoloNo92 Jul 15, 2013 @ 12:42pm 
Just tried this and it seems to have worked a treat ^_^ Thanks a million!
Showing 1-15 of 16 comments
< >
Per page: 15 30 50
Date Posted: Jun 28, 2013 @ 4:07am
Posts: 16