Half-Life 2 > General Discussions > Topic Details
.. Feb 14, 2013 @ 1:39pm
Having performance issues playing HL2
I'm VERY confused and I'm hoping someone can help. I just bought and installed Half-Life 2 and I'm having major issues while playing it. Frame rates dropping like crazy, freezes, glitches, and just generally unplayable. My system can DEFINITELY handle the game. i5-3570K, HD 7970, 8GB RAM. I can play any game on the planet with this system but I can't play a 10 year old game? I hope someone can help . . .
Showing 1-5 of 5 comments
< >
z1gaming Feb 14, 2013 @ 3:20pm 
Maybe you need a faster hard drive

because my computer is worse than that and i can play hl2 on medium-low settings
.. Feb 14, 2013 @ 3:28pm 
Definitely not the hard drive. It's on an SSD lol. I play Skyrim, BF3, etc etc on ultra/high with no issues. That's why I'm so confused.
_GoldSrc_ Feb 15, 2013 @ 4:38pm 
Man your system is way better than mine and you're having problems with HL2?.
have you tried to run the game in a window and check the task manager to see if the cpu usage is weird
my cpu is an i3 and i have a GTX-650 and the game runs fine.
laserad Apr 30, 2013 @ 11:53am 
im waking up this topic... i have a 7870XT with the same problem... afterburner tells me the card goes to idle clocks of 300/150.. dropping to 30-40fps at times feeling stuttery, everything set to max with 8msaa and vsync on... the card has the same tahiti core as the top end ati7970
i used to have 6870 playing hl2 just fine.. but this tahiti with the boost clock function is ♥♥♥♥♥♥♥ me off.. i dont have problems in other games as pretty much everything i play is graphically more demanding than hl2 and is supported in newer drivers properly

EDIT: i made the vsync work at 60fps by pushing the graphics and making the game more demanding, preventing it to use lower clocks.. how? xD
ati catalyst - 4xEQ SUPERSAMPLING.. with 8x it stresses the gpu too much and framerate drops sometimes and i want the game to run constant 60 :( also looks pretty:) PRETTY
Last edited by laserad; May 2, 2013 @ 12:43pm
Lord Tony Aug 17, 2013 @ 10:59am 
I'm having same issues.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Feb 14, 2013 @ 1:39pm
Posts: 5