Half-Life 2 > General Discussions > Topic Details
Chade May 21, 2013 @ 1:12pm
Half life 2 Stuck in DX8 mode?
Just downloaded it again to get hold of some cards, but noticed the game is stuck in Dx8 mode, cannot change the option in the video menu at all. Tried checking the cache, no luck, what was the command to force DX9+ from the command line? I've forgotten.
Showing 1-11 of 11 comments
< >
Mozgus May 22, 2013 @ 12:05am 
+mat_dxlevel 90 in launch options
VideoBIT May 22, 2013 @ 3:08am 
I have the same issue. Do you think Valve will fix it later?
Motörhead May 22, 2013 @ 5:27am 
Same here. Thanks for the command.
天使Lynus' Kouhai天使 May 23, 2013 @ 9:36am 
Proper command is -dxlevel 90
Mozgus May 23, 2013 @ 9:39am 
Originally posted by Kodek (GB):
Proper command is -dxlevel 90
That didn't work for me, buddy. mat_dxlevel here.

https://developer.valvesoftware.com/wiki/Mat_dxlevel
Motörhead May 23, 2013 @ 11:15am 
A patch appeared for HL2 a few minutes ago, downloaded and tested, it fixes the issue, now the game detect my hardware as able to run dx9. No need for any command anymore
Chade May 23, 2013 @ 11:19am 
Thanks people, the command switch was ok as a workaround, but the patch fixed it up.
Mozgus May 23, 2013 @ 11:20am 
Fantastic
Chade May 23, 2013 @ 12:26pm 
Scratch that. Still not working. I can force it to a higher DX level using the console or command line, but it doesn't enable all the effects, then when trying to enable them via the options it either crashes the game or i end up with a pink and black chequered screen. Tried deleting all HL2 data from Steam and redownloading it twice, but nothing seems to fix it. Perhaps HL2 needs an update to detect some of latest graphics cards?
Burty Jul 1, 2013 @ 10:18am 
I've just built my brand new rig with an Nvidia GTZ 780 in it and i'm getting the same issue, it's stuck in DX8 mode, this is annoying -_-
Fuchs808 Jul 1, 2013 @ 11:53am 
With GTX 670 same problem
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: May 21, 2013 @ 1:12pm
Posts: 11