Half-Life 2 > General Discussions > Topic Details
Ayleesh May 20, 2013 @ 12:06pm
Why my HL2 is in russian?
Hi comrade...i mean, hi everyone, ill reinstalled hl2 for the card thing and stuff. But i have a little problem, the game is russian, people spoke russian, things are written in russian and stuff. Now, i'm pretty sure i'm not russian, when ive played HL2 the first time, a lot of time ago everything was fine. Even if i right click on the the game properties in my steam library and select my language, the game wont change. What can i do to resolve my problem?
Last edited by Ayleesh; May 20, 2013 @ 12:07pm
Showing 1-15 of 30 comments
< >
Hasgar May 20, 2013 @ 12:45pm 
have the same problem but my game is now japanese somehow...i always played it in german.
Hasgar May 20, 2013 @ 12:50pm 
i changed the language to english and everything worked fine in english. after that i changed the language back to german and again everything is japanese or chinese -.-
Ayleesh May 20, 2013 @ 12:52pm 
Originally posted by Hasgar:
i changed the language to english and everything worked fine in english. after that i changed the language back to german and again everything is japanese or chinese -.-

Ill try to change language, usually with the other games, a little download starts and in the next play the language is changed, but in this case anything happens.
OdioInserireID May 20, 2013 @ 1:20pm 
i have the same problem
MarcoCav May 20, 2013 @ 1:27pm 
Same problem for me (I'm trying to play HL2 in italian like I do in the past, but nothing... only russian is available).
AbstractSuper May 20, 2013 @ 1:28pm 
And i'd like to ask - why my HL2 is NOT russian??! Starts in german, and only choice i have - switch it to english! Although subtitles and interface are in russian. Strange thing... Is anyone here knows what to do with it??
AbstractSuper May 20, 2013 @ 1:32pm 
Maybe it depends on a region choice in download+cloud tab in preferences?? My Steam autochecked it as Sweden, I don't know why)
Chainworm666 May 20, 2013 @ 1:37pm 
The gaem taeks plaec in russianland! that's WHY
Ayleesh May 20, 2013 @ 1:44pm 
Originally posted by Killers:
i have the same problem


Originally posted by MarcoCav:
Same problem for me (I'm trying to play HL2 in italian like I do in the past, but nothing... only russian is available).


Originally posted by AbstractSuper:
And i'd like to ask - why my HL2 is NOT russian??! Starts in german, and only choice i have - switch it to english! Although subtitles and interface are in russian. Strange thing... Is anyone here knows what to do with it??


Originally posted by AbstractSuper:
Maybe it depends on a region choice in download+cloud tab in preferences?? My Steam autochecked it as Sweden, I don't know why)


Originally posted by Chainworm:
The gaem taeks plaec in russianland! that's WHY

O MY GOD THEY ARE INVADING US!!!!!
CONGROO May 20, 2013 @ 3:30pm 
I'm actualy want to play in russian but when i choose russian - everyone speaks in german, try to download german... game turn to korean :D Only english works fine. looks like someone mess up with languages.
Ayleesh May 20, 2013 @ 3:41pm 
Originally posted by El.Ψ.CONGROO:
I'm actualy want to play in russian but when i choose russian - everyone speaks in german, try to download german... game turn to korean :D Only english works fine. looks like someone mess up with languages.

If you are not trolling, this thing make me laugh a lot
Originally posted by El.Ψ.CONGROO:
I'm actualy want to play in russian but when i choose russian - everyone speaks in german, try to download german... game turn to korean :D Only english works fine. looks like someone mess up with languages.

same
Hardkorn May 20, 2013 @ 7:11pm 
Open HL2 game properties and change the beta to steampipe beta.
Last edited by Hardkorn; May 20, 2013 @ 7:12pm
Seven7 May 21, 2013 @ 12:21am 
If you do not want to switch to the beta version of Steam Pipe
(because it has a lot of bugs and problems with modifications and old save game)
switch between languages
Russian - inside Italian
German - inside Russian
Italian - ?
Korean - inside German
etc.
Ayleesh May 21, 2013 @ 12:24am 
Problem solved (at least for me): go on your game library, right click on HL2 and chose languages, select the one you prefer, then close your steam and open it again. At the restart of the client, your HL2 should be in "suspended download" just right click on it and restart the download, after a little download, everything should be fine.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50
Date Posted: May 20, 2013 @ 12:06pm
Posts: 30