Half-Life 2 > General Discussions > Topic Details
pfannkuchen_gesicht May 9, 2013 @ 6:02pm
Linux beta bugs and issues thread
As the Half-Life 2 Beta finally arrived for linux I thought I open a bug thread, so we can report everthing that should be fixed sooner or later.
Don't forget to include your system specs if you post issues.

my pc's specs:
>HW<
AMD Phenom II X4 955(3.2GHz)
2x 4GB DDR3-1333(7-7-7-20) G.Skill RAM
MSI 790FX-GD70
ASUS EAH5870(AMD HD5870, 1GB VRAM)

>SW<
Arch linux(3.8.10-1)
Xfce DE
Catalyst 13.4
Xorg 1.13(thanks AMD!)
xrandr 1.4

Anyways, the game works mostly well and also the performance is good most the time. Sometimes at certain places the fps fall down to 40fps though. Also there is some periodic stutter, it runs smooth and every few seconds it freezes for a few milliseconds(the sound also freezes).
I also noticed some graphical glitches, like some objects having corrupt textures when on the edge of the screen not always and kinda hard to reproduce.
Also some particle effects seem to have coloring issues as well as texture corruption, for example when barney throws you the crowbar and the scanners are flying out of the citadel, some of them just show up as grey rectangles.

EDIT: particle color corruption:
http://steamcommunity.com/sharedfiles/filedetails/?id=144196372

Also noticed that normal mapping seems to cause some stron moire effect:
http://steamcommunity.com/sharedfiles/filedetails/?id=144196402


Last edited by pfannkuchen_gesicht; May 10, 2013 @ 6:37am
Showing 1-15 of 99 comments
< >
muffinduck01 May 9, 2013 @ 7:02pm 
This is about as vague as it gets, but I just installed the HL2 beta on Linux Mint 14 64 bit. When I hit the Start button in the Steam browser, I see a window pop up, but it quickly goes away.

AMD FX 4100
ASUS M5A97 Revision 1
GSkill 2 x 4 GB DDR3 2133
ASUS DirectCU2 Radeon HD 6850
Linux Mint 14 64 bit, Kernel 3.5.0-17
MATE 1.4.2-1
AMD Catalyst 13.4
Last edited by muffinduck01; May 9, 2013 @ 7:02pm
airtonix May 9, 2013 @ 7:50pm 
Ubuntu 12.10 Gnome Shell 3.6.
Started a new game, got off the train, after being escorted down the corridor guard won't open the door.

http://imgur.com/uzaPFLC
Last edited by airtonix; May 9, 2013 @ 7:56pm
危ないー May 9, 2013 @ 10:07pm 
I'm on Arch Linux x86_64 using Xmonad.
I loaded an ancient save, and I'm in the dark energy chapter.
Alyx tells me to get on the elevator, and I do. The door shuts, but she doesn't activate the elevator. I'm guessing it's related to the bug posted by airtonix.
Jonny Paul Larkin May 9, 2013 @ 10:53pm 
Ubuntu 13.04 64-bit (kernel 3.8.0-19-generic) with Unity. Everything ran smooth as butter until the point after you leave the red trailer in the "Red Letter Day" chapter. The game just hung and quit on me. I'll see if it happens again and will post some better details.

Specs:
AMD Phenom II X4 925 @ 2.8 GHz
EVGA GeForce GTX 550 Ti using NVIDIA 313.3 drivers
4 GB DDR3 RAM
Beloved Girdot of the Universe May 9, 2013 @ 10:55pm 
Seems to me there's a bug with activating triggered events. Only played for the first 15 minutes or so, but I encountered two bugs:

One, when Barney pulls you into the interrogation room to reveal himself, the combine that escorted you there just...doesn't leave. Kinda funny watching Barney reveal his identity right in front of a combine soldier.

Two, in Dr. Kleiner's lab, when attempting to assist Alyx. The plug pops out, and I plug it in just fine, but then when Kleiner has me pull the switch, it does nothing, and Alyx just sits up there with the teleporter going crazy around her.

Still, amazing performance though! I was hitting 300fps consistently the entire time. Gaming on linux is finally happening! :D

Whoops, probably should add:
Running Linux Mint 14 with dwm.
Last edited by Beloved Girdot of the Universe; May 9, 2013 @ 10:57pm
[ARCH] perlmut May 9, 2013 @ 11:43pm 
Not enjoyable right now?
Rotech May 10, 2013 @ 12:50am 
Performance is great for me on Arch Linux 3.9.1 X86_64. I didn't have the problem with the combine soldier not leaving, but I am having the same issue with Alyx in the transporter.
Alex7Kom May 10, 2013 @ 6:12am 
Noticed only Breen not standing during the teleporting scene in A Red Letter Day.
Ubuntu 13.04 x64, Unity, GeForce GT 640, nVidia driver 319
###O?qÿáÓ May 10, 2013 @ 6:19am 
Originally posted by airtonix:
Ubuntu 12.10 Gnome Shell 3.6.
Started a new game, got off the train, after being escorted down the corridor guard won't open the door.

http://imgur.com/uzaPFLC

I tried to reproduce this. But it all worked fine.

Debian Wheezy 64bit
AuthenticAMD AMD FX(tm)-8350 Eight-Core Processor [Family 21 Model 2 Stepping 0]
AMD AMD Radeon HD 79x0 series (Tahiti) (3072MB) driver: 1.4.1741
16GB RAM

Screenshots:
http://steamcommunity.com/sharedfiles/filedetails/?id=144285086
http://steamcommunity.com/sharedfiles/filedetails/?id=144285177
Last edited by ###O?qÿáÓ; May 10, 2013 @ 6:22am
pfannkuchen_gesicht May 10, 2013 @ 6:27am 
for those of you having trouble with events, like npcs going/openening doors/etc. try to validate the game cache, worked for me. Only Breen is still sitting instead of jumping up from his chair.
Last edited by pfannkuchen_gesicht; May 10, 2013 @ 6:34am
hun.gergov May 10, 2013 @ 8:02am 
I didn't experience any bugs other than the game slowing down terribly every 5-10 minutes. Sometimes it just happens, but i can also reproduce it intentionally if i change the graphics settings during playing. The framerate drops down to 3-4 FPS and if i Alt+Tab out of the game the whole desktop is slow. Top shows 99% CPU usage for both hl2_linux and Xorg. The system load is also very high, 30-45%.
I'm not sure if it's a game, Xorg or Nvidia driver bug. I did try different versions (310.40 and 310.51 Beta) of the latter, but the problem didn't go away.

I'm using Xubuntu 10.04 x64, kernel 3.2(.24), Nvidia driver 310.51 Beta and an ancient Geforce 8600M GT video card.
Zaister May 10, 2013 @ 8:39am 
I noticed that my Steam Cloud saves from Windows were imported for Episode One, but nor for Half-Life 2 and Episode Two.
pfannkuchen_gesicht May 10, 2013 @ 8:50am 
some other graphical issues I had so far:
Alpha issues
http://steamcommunity.com/sharedfiles/filedetails/?id=144299708
http://steamcommunity.com/sharedfiles/filedetails/?id=144299644
http://steamcommunity.com/sharedfiles/filedetails/?id=144298976
http://steamcommunity.com/sharedfiles/filedetails/?id=144298915
http://steamcommunity.com/sharedfiles/filedetails/?id=144298864
water refraction issues
http://steamcommunity.com/sharedfiles/filedetails/?id=144298704
http://steamcommunity.com/sharedfiles/filedetails/?id=144298779
refreaction color banding, also changing depending on view angle
http://steamcommunity.com/sharedfiles/filedetails/?id=144299364
http://steamcommunity.com/sharedfiles/filedetails/?id=144299281
and the motorboats shadow is looking weird
http://steamcommunity.com/sharedfiles/filedetails/?id=144299197
http://steamcommunity.com/sharedfiles/filedetails/?id=144299118
http://steamcommunity.com/sharedfiles/filedetails/?id=144299018
also I think I can't remember the skybox stretching from the win version
http://steamcommunity.com/sharedfiles/filedetails/?id=144299244

another thing that is really annoying right now and I think since Catalyst 13.4 it happens that periodically the game slows down and speeds up back again which feels very strange, the stutter is gone though.
It is really strange, you move suddenly it slows down and in the next moment it jumps back to normal and you're at a position where you would be if the slow down never happened.
Last edited by pfannkuchen_gesicht; May 10, 2013 @ 8:53am
cdtnjlfkmyjvth May 10, 2013 @ 9:23am 
Ubuntu 13.04 64-bit. Problems with textures, intro screen looks this way: http://i.imgur.com/7AS6zWv.png
My specs:
Inte Core i3 CPU M 390 @ 2.67GHz
Intel Ironlake Mobile
3 GB RAM
hero1900 May 10, 2013 @ 10:05am 
the game works so well for me the problem is in crashing from time to time when moving from one area to another
Showing 1-15 of 99 comments
< >
Per page: 15 30 50
Date Posted: May 9, 2013 @ 6:02pm
Posts: 99