Half-Life 2 > General Discussions > Topic Details
fultown_1 Nov 11, 2013 @ 11:04am
Launcher.dll null (HL2)
Anyone knows how i can fix this error NO LAUNCHER.DLL FOUNND (NULL) I have tried all the options out there and none worked. Getting a new machine is not an option. I'm running an 3100+ AMD ATHLON, 2GIG RAM, I have play the game for 4 hours. by the next time I went to boot it up it had this error..????? thanks in advance
Showing 1-12 of 12 comments
< >
Pinhead Nov 11, 2013 @ 2:55pm 
This is an error that I don´t know. But go to the Half-Life 2 file and try to execute this game by clicing in "hl2.exe" If works, delate the direct access from the "desctop" and make an another one by using the "hl2.exe" file with right clic and, finally, change the name of the new direct acces to "Half-Life 2". This is the only help that I can give you. And well, I had a similar problem, but my own message error said something about a subdirectory called Minerva and about some .cfg file. So... I am not sure about my solution, but try it.

And finally check the cache of the game to be sure that you have all the files installed correctly, but, I am sure that you did that.
Ranmamez Jan 5 @ 1:44am 
It's futile to do that.
truben99 Jan 8 @ 5:22pm 
Here's something I just found out because I had to do a reinstall of my OS. I re-installed Steam over the existing old copy so Windows would recognize that it was installed. Same folder as before, same game files as the last time I tried to play any of my Half-Life2 games. Didn't think they would work, but I had other games on Steam that I wanted to play. Each of the Half Life 2 games went through an initial update before I could launch them. BUT THEY WORK NOW! And they worked for about 4 days until I launched Steam again and it updated the damn games again! So I went back and reinstalled Steam over my existing copy and THE SAME THING HAPPENED! All my games work again. I don't think it's just because they don't support Athlon XP processors anymore (SSE2 not compatible). I have set all of my games not to automatically update, and also, I am only using Steam in offline mode until they can figure this out. Using an Athlon XP 2600, and the games work.
Ranmamez Jan 9 @ 9:18am 
Wich os did you reinstall?
truben99 Jan 9 @ 12:23pm 
Windows XP. but I don't think it was the OS reinstall that did it. It was the Steam reinstall over the existing installation. It's worked twice so far in the last week or so.
Ranmamez Jan 9 @ 1:02pm 
So let me understand: you had WinXP, and Steam with Source engine games on it, and on a athlon xp 2600+, at a certain point it didn't run anymore or not so well, so you reinstalled Windows from scratch maintaining the original steam folder and reinstalled it over it, and all went well?
Besides, did you try HL2 and TF2? Are they the latest releases or just some old versions?
Thanks.
truben99 Jan 9 @ 2:08pm 
Yes, I had WinXP on its own partition. My Steam with Source engine games were on a seperate partition. After a clean installation of XP , I reinstalled all the apps that were on the other drives, including Steam. Alll my games worked, including all Half Life 2 games, after a quick update when I first launched Steam. A week later, I tried to play them, they updated again, and then they didn't work anymore. So I said, let's see if it's the reinstall of Steam itself that does something. Sure enough, after the second reinstall of Steam into the same folder as before, the games started working again. So now, I will just play them offline and not let Steam update the games again. Have not tried TF2, but I thought I read somewhere that they had actually removed the SSE2 requirement from their files for that game.
I guess the point is, it wasn't the reinstall of XP, it was the reinstall of Steam into its existing folder that made the games work.
The steps I speciffically took yesterday are as follows:
downloaded and installed the Steam setup.exe (from Steam)
after installing, I ran Steam and it immediately updated itself.
When that wass done, I went to my games, where all four Half -Life2 games said update required to play.
double clicked Half life2 to play, and the little box comes up saying updating, and there is an option in the box to launch game right after the update.
Launched game right after the update and it work!
Did the same thing for all other games saying update required.
They all work.
Went offline on my Steam app to avoid any other updates which will break the games again.


truben99 Jan 9 @ 2:17pm 
Not sure of the versions of the games, but most of the vpk files are from October 2013. There are a few with a newer date than that. Hope that helps.
Ranmamez Jan 9 @ 5:41pm 
Hmm ok, thank you for now.
I'll do some tryings now.
I read too that they removed SSE2 requirements from TF2 left from a past update (it was for a linux compatibility compile), but still won't run on my ath xp, even though it gets a different error than this HL2 one.
Btw, did you had TF2 installed before the windows refreshing, or do you have to download and install it whole?
truben99 Jan 9 @ 6:28pm 
I don't have TF2 installed on my computer. I would have to download it from Steam, and I am not going to do that until they figure this out first.
Ranmamez Jan 9 @ 6:44pm 
Heh, I guess you would wait like forever :(
I'm lucky because I already have newer hardware that can run it, and the AthXP i'm using is just a rig i've assembled for fun and experimenting...
truben99 Jan 9 @ 7:17pm 
I'll be getting a windows 7 rig myself, but I can hold off a little longer now! But I've had this Athlon for 10 years. The windows reinstall I did was the first one ever for this system. Used to be a heavier gamer, now I'll usually just play a level or two here and there.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Nov 11, 2013 @ 11:04am
Posts: 12