Antichamber > Discusiones generales > Detalles del tema
and 1 FEB 2013 a las 7:39
Doors don't open in Learn To Draw [green gun]
Is this a bug or am I not doing this right. I fill the gun with green blocks, go to a door and fill in both sections all the way with green blocks. should the door then open or is there something else to it. Also the green progress bar that is displayed when a section is filled seems to be random and rarely shows up.
< >
Mostrando 1-15 de 17 comentarios
Morning Coffee  [desarrollador] 1 FEB 2013 a las 7:41 
This sounds like a bug, sorry. Does it still happen if you quit the game and re-open it?
and 1 FEB 2013 a las 8:00 
Yep, no luck. I might try a new game and see if that fixes it. I'm playing it on an oldish laptop, maybe that has something to do with it. Thanks for the reply.
Morning Coffee  [desarrollador] 1 FEB 2013 a las 8:23 
The green progress bar on the door is only filling up when the laser at the end of those trails are getting filled. A new game likely wouldn't fix it. I'm not sure why this is happening for you though, and will look into it.
The REAL Joker 2 FEB 2013 a las 10:26 
I've got the exact same problem. Would re-installing the game fix it (not that I want to but at this point I don't really see any other choice).
and 2 FEB 2013 a las 17:27 
I tried validating the files and then deleting and re-installing, but that didn't fix it. The wierd thing is that when I got to that point after I had re-installed it, the door opened but when I walked around back into the room and tried again it wouldn't open....
Michael Farquhar 2 FEB 2013 a las 18:51 
There seems to be a bug in which not all the lasers register being cut by blocks. I've found that moving the block in and out of the laser should eventually cause the game to recognise that the laser has been cut. There are multiple other locations in which this bug features, usually in the locations where the blocks are constrained or behind glass.
The REAL Joker 3 FEB 2013 a las 4:43 
How many times would you guess you deleted and placed the block in the laser before it worked? Because I stood there for 10 minutes replacing blocks and it still didn't register.
and 4 FEB 2013 a las 7:10 
I couldn't get it to work with the green gun, I came back to it with the yellow gun and got the doors to open eventually. The yellow gun can speed up the process of moving the blocks in and out.
Cubey 4 FEB 2013 a las 7:25 
Yes this is a bug. Unfortunately the only real work around is brute force perciverance. If you keep replacing the blocks, eventualy it will recognise the beam being cut and register that switch.
Unfortunately this can take a while. I ran across this bug when i needed to break two lines of 8 laser beams on each side of a green door. I had filled both sides but the door only registered about 13 or 14 of the lasers properly cut. Personaly i found a greater success of getting the switches to register when placing the blocks individualy rather than 'streaming' them in flows. of course, this wont work if you are required to put them behind objects.

Just keep at it and know that you aren't the only ones suffering from this but, and that you wont end up as the only ones to be defeated by it.
The REAL Joker 4 FEB 2013 a las 7:57 
Alchemist were you using the green or yellow gun? I want to know if I should start trying to get the next level gun before comiting to replacing blocks for half an hour only to find that the green gun is horribley broken :P
Cubey 4 FEB 2013 a las 10:17 
If i remember rightly, i was using the green gun, but that i cannot be 100% sure of.
I would recommend going to another part, maybe getting the next gun, then coming back. Maybe it will 'fix' its self if its not used or something else is reset ...
its really just trial and error i feel.
The REAL Joker 4 FEB 2013 a las 14:05 
ok buddy thanks for the suggestions :)
Morning Coffee  [desarrollador] 6 FEB 2013 a las 18:13 
This is a weird bug that is going to be related to the timing of when the laser blocking check takes place, and will take some time to track down why it's causing problems. It may be something as simple as me needing to delay a check by another frame if for some reason some machines aren't registering collision on the exact frame that is being checked, as other computers are.
and 6 FEB 2013 a las 22:19 
Alexander could this be caused by framerate issues or by the hardware/software the computer is running. I'm running it on a laptop with windows xp that just matches the min-specs the game specifies. I had to drop the res to 800x480 and still had framerate issues in some areas.

I did manage to complete the game and as alchemist was saying, I was able to brute force that section once I had the yellow gun.
Última edición por and; 21 MAR 2013 a las 23:02
< >
Mostrando 1-15 de 17 comentarios
Por página: 15 30 50

Antichamber > Discusiones generales > Detalles del tema
Publicado el: 1 FEB 2013 a las 7:39
Mensajes: 17