Antichamber > General Discussions > Topic Details
German Waffles Feb 21 @ 7:49am
Game Does Not Launch.
Hello everybody. I've purchased this game out of the humble bundle 11, and after I installed it the game simply wont launch. I've tried a myriad of things, but can't even get a black screen. I'm running Linux Mint Cinnamon 64bit, and can run all my other games just fine. Anybody have any thoughts?
Showing 1-8 of 8 comments
< >
◆sviat93◆ Feb 21 @ 9:07am 
Launches to me, but crashes after Unreal logo.
Billybob3001 Feb 21 @ 9:43am 
I have 0 experience with Linux since I've always been a windows user, but mabey there are similarities. This game also did not start for me initially. I would click play and nothing would happen. I fixed it by download an older .Net Framework v3.5 since apparently v4+ is too new. Mabey there is something like that for Linux?
Last edited by Billybob3001; Feb 21 @ 9:43am
blackout24 Feb 21 @ 10:54am 
Launch it from terminal it will tell you what's wrong. You're probably missing some libraries that the games needs and which would be provided by steam-runtime, if the game was added to the steam linux library. On my Arch Linux box it only complained about the 32 bit versions of libvorbis, libogg and libpulse which I didn't have installed since everything I have is pure 64 bit.
Last edited by blackout24; Feb 21 @ 10:55am
Californ1a Feb 21 @ 1:56pm 
Not sure if any of these would also apply for linux, but the Antichamber subreddit keeps a listing of fixes for startup crashes.
http://reddit.com/r/antichamber/wiki/startupcrash
German Waffles Feb 21 @ 8:22pm 
UPDATE: So I launched the game from terminal like blackout was saying and I got this error message:
./UDKGame-Linux: error while loading shared libraries: libogg.so.0: cannot open shared object file: No such file or directory

So I searched for libogg and found it was actually named "libogg.so" so i renamed it to "libogg.so.0". I also had to do the same for "libvorbis.so"
When I launched the game afterwords It distored the screen and threw up this in the terminal:

[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Loading library: libPhysXCooking.so
Result of loading library libPhysXCooking.so: 0xb24f500
Loading library: PhysXUpdateLoader.so
ERROR: PhysXUpdateLoader.so: cannot open shared object file: No such file or directory
Result of loading library PhysXUpdateLoader.so: 0x0

ITS NOT EVEN ON THE STEAM LIBRARY FOR LINUX! (Although it was today for a brief moment for some reason....) This is funny because I got the game through direct download through bundle, not steam.........It looks like ultimately I'm missing the library PhysXUpdateLoader.so (maybe wasn't put in the linux release on accident?)
Last edited by German Waffles; Feb 21 @ 8:38pm
╰IB╮Koka Jul 7 @ 4:34am 
Could you solve the problem?!
phxx Jul 10 @ 10:20am 
I have the same problem :( Not starting and getting errors of unfound libraries.
JhonnyBGoode Jul 10 @ 10:56am 
Actually I didn't bought that on steam. But this is what I need to do, to fix your errors, but not mine: Still not loading:

1. It's generally better with linux to not let it run fullscreen, so go to the config file and turn fullscreen to false
2. For your Library loading errors you need to set-up an LD_LIBRARY_PATH:

export LD_LIBARY_PATH=PATH_WHERE_YOU_INSTALLED_IT/Binaries/Linux/lib

(best add that into the Antichamber.sh file)

On my computer (actually a laptop this still fails with):

Loading library: libPhysXCooking.so
Result of loading library libPhysXCooking.so: 0xb08c280
Loading library: PhysXUpdateLoader.so
ERROR: PhysXUpdateLoader.so: cannot open shared object file: No such file or directory
Result of loading library PhysXUpdateLoader.so: 0x0
Loading library: libPhysXCore.so
Result of loading library libPhysXCore.so: 0xafea280
LLVM ERROR: Program used external function '' which could not be resolved!
Showing 1-8 of 8 comments
< >
Per page: 15 30 50