Don't Starve

Don't Starve

 This topic has been pinned, so it's probably important
Eolian Mix Jul 13, 2013 @ 11:54am
Resolution/Pixelation Problem (RESOLVED)
This fix works on Nvidia and AMD graphic cards and works for both Don't Starve and Don't Starve Together.

I just bought Don't Starve and when running the game, all the graphics are pixelated and terrible. The loading screen is blurry, the fire is pixelated, and in the swamp there are red pixels everywhere. No matter what resolution or windowed/fullscreen mode it's in, it's still appears pixelated. My computer runs all of my other games fine, so I'm not really sure what the issue is here... It's not that I'm just not used to the game's style, because I've played it for hours previously on a friend's computer...

Example screenshots of the error:
http://i.imgur.com/PjBuNnqh.jpg
http://i.imgur.com/4rYfbNEh.jpg
http://i.imgur.com/Da20DeUh.jpg (Dusk is darker, with many distracting red pixels.)

THE FIX!
Works on Nvidia / AMD graphics cards and both Don't Starve (DS) / Don't Starve Together (DST).
  1. Open up Nvidia or AMD graphic card control panel - see directly below and follow the path for Nvidia or AMD (If you're not sure which brand of graphic card you have, just type either "Nvidia" or "AMD" into your computer's start menu. Whichever word brings up a program in the start menu should most likely be the brand of card that's in your computer.)
    • Nvidia Control Panel > Manage 3D Settings > Anisotropic filtering
    • AMD Catalyst Control Center > Gaming > 3D Application Settings > Anisotropic Filtering
  2. Put the Anisotropic Filtering down to 2x, then up to 16x. Apply changes. (Feel free to leave the GPU window open - we'll be going back to it in just a minute.)
  3. Run the game (DS or DST). Turn off Small Textures in the in-game Options menu. Apply changes.
  4. Close game. Switch Anisotropic back to "Let The Application Decide" or "Use Application Settings". (The phrasing depends on if it's AMD or Nvidia, but they mean the same thing.)
  5. Start the game. At this point everything should be fixed and looking less pixelated! (Yay!) Enjoy your game - it's one of my favorites! :)

EDIT
May 9, 2015 - Fix works for DST!!
- Hi everyone! I'm glad this has helped so many of you to enjoy the game! Oddly enough I had this same problem on Don't Starve Together on an entirely new computer, but this fix still worked! Works with both Nvidia and AMD cards.

EDIT
Dec 4, 2015 - Minor Edits
- Hello again! I'm so glad this has helped so many people! I made some minor formating and grammatical changes to my original post and instructions to hopefully make it even more accessible and understandable to those who are reading this fix. I've also rewritten the first step of the fix to include the specific path for an AMD graphic card. Good luck and have fun not starving! ;)
Last edited by Eolian Mix; Dec 4, 2015 @ 12:45am
< >
Showing 1-15 of 35 comments
Eolian Mix Jul 13, 2013 @ 12:21pm 
Been troubleshooting for the past half hour on it and fixed both problems.
If anyone needs it, here was my fix.
Open up Nvidia control panel > Manage 3D Settings > Anisotropic filtering
Put it down to 2x, then up to 16x, then run game. Turn off Small Textures in the in-game options. Close game. Switch Anisotropic back to letting the application decide, run again, and it fixed it for me. Yay! :)
Haggis McMutton Jul 13, 2013 @ 12:41pm 
wow... you literally baffled you graphic card XD
Snake Feb 6, 2014 @ 3:27pm 
Thanks this fixed it
J20Hawkz Feb 6, 2014 @ 3:36pm 
Good to hear things are working. Awesome attempt at a self fix!
Eolian Mix Feb 9, 2014 @ 6:43pm 
:) I'm glad this could help someone else! Enjoy the game! :D
Rachel Apr 7, 2014 @ 2:00pm 
Thank You, this helped me <3
Eolian Mix Apr 13, 2014 @ 7:24pm 
Originally posted by Martii:
Thank You, this helped me <3

Yay! :) Glad this worked for you! Enjoy the game!
Eanimus Aug 9, 2014 @ 6:21am 
Thanks for the solution.
V4ND4L Dec 28, 2014 @ 3:17pm 
Solid fix. Thank you.

HatsuK May 5, 2015 @ 5:54pm 
This fix my problem too, thanks you!
Eolian Mix May 9, 2015 @ 6:42pm 
EDIT May 9, 2015 - Fix works for DST!!

- Hi everyone! I'm glad this has helped so many of you to enjoy the game! Oddly enough I had this same problem on Don't Starve Together on an entirely new computer, but this fix still worked! Works with both Nvidia and AMD cards.
J20Hawkz May 10, 2015 @ 12:25am 
I've pinned this thread. Great job mate.
Eolian Mix May 10, 2015 @ 2:37pm 
Originally posted by J20Hawkz:
I've pinned this thread. Great job mate.

Thanks J20Hawkz!
Kapuri Jun 4, 2015 @ 6:05am 
It worked! Thanks a lot!
Last edited by Kapuri; May 22 @ 10:53am
castielafin Dec 1, 2015 @ 11:52am 
Originally posted by Eolian Mix:
Been troubleshooting for the past half hour on it and fixed both problems.
If anyone needs it, here was my fix.
Open up Nvidia control panel > Manage 3D Settings > Anisotropic filtering
Put it down to 2x, then up to 16x, then run game. Turn off Small Textures in the in-game options. Close game. Switch Anisotropic back to letting the application decide, run again, and it fixed it for me. Yay! :)
Thank you thank you very very much
< >
Showing 1-15 of 35 comments
Per page: 15 30 50