TKB928 Nov 24, 2012 @ 1:41am
No Sound?
So yeah, no sound whatsoever. I've tried using headphones & speakers, reducing the quailty of graphics, nothing works. How does one get sound to work?

I did have some problems getting the game to load earlier, but I fixed that by installing new .dll files. Maybe I missed one?
Showing 1-9 of 9 comments
< >
gunman10 Nov 24, 2012 @ 8:20am 
I have had the same problem i think that the way me and you fixed the game from crashing like deleted the sound
kim jong un Nov 24, 2012 @ 10:04am 
I finally fixed the game and im having the same problem is there any solution?
kim jong un Nov 24, 2012 @ 10:05am 
And i also got alot of lag is it the same for you guys?
TKB928 Nov 24, 2012 @ 10:53am 
I've heard this game isn't the best with lag, but I would turn down the graphics settings to see if it's that. It set most of my graphic settings to their highest setting on my computer, which is able to run them but at a poor framerate. Lowering the graphics to medium settings made it twice as smooth.

To everyone else, we had problems launching the game from startup and downloaded the following .dll files to get it to work:

D3DCompiler_43.dll
d3dx9_43.dll
d3dx11_43.dll
XAPOFX1_5.dll

My guess is that there's another .dll file (or files) that controls sound that the game can run without, but of course controls the sound. I'm not really an expert with .dll files though, so I don't know the extensions for those that control sound.
Blatte Nov 24, 2012 @ 5:19pm 
Alright so I had this exact problem. Here's the solution that worked for me:

Go in your steamapps folder ­-­} common -} chivalrymedievalwarfare -} binaries -} RedistChiv -} DXRedistCutdown -} DXSetup

Then just install everything and you should be able to play with sound.

I hope it helped.
TKB928 Nov 24, 2012 @ 6:37pm 
It does, thanks.
Notrut Dec 25, 2012 @ 9:45am 
Originally posted by Blatte:
Alright so I had this exact problem. Here's the solution that worked for me:

Go in your steamapps folder ­-­} common -} chivalrymedievalwarfare -} binaries -} RedistChiv -} DXRedistCutdown -} DXSetup

Then just install everything and you should be able to play with sound.

I hope it helped.

What exactly do you mean by 'install everything'? I ran the .exe's but still no sound working.
Le Hobbit Jul 14, 2013 @ 6:04am 
Originally posted by Blatte:
Alright so I had this exact problem. Here's the solution that worked for me:

Go in your steamapps folder ­-­} common -} chivalrymedievalwarfare -} binaries -} RedistChiv -} DXRedistCutdown -} DXSetup

Then just install everything and you should be able to play with sound.

I hope it helped.

i get to my binaries and i dont seem to have the RedistChiv piece, any advice?
Garret Bobby Ferguson Jul 20, 2013 @ 10:16pm 
He meant this:

C:\Program Files (x86)\Steam\SteamApps\common\chivalrymedievalwarfare\_CommonRedist\DirectX\Jun2010
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Nov 24, 2012 @ 1:41am
Posts: 9