blackmantram Jul 29, 2013 @ 10:41pm
Gamepad Support
Will this game have gamepad support? I definitely loved it but I think it would be better with gamepad.
Showing 1-15 of 22 comments
< >
cprince  [developer] Jul 30, 2013 @ 2:20am 
It's had it for a couple of months now.
default_loser Jul 30, 2013 @ 6:20am 
I was going to make a different thread about this, but when I use a wired XBox controller, all of the buttons and triggers also move my droid...so if I try and hit A or use the left trigger to shoot, the droid also walks in a certain direction. Am I doing something wrong here, or is there a setting I need to change? I've never had a problem in any other game with this controller, it's pretty standard, and it works fine in Ultratron.
cprince  [developer] Jul 30, 2013 @ 6:36am 
hmm, if it works fine in Ultratron I'm not sure why it wouldn't be working in Droid Assault - we've got the same code in there.
default_loser Jul 30, 2013 @ 8:17am 
maybe it's because I'm not hitting the triggers in Ultratron, I dunno...but it's completely unusable in Droid Assault, as the buttons and triggers are also bound to walking directions it seems.
cprince  [developer] Jul 30, 2013 @ 8:32am 
I'm using a standard wired 360 controller here, and it behaves exactly as expected in all 3 arcade games :S
default_loser Jul 30, 2013 @ 1:15pm 
Well I wish I could say the same, but the game is completely unplayable with a controller for me. Is there anybody I could contact for support?
cprince  [developer] Jul 30, 2013 @ 1:27pm 
Well, me :/ But why your controller behaves crazily is completely beyond my ken. It works for all our development machines. We've not twiddled any settings at all, mind - you may have.
default_loser Jul 30, 2013 @ 1:33pm 
I'm not even sure what settings there are to twiddle. This is the only game I've had any controller issues with out of the dozens I've used. I was hoping there was someone I could talk to, because having the developer tell you "Works for me!" after asking for help regarding one of their products not working correctly is pretty frustrating and if I'm honest, a little bit insulting.
cprince  [developer] Jul 30, 2013 @ 2:29pm 
Insulting would be me saying, you're an idiot, you're doing it wrong, but I'm not saying that; I'm saying, we just plugged ours in and they worked, so we don't know why yours doesn't. Really. I have absolutely no idea. We didn't have to do any special code or configuration - they just worked for us. There may be bugs in the underlying library we don't know about (jinput, fwiw), or there may be some settings that you changed a while ago (is there a "reset to defaults" thing?). We just don't know.
default_loser Jul 30, 2013 @ 4:02pm 
I never said you insulted me, I said I find it insulting that I came to you with a technical problem after purchasing your game and got the response of a shoulder shrug and "I dunno, works fine for me!" It's not your words that frustrated me, it's your attitude. I hope you understand that a customer feeling like they're not being taken seriously and being brushed off DOES feel insulted; a simple "I'll look into it" or any attempt to even acknowledge the problem would have gone a long way. From my perspective, I brought up an issue I had, and the response I got basically told me that there is no chance you'll bother trying to fix it or find the root of the problem, and the only conclusion I can draw from that is that buying a future product would be a risk in the case any sort of technical issue arose.

Not trying to start drama, I just want you to see it from the perspective of a customer.
cprince  [developer] Jul 31, 2013 @ 1:56am 
Of course I've looked in to it! That's why I'm saying I don't know. I can't find any reason for your controller to be different to ours. They work for 99% of people, but not you. This leaves me clueless.

If you take a look around the support in all the other subjects I hope you'll be satisfied with the level we provide. But this one has us stumped.
markx2 Nov 28, 2013 @ 8:33pm 
Windows 7, Xbox 360 Wired controller.

I have 5 hours of Ultratron played and the controller "just works".
Droid Assault I have 9 minutes because I cannot work out what is meant to happen with the buttons. In fact while trying different things to write this it crashed - still had music and the top/bottom overlays with score/chassis but the rest was black and ESC did not work.

If I can send you any details I'll happily do so!
cprince  [developer] Nov 29, 2013 @ 12:53am 
Oh-ho, that sounds like a bona-fide crash there - Alli has been meddling with controller support in DA just lately and he might have broken it. There's logs in your user home directory under .droid_assault_1.92 - it'd be grand if you could pastebin them. The err.log in particular.
markx2 Nov 29, 2013 @ 12:56am 
http://pastebin.com/5dxFM9QW - hope it helps?
cprince  [developer] Nov 29, 2013 @ 1:01am 
Perfect :)
Showing 1-15 of 22 comments
< >
Per page: 15 30 50