Lip_Gloss Nov 27, 2013 @ 3:07pm
Save / Load broken? [SOLVED]
After I press Escape the game auto-saves. When I want to continue the game asks if I want to restore previous game. I answer yes.

Problem is the game do not respond to keyboard or mouse after the load (restore). All I can do is press escape and the game makes another auto save (which will also not work).

Is it broken or am I missing something?

(Also I have the Defeated Level 40 Boss but my level unlocks are gone.)
Last edited by cprince; Dec 20, 2013 @ 8:25am
Showing 1-13 of 13 comments
< >
cprince  [developer] Nov 28, 2013 @ 1:53am 
Working fine here - have you got a controller plugged in? Which OS is this?
Lip_Gloss Nov 28, 2013 @ 12:24pm 
Running Win7 64 bit. No controller plugged in. I did restart and exit, restarted steam. Verified cache...

Am I just missing something really simple? Do I need to press certain a key to continue the game after it has loaded and I can see the level and my bots? I mean, the game is running as the range indicator to enemy bots is changing. Still, no response when I move mouse and keyboard.

If I restart "New game" from level one, everything works just fine. Its after a save/load there is a problem.
Last edited by Lip_Gloss; Nov 28, 2013 @ 12:25pm
Lip_Gloss Nov 29, 2013 @ 12:34am 
Yeah, I tried to restore a game just now (on lvl 31 this time). The game loads the level and both graphics and sound is good. Only, I cant move! Keyboard and mouse will not move the bots I have.

Edit: I can start att lvl 31 now by usin the level unlocks. Although, the save/load problem is still there.
Last edited by Lip_Gloss; Nov 29, 2013 @ 12:40am
cprince  [developer] Nov 29, 2013 @ 12:54am 
Hmmm. I have a feeling it thinks you've got a controller attached. I'll poke Alli to investigate it further - we couldn't reproduce it yesterday but we'll have a more thorough search.
Lip_Gloss Nov 29, 2013 @ 1:15am 
Ill try connecting a controller and disconnecting it and see if it helps.
Lip_Gloss Nov 29, 2013 @ 1:27am 
Didn't help. Problem still there. Hm... Strange that the game would think I use a controller only after a restore (save/load).
Last edited by Lip_Gloss; Nov 29, 2013 @ 1:28am
cprince  [developer] Nov 29, 2013 @ 2:06am 
Aha I know what's actually going on here now. Your Player is crashing, and gets removed from the game. Unfortunately the Player is the thing wot listens for joystick / keyboard / mouse input.
Lip_Gloss Nov 29, 2013 @ 2:13am 
Sounds promising... :)
Lip_Gloss Dec 6, 2013 @ 11:36pm 
Any update on this issue?

Also this is consistent for me. It happen everytime I press escape to pause/save the game. Or rather everytime i restore the game from the save.
Last edited by Lip_Gloss; Dec 6, 2013 @ 11:38pm
cprince  [developer] Dec 7, 2013 @ 10:29am 
I'll check on Monday.
cprince  [developer] Dec 20, 2013 @ 7:58am 
Is it fixed now?
Lip_Gloss Dec 20, 2013 @ 8:14am 
I was experimenting with a controller plugged in (trying software emulation) so I wasn't sure what fixed it. But from your comment I guess YOU fixed it. ;)

A great game just became better!
cprince  [developer] Dec 20, 2013 @ 8:25am 
Hurrah!
Showing 1-13 of 13 comments
< >
Per page: 15 30 50