Ultratron > General Discussions > Topic Details
Captain_Coke Mar 25, 2013 @ 5:21pm
Can't start the game "you need new drivers" [solved]
Hello everyone

I'd really like to play this, but everytime I start, I got this message popping : "You need to get new graphic card drivers in order to play Ultratron. Please contact you system vendor for assistance"

The problem is this, I've got the latest nvidia drivers (updated today, the precedent did not work any better). I have never had any OEM display drivers (new win 7 installation from 2 month ago).

Everything is up to date, I tried to verify game cache, restart my computer, uninstall / reinstall the game... no luck. Even tried to deactivate my anti-virus, for what it's worth...

I also tried the demo version, same issue.

Specs :
Win 7 pro 64
I3 3240 @3.5ghz
Geforce GTX 660
8gb ram

[EDIT]: apparently the problem was caused by my monitor using an unusual refresh rate, setting it to 60hz allowed me to start the game once and now it works like a charm.
Last edited by Captain_Coke; Mar 28, 2013 @ 7:03am
Showing 1-15 of 23 comments
< >
cprince  [developer] Mar 25, 2013 @ 5:35pm 
Does the Puppygames version work ok?
Captain_Coke Mar 25, 2013 @ 5:40pm 
no, it even seems to launch itself two times each time I double click on the desktop shortcut... but same message (two time)
Captain_Coke Mar 25, 2013 @ 5:45pm 
Alright, I found an error log in my user folder, how should I transmit it to you?

cprince  [developer] Mar 25, 2013 @ 5:49pm 
Just paste it here will be fine. Or at least the last bit of it, if it "repeats".
Captain_Coke Mar 25, 2013 @ 5:52pm 
from err.log (there's also out.log in that folder)


Tue Mar 26 01:40:36 CET 2013 java.lang.RuntimeException: No OpenGL context found in the current thread.
Tue Mar 26 01:40:36 CET 2013 at org.lwjgl.opengl.GLContext.getCapabilities(GLContext.java:124)
Tue Mar 26 01:40:36 CET 2013 at org.lwjgl.opengl.GL11.glGetString(GL11.java:1770)
Tue Mar 26 01:40:36 CET 2013 at net.puppygames.applet.Game.init(Game.java:985)
Tue Mar 26 01:40:36 CET 2013 at net.puppygames.applet.Launcher.main(Launcher.java:89)
Tue Mar 26 01:40:36 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Tue Mar 26 01:40:36 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 01:40:36 CET 2013 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 01:40:36 CET 2013 at java.lang.reflect.Method.invoke(Unknown Source)
Tue Mar 26 01:40:36 CET 2013 at net.puppygames.installer.installer.GameInstaller.callMainMethodOnIsolatedClass(GameInstaller.java:157)
Tue Mar 26 01:40:36 CET 2013 at net.puppygames.installer.updater.GameDataSync.main(GameDataSync.java:114)
Tue Mar 26 01:40:36 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Tue Mar 26 01:40:36 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 01:40:36 CET 2013 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 01:40:36 CET 2013 at java.lang.reflect.Method.invoke(Unknown Source)
Tue Mar 26 01:40:36 CET 2013 at net.puppygames.installer.installer.GameInstaller.callMainMethodOnIsolatedClass(GameInstaller.java:157)
Tue Mar 26 01:40:36 CET 2013 at net.puppygames.installer.installer.GameInstaller.main(GameInstaller.java:85)
Tue Mar 26 01:40:36 CET 2013 at net.puppygames.installer.updater.GameUpdater.main(GameUpdater.java:8)
cprince  [developer] Mar 25, 2013 @ 6:24pm 
Can you try the Puppygames one again now for me please? (Just run it)
Captain_Coke Mar 25, 2013 @ 6:29pm 
nothing changed....
Captain_Coke Mar 25, 2013 @ 6:31pm 
i paste the new bit of log it generated :


Tue Mar 26 02:30:23 CET 2013 java.lang.RuntimeException: No OpenGL context found in the current thread.
Tue Mar 26 02:30:23 CET 2013 at org.lwjgl.opengl.GLContext.getCapabilities(GLContext.java:124)
Tue Mar 26 02:30:23 CET 2013 at org.lwjgl.opengl.GL11.glViewport(GL11.java:3206)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.applet.Game.resetViewport(Game.java:1909)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.applet.Game.setFullscreen(Game.java:1842)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.applet.Game.initDisplay(Game.java:1774)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.applet.Game.init(Game.java:976)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.applet.Launcher.main(Launcher.java:89)
Tue Mar 26 02:30:23 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Tue Mar 26 02:30:23 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 02:30:23 CET 2013 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 02:30:23 CET 2013 at java.lang.reflect.Method.invoke(Unknown Source)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.installer.installer.GameInstaller.callMainMethodOnIsolatedClass(GameInstaller.java:157)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.installer.updater.GameDataSync.main(GameDataSync.java:114)
Tue Mar 26 02:30:23 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Tue Mar 26 02:30:23 CET 2013 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 02:30:23 CET 2013 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
Tue Mar 26 02:30:23 CET 2013 at java.lang.reflect.Method.invoke(Unknown Source)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.installer.installer.GameInstaller.callMainMethodOnIsolatedClass(GameInstaller.java:157)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.installer.installer.GameInstaller.main(GameInstaller.java:85)
Tue Mar 26 02:30:23 CET 2013 at net.puppygames.installer.updater.GameUpdater.main(GameUpdater.java:8)
Captain_Coke Mar 27, 2013 @ 9:08am 
I still can't play, even since the newest updates (steam and puppygames version) ...
cprince  [developer] Mar 27, 2013 @ 10:31am 
Is the log looking any different this time?
Captain_Coke Mar 27, 2013 @ 2:05pm 
Wed Mar 27 17:04:26 CET 2013 Failed to set fullscreen=true due to org.lwjgl.LWJGLException: Failed to set display mode (-2).
Wed Mar 27 17:04:26 CET 2013 java.lang.IllegalStateException: Display must be created.
Wed Mar 27 17:04:26 CET 2013 at org.lwjgl.input.Mouse.create(Mouse.java:295)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.setFullscreen(Game.java:1837)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.initDisplay(Game.java:1781)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.init(Game.java:974)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Launcher.main(Launcher.java:89)
Wed Mar 27 17:04:26 CET 2013 java.lang.IllegalStateException: Display must be created.
Wed Mar 27 17:04:26 CET 2013 at org.lwjgl.input.Keyboard.create(Keyboard.java:327)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.setFullscreen(Game.java:1842)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.initDisplay(Game.java:1781)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.init(Game.java:974)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Launcher.main(Launcher.java:89)
Wed Mar 27 17:04:26 CET 2013 java.lang.RuntimeException: No OpenGL context found in the current thread.
Wed Mar 27 17:04:26 CET 2013 at org.lwjgl.opengl.GLContext.getCapabilities(GLContext.java:124)
Wed Mar 27 17:04:26 CET 2013 at org.lwjgl.opengl.GL11.glViewport(GL11.java:3206)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.resetViewport(Game.java:1916)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.setFullscreen(Game.java:1849)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.initDisplay(Game.java:1781)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Game.init(Game.java:974)
Wed Mar 27 17:04:26 CET 2013 at net.puppygames.applet.Launcher.main(Launcher.java:89)
Jimbo75 Mar 27, 2013 @ 5:19pm 
i have the same problem and ive also tried all of that, still doesnt work
Jimbo75 Mar 27, 2013 @ 5:20pm 
i can play any other game but puppygame's games
cprince  [developer] Mar 27, 2013 @ 5:24pm 
we're clearly hitting a buggy path in your drivers somehow but what that is I have no idea... is your system "unusual" in any way?
Captain_Coke Mar 27, 2013 @ 5:40pm 
I really don't think my system is unusual in any aspect...

Win 7 pro 64
I3 3240 @3.5ghz
Geforce GTX 660
8gb ram
Intel SSD (180gb)


maybe I've got an unusual refresh rate on my screen (66hz).. but that's all I can see
Showing 1-15 of 23 comments
< >
Per page: 15 30 50
Date Posted: Mar 25, 2013 @ 5:21pm
Posts: 23