Terseus Jul 1, 2013 @ 7:22am
[Linux] Game not running (segmentation fault)
When running the game with the recent beta update a black window appears and closes after 1 second, the same as before the update.

This problem it's old and known to happen in Linux systems with ATI graphics card and the proprietary Fglrx/Catalyst driver, there are some comments in threads about this but are old and doesn't receive enough love for such a serious issue :)

My complete system specs (in spanish, sorry):
Información sobre el procesador:
Fabricante: AuthenticAMD
Velocidad: 3200 Mhz
Procesadores lógicos 4
Procesadores físicos 4
HyperThreading: No compatible
FCMOV: Compatible
SSE2: Compatible
SSE3: Compatible
SSSE3: No compatible
SSE4a: Compatible
SSE41: No compatible
SSE42: No compatible

Información sobre la red:
Velocidad de la red:

Versión del sistema operativo:
Linux (64 bits)
Nombre de kernel: Linux
Versión de kernel: 3.9.8-1-ARCH
Editor de X Server: The X.Org Foundation
Versión de X Server: 11402000
Gestor X Window: KWin
Versión del runtime de Steam: steam-runtime-release-i386_2013-05-08

Tarjeta de vídeo:
Controlador: ATI Technologies Inc. ATI Radeon HD 5700 Series

Versión de controlador: 4.2.12337 Compatibility Profile Context 9.012
Densidad de color del escritorio: 24 bits por píxel
Frecuencia de actualización del monitor: 59 Hz
Identificador del fabricante: 0x1002
Identificador del dispositivo: 0x68b8
Número de monitores: 1
Número de tarjetas de vídeo lógicas: 1
Resolución de pantalla principal: 1920 x 1200
Resolución de escritorio: 1920 x 1200
Tamaño de pantalla principal: 20,39" x 12,76" (24,02" diag)
51,8cm x 32,4cm (61,0cm diag)
No se ha detectado la memoria VRAM principal

Tarjeta de sonido:
Dispositivo de sonido: Realtek ALC1200

Memoria:
RAM: 12020 Mb

Varios:
Idioma de la IU: Español
LANG: es_ES.UTF-8
Micrófono: Not set
Espacio total en disco disponible: 388468 MB
Bloque libre más grande en el disco: 12476 MB

Output of the game when running from a console:
Loading asset /home/me/.local/share/HotlineMiami/hotline.cfg from disk
Setting breakpad minidump AppID = 219150
dlopen failed trying to load:
/home/me/.local/share/Steam/linux32/libsteam.so
with error:
/home/me/.local/share/Steam/linux32/libsteam.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
libsteam.so
with error:
libsteam.so: cannot open shared object file: No such file or directory
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197982447814 [API loaded no]
Initializing ClusterManager
Loading Localization Data
CSplashScreen::Initialize
Initializing SurfaceManager
Segmentation fault (core dumped)

Please developers, if more information are needed just ask ^_^
Showing 1-15 of 47 comments
< >
Rutger  [developer] Jul 1, 2013 @ 7:45am 
Hello Terseus,

Sorry to hear you're still running into issues. Can you accept my friend invite and I'll pm you a new build to try.
ChemBro Jul 1, 2013 @ 7:57am 
Same problem here. Arch Linux 64bit, Radeon HD 6670, Catalyst 13.6b.
C20H25N3O ( 。∀゚ ) Jul 1, 2013 @ 9:00am 
I'm encountering the same problem for the past two beta updates now :(


Processor Information:
Vendor: AuthenticAMD
Speed: 3600 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Unsupported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 13.04 (64 bit)
Kernel Name: Linux
Kernel Version: 3.9.0-030900-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11304000
X Window Manager: KWin
Steam Runtime Version: steam-runtime-release-i386_2013-06-28

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 7800 Series

Driver Version: 4.2.12337 Compatibility Profile Context 13.101
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x6819
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20,04" x 11,26" (22,95" diag)
50,9cm x 28,6cm (58,3cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 12014 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 300326 Mb
Largest Free Hard Disk Block: 63181 Mb

nevermind, that's an entierly different problem. It doesn't want to load the x86_64 lib I have installed :(((


EDIT
output from console:

./Hotline: error while loading shared libraries: libvorbisfile.so.3: cannot open shared object file: No such file or directory
Last edited by C20H25N3O ( 。∀゚ ); Jul 1, 2013 @ 9:17am
Toost Inc. Jul 1, 2013 @ 9:36am 
For me as well, Arch x64, Catalyst 13.4

Seems to be ATI related?
Cookie Jul 1, 2013 @ 10:44am 
Same Problem Arch x64, Intel Integrated Graphics.
x64 related? Maybe missing dependencies?

[edit] Problem for me only exists with VSync enabled
Last edited by Cookie; Jul 1, 2013 @ 11:05am
Terseus Jul 1, 2013 @ 11:13am 
Originally posted by Cookie:
Same Problem Arch x64, Intel Integrated Graphics.
x64 related? Maybe missing dependencies?

[edit] Problem for me only exists with VSync enabled

I tried with and without vsync, in window and in fullscreen, but I have no luck, it doesn't work :(

I don't think it's dependencies or x64 related, probably it's yet another bug in the crappy Catalyst drivers combined with something the game does when allocate resources at launch.
Toost Inc. Jul 1, 2013 @ 11:39am 
Thing is, I've had the game working some time before the Humble Bundle sale, so things possibly went wrong in between updates.
Ancu Jul 1, 2013 @ 12:48pm 
Yeah, I get the segfault in XQueryExtension too (most likely because the Display *dpy is NULL). Can you somehow check for that?
Renderwut Jul 1, 2013 @ 12:49pm 
Originally posted by Toost Inc.:
Thing is, I've had the game working some time before the Humble Bundle sale, so things possibly went wrong in between updates.
Or maybe you did update the video card driver? Older catalyst versions worked for me, the new ones don't.
Toost Inc. Jul 1, 2013 @ 7:46pm 
hm, possible but I don't think so, the 13.4 drivers have been out since April, and I got my last achievement 24th of May, the only changes to the package (catalyst-total on the AUR) since then have been cosmetic.

How old are we speaking?

Besides that the Catalyst drivers have always been wonky with this game, the game severly slowed down if there were any enemies alive on the proprietary ATI drivers back when the game would still run.
damn_pastor Jul 2, 2013 @ 4:19am 
Arch Linux 64bit Nvidia, everythings allright.
Xnet Shadow Jul 2, 2013 @ 5:15pm 
I can't launch the game, i get a missing executable error
Toost Inc. Jul 2, 2013 @ 7:43pm 
@Xnet Shadow,

You need to opt-in to the beta. The passcode is 'hlm', with l being the lowercase L.
Xnet Shadow Jul 2, 2013 @ 10:19pm 
thanks, but now the problem is that when i open the game a black window appears and crashes.
C20H25N3O ( 。∀゚ ) Jul 3, 2013 @ 2:53am 
Here's what I get from the Humble Bundle version

Loading asset /home/frank/.local/share/HotlineMiami/hotline.cfg from disk
Initializing ClusterManager
Loading Localization Data
CSplashScreen::Initialize
Initializing SurfaceManager
Segmentation fault (core dumped)
Showing 1-15 of 47 comments
< >
Per page: 15 30 50
Date Posted: Jul 1, 2013 @ 7:22am
Posts: 47