jlittlej Jun 8, 2013 @ 12:55pm
[SOLVED] Controls completely not working in Ubuntu
Hi all, this is driving me completely nuts.

When I start Hotline Miami on Ubuntu 13.04 I can navigate the menu with arrow keys and hit the Enter key to start a game. When I get the guy saying 'I'm gonna show you how to kill people' I cannot do anything. None of the keys on my keyboard or buttons on my mouse cause the game to advance.

The only key that works in game is ESC to bring up the menu. I can then use WASD to move the selection between RESUME and QUIT, but I have no way of selecting them (Enter does nothing, no other key on the keyboard or button on the mouse does anything).

Can anyone even tell me what the default controls are?!

If I launch the game and go to OPTIONS then CONTROLS, I'm presented with a title WALK, a player model on the screen and a round disc with an L in it. Whatever key I press on the keyboard, the text W.A.S.D (ENTER TO RECONFIGURE) flashes up for a tiny instant then disappears. I have no way to exit this screen (ESC does nothing but cause the WASD message to flash up again).

Can anyone help?! What the *$"£$ is going on?
Last edited by jlittlej; Jun 16, 2013 @ 1:41pm
Showing 1-3 of 3 comments
< >
ACID360 Jun 9, 2013 @ 8:20am 
same happening to me aswell some thing gone wrong i was half way through the game this really sucks !
jlittlej Jun 16, 2013 @ 1:44pm 
I finally got to the bottom of this.

I have an HP laptop with an accelerometer inside. For some very strange reason it seems that Ubuntu installs this accelerometer as a joystick, so my problem was that the game was constantly receiving input from this 'joystick' and it was stopping me reconfiguring the controls.

I'm sure I need to blacklist a module to fix this permanently, but for a temporary fix I simply deleted this device:

sudo rm /dev/input/js0
Helena Feb 21 @ 7:04am 
(Apologies for resurrecting zombie thread)

Instead of removing the device, there's a configuration option in the launcher: "Joystick Handle". By default it seems to grab onto the first joystick that's attached. (which for me is also an accelerometer -- something I didn't know until I bought a joystick, tried to configure it, and was very confused by the js0 entry until I moved my laptop)

Simply select "No Joystick" and the problem goes away (without having to unlink an input device... )
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jun 8, 2013 @ 12:55pm
Posts: 3