PizzaDude [Linux] May 24, 2013 @ 5:53pm
No sound in Linux Beta
No sound in Linux Beta.
Using Linux Mint 13 32-bit which is based off of Ubuntu 12.04 so the audio should work.
Any fix?
Showing 1-15 of 17 comments
< >
Stümmel im Getümmel May 25, 2013 @ 11:03am 
same here. opensuse 12.3
satsun *2098* May 25, 2013 @ 1:20pm 
Sounds is working fine for me. I'm in Ubuntu 13.04.

Maybe try updating/installing libopenal. Recently I installed libopenal1 and libopenal-dev so see if that helps.
PizzaDude [Linux] May 25, 2013 @ 3:29pm 
I have both, still no sound.
satsun *2098* May 25, 2013 @ 5:34pm 
Another thing I've done in the past was I downloaded an OpenAL GUI that I think basically edits one of the OpenAL configuration files. One major change I made via that GUI was I removed various sound APIs (or something) and only left PulseAudio for OpenAL to use. For example, when I start Amnesia it would show many sound options but after removing ALSA and some other stuff in the OpenAL config GUI now Amnesia only shows PulseAudio as being available.

Not sure, but maybe that's forcing Hotline Miami to use PulseAudio. I can't remember the name of that GUI. I may have also downloaded libalut-dev and libalut0. That's the OpenAL Utility Toolkit; maybe that GUI is part of that. Not currently in Linux to test.

Sorry for being so vague, I still have a lot to learn about Linux.
Last edited by satsun *2098*; May 25, 2013 @ 5:35pm
Rutger  [developer] May 25, 2013 @ 5:51pm 
We included an OpenAL library with the latest build. Can you try deleting it in the lib folder? Otherwise run Hotline from a terminal and check if the output hints to any possible errors.
PizzaDude [Linux] May 25, 2013 @ 6:11pm 
Tried deleting the lib, still no sound. Here's output from the terminal http://paste.ubuntu.com/5702073/
satsun *2098* May 25, 2013 @ 7:44pm 
Ahh, I installed alsoft-conf to configure OpenAL settings (apt-get alsoft-conf to install). For "Backend in use" I took out everything except for PulseAudio. I also removed libopenal.so.1 and ran the game and I still got sound.

I'm running a Creative X-Fi with a 7.1 speaker configuration. This game gives me sound in all speakers without upmixing enabled. Doesn't do that in Windows in the beta.
PizzaDude [Linux] May 25, 2013 @ 7:54pm 
I have sound in all the other games I have on Steam for Linux, just not Hotline Miami.
Stümmel im Getümmel May 26, 2013 @ 7:33am 
Started the game in a window... sound works fine now. I have absolutely no idea why

//edit: i got it, restart the pc after install and the sound is working
Last edited by Stümmel im Getümmel; May 26, 2013 @ 7:46am
satsun *2098* May 26, 2013 @ 9:36am 
I'm playing fullscreen with Unity. Are you guys using a different UI?
PizzaDude [Linux] May 28, 2013 @ 5:23pm 
Still no sound for me. Linux Mint 13 32-bit with Cinnamon DE.
PizzaDude [Linux] May 28, 2013 @ 6:08pm 
Even tried re-installing and rebooting my pc.
Stümmel im Getümmel May 29, 2013 @ 8:32am 
try to close every program like firefox o.s. w could block the sound and start hotline miami again. works for me so far
PizzaDude [Linux] May 29, 2013 @ 11:45am 
I did. No luck.
PizzaDude [Linux] May 30, 2013 @ 9:10am 
I checked pulseaudio volume control and Hotline Miami is playing it's audio in a non-existant soundcard http://i.imgur.com/9FMsT8W.png (the Nvidia HDMI one)
It should be playing the audio to the Built-in Audio Analog Stereo one instead.
There is no way to change this that I know of.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: May 24, 2013 @ 5:53pm
Posts: 17