Mighty Jan 29 @ 11:52am
Linux(BUG)
Okay so i just installed hotline miami off the humble bundle. I then set it up. realized i had 64bit and so its instantly broken. I then followed the readme instructions, which you should include you MUST add :i386 after all of those it tells you to install for 3.10 ubuntu as ia32-libs no longer works.

Then after i figured that out. I open up the game, tried all different variations of the opens. Open, black screen, instant crash all within 1-2 seconds or so. Have done apt-get update, updated drivers, everything i can possibly do i can.

Still doesn't work. this is the error and hopefully someone can help me out with this.

mighty@MightyComp:~/Desktop/Hotline$ ./hotline_launcher
Loading asset /home/mighty/.local/share/HotlineMiami/hotline.cfg from disk
Initializing ClusterManager
Loading Localization Data
CSplashScreen::Initialize
Initializing SurfaceManager
Segmentation fault (core dumped)
/home/mighty/.local/share/HotlineMiami//home/mighty/.local/share/HotlineMiami/mighty@MightyComp:~/Desktop/Hotline$

Showing 1-1 of 1 comments
< >
wlayton27 Jan 29 @ 1:49pm 
Ugh. "Segmentation fault" is the worst error message ever written. I'm guessing it is probably the fact that you're running a dual-library OS; I tried running dual libraries (x86/64) in Slackware a year ago and eventually gave up in frustration.

It sounds to me that you've followed the instructions by adding :i386 in a config file to reference the game to the 32-bit libraries? Have you made sure that those 32-bit libraries are installed and located in the correct directory? I remember having to recompile 32-bit libraries to create the 64-bit libraries and then rename those original files and move them to a lib-i386 folder. But that wasn't Ubuntu, it was Slackware, and it was a major pain to do all the work manually.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: Jan 29 @ 11:52am
Posts: 1