Hotline Miami

Hotline Miami

View Stats:
Hotline Miami & Xbox 360 controller bug(s)
First off, I haven't come across a thread that posed a problem similar to mine but if one exists and has been answered to, sorry for the duplicate.

Some people have reported that their wired Xbox 360 controller works perfectly with this game. I seem to have the issue that despite several in-game prompts, the interaction button is B instead of A. Now this in itself proposes no problem but it seems that the ability to interact works very randomly. All the keys seems to be a bit off (that is, the controller configuration shown in the menu does not really represent the true configuration) and I'm wondering if there are others who are perhaps struggling with the issue or who have even solved the issue. Normally I could probably "get by" with this but as 1) I'm stuck in the level right after the prelude and 2) this is precisely because I can't seem to interact despite systematically pressing every button on my controller, I am getting more and more frustrated.

I've installed the Xbox 360 Accessories Software 1.2 but that hasn't improved the situation at all. I've also tried creating a file named "xbox2" to the root of the game directory (as this was advised in another thread) but this hasn't done anything either.

I'm running the game on 64-bit Win 7.

< >
Showing 1-8 of 8 comments
(VSC)Repconn Jan 25, 2014 @ 10:18am 
Same problem on my Win7 32bit. I just passed the level by using mouse & keyboard instead. Nontheless it is very annoying to play with the controller set up like this. I've just emailed support, I hope this somehow gets fixed.
BlackberryDragon Feb 11, 2014 @ 11:33am 
I'm having this issue too, with a regular Microsoft 360 wireless controller, on Windows 7 64-bit. Current drivers, no problems in other games.

Moving (L), Punch/Swing/Shoot (RB), Pickup/Throw (LB) are fine, but then...

Interact/Menu Select (A) is now (B)
Drop/Menu Back (B) is now (X)
Lock (R Stick Button)/(RT) is now (A)/(Start)
Look Offscreen (LT) is now (Back)
Pause (Start) is now (R Stick Button)
and Aim (Right Analog) is now LT and RT analog triggers LOL

Not really keen on playing this game with Keyboard/Mouse, I like twin-stick shooter functionallity.

Haven't found anyone with a solution so far.
calledpipes Mar 21, 2014 @ 2:08pm 
Hey, OK so i had this problem (B button working for A, right analog stick not working at all), and I found a solution.

There were some people here talking about their controllers not working, and some suggestion that it was interference with COMODO Defence +. As I was running COMODO, i decided to see if this was the solution. Simply closing COMODO and running the game offline didn't work, but after uninstalling COMODO and swapping anti-virus, my controller works perfectly!

So yeah, I'll bet you all here have COMODO.

Hope this helps.
(VSC)Repconn Mar 21, 2014 @ 2:55pm 
Wow, thats a pretty good diagnosis! I hate COMODO and now I finally have a reason to uninstall it. Thanks calledpipes!
Redacted Mar 21, 2014 @ 4:13pm 
Anybody have an ideas for someone who doesn't have COMODO and is still getting this problem?
BlackberryDragon Mar 21, 2014 @ 7:43pm 
I was able to get it to work without having to uninstall COMODO. The trick is to prevent COMODO from running the game exe in the sandbox by listing it as a trusted application. Then it doesn't interfere at all, and my controls are normal.

Thanks to calledpipes for pointing me in the right direction.
Kermit Vandervort Apr 1, 2014 @ 10:01am 
Thanks, calledpipes & BlackberryDragon for your input. I have COMODO and yes, it was the culprit all along. Having listed the game EXE as a trusted application resolved the issue for me. Thanks a ton!
Cornwallis Mar 16, 2015 @ 11:32pm 
Just booted up this game for the first time in a long time to finally finish it and I have the same problem with the switched around controls on my X360 wired controller. I'm running Windows 7 64-bit, already had the updated controller drivers, tried the "xbox2" file in the game directory, and I don't have COMODO. I use Avast! for anti-virus and it doesn't seem to have any feature that let's me list and EXE as a trusted application. I also tried setting the game EXE's to "Run as administrator." But that also didn't fix it. I've got no clue what's causing it.

The good news is this is only the case for the updated version. The original version works perfectly for me, and I just ran from Chapter 5 all the way to the end.

So I dunno if this is real helpful a year after the fact, but if the COMODO solution doesn't work or is not relevant for anyone reading this, try the original version option when starting the game!
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Jan 22, 2014 @ 8:01pm
Posts: 8