Scribblenauts Unlimited

Scribblenauts Unlimited

View Stats:
Jamie Rose Mar 17, 2014 @ 11:12pm
Crash Dump Error
This game worked fine when I first bought it. I launched it today and it crashed and I got some unhandled exception error. I tried changing the resolution in launch options but this did not, nor did running in a window. I tried Deleting Local Content and reinstalling, I also tried DXSetup, but none of these helped. Saw files from creepy sources claiming a fix, but that just screamed trojan to me.

Can anyone help? I'm getting a little tired of my games not working.
< >
Showing 1-12 of 12 comments
cyanic Mar 24, 2014 @ 5:25pm 
Hmm, so the regular fixes don't work. Maybe upload the crash dump somewhere, and I'll see if I can make sense of it.
Jamie Rose Mar 24, 2014 @ 7:39pm 
how does one do that?
cyanic Mar 26, 2014 @ 3:51pm 
There should be a folder with the dumps in the game's folder. Pick one of the dumps and upload it to a file sharing site, then link it here.

Edit: You are looking for files with a .dmp extension.
Last edited by cyanic; Mar 26, 2014 @ 5:45pm
Jamie Rose Mar 29, 2014 @ 11:42am 
Can you point to a place where I can upload this?
cyanic Mar 29, 2014 @ 1:05pm 
Dropbox, MediaFire, or any other service you can think of. It doesn't matter where you upload it.
cyanic Mar 29, 2014 @ 5:57pm 
Preliminary analysis results:

Crash time: Feb. 29, 2014 11:38:37 AM
RVA: Scribble.exe+0x392e78
Exception code: 0xc0000005 (access violation)
Description: The game tried to call the IDirect3DTexture9::GetSurfaceLevel() method on a null object. I.e. a texture that was supposed to be loaded wasn't, and the game assumed it was.

The crash dump is only a Minidump, and as such is missing a lot of contextual information. It'd be more useful if I got a full dump. In the meantime, try updating your graphic card driver, and maybe run the game on its own (that is, not launching it from Steam) and see if things change. I should have ask for this first, though: at what point does the game crash? When you launch it? When you click on a certain thing? What do you see immediately before the game crashes? I noticed you said that you changed from full-screen to windowed, which implies the game can at least get into the main menu and the settings menu. So does your game crash when you click on the continue button? Or when you create a specific item?
Jamie Rose Mar 29, 2014 @ 6:12pm 
The game crashes at launch.
I launch the game, I see a black screen, it returns to desktop and I get a crash dump error message.
I changed the launch mode from steam settings (-windowed and I have changed it back to no avail.)
I cannot get into the game at all.
Launching from the folder gives me the same error, as does launching it from anywhere else.

My graphics drivers are updated, I've updated them 30 times over because of issues like this. My card is a Radeon 4200 which is a fossil and I'm sure I will now be told to replace. I cannot do that because I have no money. It would also not explain why the game ran perfectly fine when I first bought it.
cyanic Mar 30, 2014 @ 11:28am 
What if you remove your save games? Just rename the saves folder and the game will recreate it.
Jamie Rose Mar 30, 2014 @ 12:19pm 
This seems to have worked, so I guess my save data was corrupt. Does this mean I have to start all over again?

It just said that custom objects can't be saved if steam is not running, but steam is running. What gives? Also I don't think I have any custom objects.
Last edited by Jamie Rose; Mar 30, 2014 @ 12:29pm
cyanic Mar 30, 2014 @ 2:14pm 
You can try moving back individual files from your old saves and see which one crashes. Then just throw that one out and move the rest back. As for the Steam not running error, try rebooting.
Jamie Rose Mar 30, 2014 @ 4:37pm 
Everything fixed now, except for the save data. Which seems to be irrevocably damaged.
I guess that means I have to start over again. =(

In any case, thanks for your help.
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: Mar 17, 2014 @ 11:12pm
Posts: 12