Hazmat Jul 2, 2013 @ 2:14pm
Can't even start the game
I'm wondering if anyone else has had this issue, just downloaded the JAO for the first time and upon trying to play I'm taken to the screen where you choose your merc specialty and give him a name and company nickname. Upon doing that and pressing the "play now" button I consistently get a message saying that the company name is invalid and already in use and kicks me back to that opening screen. I've tried using dozens of company names, even totally nonsensical ones, and keep getting the same message. What do I do?
Showing 1-4 of 4 comments
< >
weare138tony Jul 27, 2013 @ 12:14pm 
i keep getting the same thing. have you found a solution?
T⋱R⋱⋰'A♫P !łłŁćĆć⋱ Jul 28, 2013 @ 9:33am 
this is bulls**t
T⋱R⋱⋰'A♫P !łłŁćĆć⋱ Jul 28, 2013 @ 9:36am 
they blocked steam version becouse they want players who likes game to get browser version witch is completly unplayable in pvp without spending some big euros (you buy gold for euros and when you want reskill merc its 139 gold at lvl 23~ haha and campaign pack costs around 423 gold so wtf ) ??
weare138tony Jul 28, 2013 @ 11:00am 
yesterday I just smashed buttons for the names and it worked. I'm on steam too. So the names turned out like: wliefgweui lol. but the game is a bit disappointing.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50