mattias_oh Nov 13, 2013 @ 2:08am
[Linux] Installation of Adobe Air on 64-bit Ubuntu 13.10
Hi

For me neither the steam installation (~/.steam/root/SteamApps/common/DefendersQuest/install.sh) nor the easily alvailabe deb-file of Adobe air (https://launchpad.net/ubuntu/lucid/i386/adobeair/1:2.6.0.19170-0lucid1) nor the helpful guides for 13.04 (http://www.thepowerbase.com/2013/06/how-to-install-adobe-air-in-ubuntu-13-04/ & http://ubuntuhandbook.org/index.php/2013/07/install-adobe-air-linux-mint-32-64-bit/) worked and I couldn't start the game :(

It all seamed to boil down to that the packages "ia32-libs" and "libhal1" are no longer available in 13.10.

"Libhal1" doesn't seem to be necessary, or at least I didn't install it on purpose :P
"ia32-libs" seems to have been just a 'meta package', i.e. a link to a bunch of other packages that are still available. I randomly took pieces of advice from http://community.secondlife.com/t5/Second-Life-Viewer/Ubuntu-13-10-and-the-death-of-ia32-libs/m-p/2269003 & http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10 & http://ubuntuforums.org/showthread.php?t=2181649

And now the game works :)

Summary: To install Adobe Air on 64-bit Ubuntu 13.10 simply follow http://ubuntuhandbook.org/index.php/2013/07/install-adobe-air-linux-mint-32-64-bit/ BUT instead of step 3 install the following packages:

"""
sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 gstreamer0.10-pulseaudio:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386 gstreamer0.10-ffmpeg:i386
sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386
sudo apt-get install libnss3-1d:i386
"""
* Disclaimer: Some of those packages might not be needed

Good Luck!

Showing 1-5 of 5 comments
< >
skyghis Jan 4, 2014 @ 3:55am 
Thanks !

This worked for me after downloading almost 100Mo of 32 bit libraries from repos
Adobe Air really suxxx on linux :/ and will probably no longer work in a few years :(

Devile Jan 26, 2014 @ 2:34pm 
Thank you! I finally got it working
anthony Jan 26, 2014 @ 3:47pm 
Ugh. GTK and Pango 32bit... I think I just gave up. I run Slackware with no package management and I'm not about to deal with bulking up my 32b support enough to handle those beasts... just for this game. I agree, AIR sucks. I should have looked into the forums here before buying. As a dev I like to rely on a minimal stack: OpenGL and SDL.
z_mikowski Feb 1, 2014 @ 8:58pm 
I found this to work 100% for installing Adobe Air on 64-bit Kubuntu 13.10:

http://tkalin.com/blog_posts/installing-adobe-air-and-elance-tracker-on-ubuntu-13-10-saucy-salamander-64-bit

Spread the word! :)
Last edited by z_mikowski; Feb 1, 2014 @ 9:46pm
Naceira Apr 1, 2014 @ 4:28pm 
Tons of thanks!
Showing 1-5 of 5 comments
< >
Per page: 15 30 50