PlanetSide 2 > General Discussions > Topic Details
TheTechnician Nov 27, 2012 @ 2:53pm
Tested out Planetside 2 and 'Ultra' settings, 1080p video and some screenshots
Tested out some found 'Ultra' settings, that can apparently make the game look a lot better, if you don't mind editing an .INI file in the games' directory (it seems to be allowed and fine to do so). I was still getting sluggish performance that everyone seems to be getting, in larger firefights. But, I messed with the found settings a bit more and tweaked them to help optimize performance and here is the end result vid: http://www.youtube.com/watch?v=VPmlMrCn6vw

A few screenshots:
http://steamcommunity.com/sharedfiles/filedetails/?id=110437744&insideModal=1
http://steamcommunity.com/sharedfiles/filedetails/?id=110438132&insideModal=1
http://steamcommunity.com/sharedfiles/filedetails/?id=110441070&insideModal=1

The [what seems to be] original 'Ultra' settings are found here:
http://pastebin.com/XFkf8sYJ
^ That is a website where people can upload and share text files and you can simply save it as the text file it is and rename it UserOptions.ini and put it in your
<whatever drive steam is on>//ProgramFiles/Steam/steamapps/common/PlanetSide2
folder. (Make a backup copy of the original if you want)

Since those settings resulted in great-looking graphics, I wanted to keep most of it, but simply changed some of the more CPU-utilizing effects. My changes were all under the section Rendering (you can just copy and paste this 'Rendering' section over your 'Rendering' section in your UserOptions.ini if you want to):

[Rendering]
GraphicsQuality=5
TextureQuality=0
ShadowQuality=3
RenderDistance=2000.000000
Gamma=0.000000
MaximumFPS=60
UseLod0a=0
VSync=0
OverallQuality=-1
LightingQuality=3
FogShadowsEnable=1
EffectsQuality=5
TerrainQuality=3
FloraQuality=3
FloraDistanceScale=2.000000
ModelQuality=5
ParticleQuality=5
ParticleLOD=5
MotionBlur=1
BlurQuality=3
MotionBlurQuality=3
VerticalFOV=74
AO=1
AmbientOcclusionQuality=3
AOQuality=3
GpuPhysics=1

* Update: we have put our own Pastebin text file of the entire UserOptions.ini up here (simply save it/rename it to UserOptions.ini): http://pastebin.com/6j9aHVav
** For even more performance while still looking nice overall, try inserting these settings, most of which release even more CPU demand from the game:

RenderDistance=1000.000000
FogShadowsEnable=0
EffectsQuality=2
ParticleQuality=2
ParticleLOD=2


As you can see, most of the textures, complexity and other effects are up, but I lowered a few things like the terrain and shadows (these seemed to use the CPU quite a bit) and the draw distance, which still looks good at "2000". With these settings, I now had a much smoother, still-pretty result!

Try it out if you don't mind making a few changes to that file, I hope it works for you. Enjoy!


Will come back and try to answer questions off and on


Last edited by TheTechnician; Nov 28, 2012 @ 11:35am
Showing 1-8 of 8 comments
< >
[TE] Kuraudo Nov 27, 2012 @ 3:10pm 
People have noticed that setting shadowquality to 0 in that ini file results in, on average, +40fps gain. I was running at 30 myself and am now seeing 50 in large battles. So, not quite what they are claiming, but still huge.

Have you tried running those settings with shadowquality set to 0?
TheTechnician Nov 27, 2012 @ 3:23pm 
Originally posted by TE Kuraudo:
People have noticed that setting shadowquality to 0 in that ini file results in, on average, +40fps gain. I was running at 30 myself and am now seeing 50 in large battles. So, not quite what they are claiming, but still huge.

Have you tried running those settings with shadowquality set to 0?

Interesting! No I haven't, I just lowered them from the original '5' that was in the 'ultra' settings that were found. Guess what I'm off to test? :) Thanks
Selvator Nov 27, 2012 @ 4:37pm 
I was wondering, is TextureQuality the only setting that actually get's "better" when put on a lower value?
I tested it myself and the texture look a lot better on 0 then on a higher value.

I wonder why they did that :/
TheTechnician Nov 27, 2012 @ 5:50pm 
Originally posted by Selvator:
I was wondering, is TextureQuality the only setting that actually get's "better" when put on a lower value?
I tested it myself and the texture look a lot better on 0 then on a higher value.

I wonder why they did that :/

It's telling the game to not filter it at all, I believe, similar to how NVIDIA and AMD/ATi both have a "High Quality" setting for their Texture Filtering Quality category in their respective Control Panels that, in essence, tell it to load the texture into the VRAM and not process it at all (if possible).

Setting it to 4 or 5 (I am assuming as I don't specifically know this game's engine) is just a 'good/lots of processing' setting, which would be nice but never looks as good as 'just load it and don't touch it', heh.

The drawback is that some textures can be quite large in size and take up lots of VRAM/RAM then, which leaves less for calculations, hence putting on the filtering (at a low setting) is usually faster performance.
Last edited by TheTechnician; Nov 27, 2012 @ 6:00pm
TheCreatureFever Nov 27, 2012 @ 8:49pm 
Thanks for bring the setting shadows thing to 0 to my attention. Seems that it really helped my frame rate out. Getting a solid 25-35 fps during firefights now!

I'm a bit unsure of what to set my texture quality to though. If most of my issue seems to come from a under powered CPU, would setting it to 0 take some of the stress off it?
TheTechnician Nov 27, 2012 @ 9:47pm 
Originally posted by TE Kuraudo:
People have noticed that setting shadowquality to 0 in that ini file results in, on average, +40fps gain. I was running at 30 myself and am now seeing 50 in large battles. So, not quite what they are claiming, but still huge.

Have you tried running those settings with shadowquality set to 0?

I found I got about another 5-10 fps in big firefights, but I didn't like having no shadows at all, heh. Thanks though for the idea.


Originally posted by ZombieFever:
Thanks for bring the setting shadows thing to 0 to my attention. Seems that it really helped my frame rate out. Getting a solid 25-35 fps during firefights now!

I'm a bit unsure of what to set my texture quality to though. If most of my issue seems to come from a under powered CPU, would setting it to 0 take some of the stress off it?

The texture quality wouldn't really affect the CPU, as textures (the 'pictures' being put on the sides of everything) are usually handled by the videocard and RAM. A high value will have lots of processing/passes done to it and it might look good, but 0/noprocessing usually looks even better, as less is being done to the texture (in your videocard settings, you'd have to set it as HighQuality, which is the same thing). It would be faster, performance wise, to set any texture quality in any game to Low - but then it wouldn't look as good. Higher and it will look better, but performance is slower. It would not really be a CPU-concerned change though.
Last edited by TheTechnician; Nov 27, 2012 @ 9:50pm
MrMango Dec 4, 2012 @ 4:47pm 
Well, as soon as it gets in medium-size firefights I'm dropping down to about 10-25 fps. It's really awful. I've tried nearly everything but it just don't getting better.
My System Specs are:
CPU: AMD X4 955 3,2ghz
GPU Radeon HD 6970 2GB OC
RAM: Kingston 8 GB

These are my settings:
[Rendering]
GraphicsQuality=4
TextureQuality=0
ShadowQuality=0
RenderDistance=1005.000000
Gamma=0.490000
MaximumFPS=250
UseLod0a=0
VSync=0
OverallQuality=-1
LightingQuality=4
FogShadowsEnable=0
EffectsQuality=4
TerrainQuality=4
FloraQuality=4
ModelQuality=4
ParticleLOD=4
MotionBlur=0

Hopefully someone can help me out here, I really want to enjoy the game but it's nearly impossible right now. :(
TheTechnician Dec 4, 2012 @ 10:18pm 
Originally posted by dObMr.Mango:
Well, as soon as it gets in medium-size firefights I'm dropping down to about 10-25 fps. It's really awful. I've tried nearly everything but it just don't getting better.
My System Specs are:
CPU: AMD X4 955 3,2ghz
GPU Radeon HD 6970 2GB OC
RAM: Kingston 8 GB

These are my settings:
[Rendering]
GraphicsQuality=4
TextureQuality=0
ShadowQuality=0
RenderDistance=1005.000000
Gamma=0.490000
MaximumFPS=250
UseLod0a=0
VSync=0
OverallQuality=-1
LightingQuality=4
FogShadowsEnable=0
EffectsQuality=4
TerrainQuality=4
FloraQuality=4
ModelQuality=4
ParticleLOD=4
MotionBlur=0

Hopefully someone can help me out here, I really want to enjoy the game but it's nearly impossible right now. :(

A few things you can turn down that will help optimization are the lighting, effects, terrain, flora and particles. These use the CPU more and it seems the game isn't quite CPU-streamlined yet. Your videocard should be fine. Hope it helps!
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Nov 27, 2012 @ 2:53pm
Posts: 8