PlanetSide 2 > General Discussions > Topic Details
August!? Mar 9, 2013 @ 6:01am
Planetside 2 wont start, no crashes or errors it just closes after startup.
Hey guys any help would be appreciated. I just got a new desktop with an I7 3770 8 Core 3.4Ghz with a nvidia 620 Gtx. And after I launch the game through steam it runs the launcher then I press the play button and i get this please wait game loading box. After that the launcher just closes and there are no errors or anything. I have reinstalled PS2 i have added exception on my firewall. I have turned off my firewalls with no result. Help?
Showing 1-13 of 13 comments
< >
Gipsy Jaeger Mar 9, 2013 @ 7:56am 
Have you tried checking the file integrity on the steam games tab?
Your rig should handle it!
August!? Mar 9, 2013 @ 10:23am 
Yeh i have multiple time and It always says 4 files failed to validate, reaquiring. Then it downloads 3 of those 4 files. No clue what the last one is though.
boom!!!!!!!!!!!!!! Mar 9, 2013 @ 10:30am 
i had the same problem but i got it to worck i hat to get rid of planet side 2 then i dowload it again then it worck.
August!? Mar 9, 2013 @ 10:31am 
Originally posted by breavill:
i had the same problem but i got it to worck i hat to get rid of planet side 2 then i dowload it again then it worck.

I have tried this 3-4 times now with no luck.
boom!!!!!!!!!!!!!! Mar 9, 2013 @ 10:34am 
dont no it might be a bug on planet side 2
boom!!!!!!!!!!!!!! Mar 9, 2013 @ 10:36am 
just played planet side 2 everyone dissconeted but we all had internet worcking
boom!!!!!!!!!!!!!! Mar 9, 2013 @ 10:37am 
triying again
August!? Mar 9, 2013 @ 10:43am 
Well it certainly isnt anything to do with there servers I installed the latest patch through the launcher just fine and but i always can never launch the game.
allen.hallman Mar 9, 2013 @ 1:45pm 
turn off your virus protection then run the game. I cant run the game with my antivirus on it just wont load
August!? Mar 9, 2013 @ 3:07pm 
I have tried this with no luck
I Never Asked For This Mar 10, 2013 @ 12:40pm 
same prob
DOPELEFIRE Aug 6, 2013 @ 6:15am 
i got the same thing and looking about i found out that if u have a EU account u can't run the steam launcher for some stupid reason! download it from the PS2 eu site and it should work altho i just had a error message saying that it can not b run on windows or mite not b installed properly! will update!
ownomics Aug 6, 2013 @ 6:18am 
Originally posted by DOPELEFIRE:
i got the same thing and looking about i found out that if u have a EU account u can't run the steam launcher for some stupid reason! download it from the PS2 eu site and it should work altho i just had a error message saying that it can not b run on windows or mite not b installed properly! will update!
Apparently an edit to a certain file allows one to play on euro servers through steam.
I don't know what it is though.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Mar 9, 2013 @ 6:01am
Posts: 13