tomislav.uzelac  [udvikler] 13. sep 2013 kl. 6:24am
Game Update 1.04c (Sep13, 2013)
Hi all,

I've just pushed an update that fixes some outstanding issues with the game and the scenario editor (listed below). I kindly ask you to report if you run into problems.

Changes:
* Manual update (regarding new mechanics in Red Turn, Scenario Editor)
* Fix UI crash involving unit deployment and undoing a move
* Fix AI crash with some community scenarios
* Fix brackets issue with the Scenario Editor (AltGr on Italian/Croatian and possibly other keyboards)
* Enable deleting units in the Scenario Editor on the Mac (CTRL-D)
* Linux sound improvements

Especially wrt/ linux sound, we are now shipping all the required shared libraries (to the best of our knowledge). Additionally, we've defined a command line option you can use to set the audio driver:

--audiodriver alsa
(you can use: alsa, dma, dsp, esd, oss, pulse)

People who still have sound issues on linux - please let us know if this helps.


Cheers,

Tomislav
Viser 1-15 af 22 kommentarer
< >
danielreader 13. sep 2013 kl. 6:35am 
I just tried this out after the update and in the computer's (Russian) 1st turn under the scenario Stalingrad Campaign - Battle of Kursk it crashes when the Russian units are being reinforced. Below is the crash log.

OS: Win7 64-bit
CPU: Intel Core i7 975 @3.33 GHZ
Memory: 6GB


Traceback (most recent call last):
File "uoc.py", line 151, in <module>
File "widgets\app.pyo", line 33, in Run
File "widgets\root.pyo", line 691, in Mainloop
File "dispatch\dispatcher.pyo", line 349, in send
File "dispatch\robustapply.pyo", line 47, in robustApply
File "widgets\app.pyo", line 83, in Slot_ANIMATE_cr
File "coroutine.pyo", line 55, in switch
File "game\app.pyo", line 1421, in _cr_observer_ai
File "ai\ai.pyo", line 278, in real_tick
File "ai\ai.pyo", line 299, in play_move
File "ai\sequence.pyo", line 102, in play_move
File "game\state.pyo", line 48, in wrapper
File "game\state.pyo", line 1769, in AddSteps
File "game\state.pyo", line 557, in apply_action_record
File "game\state.pyo", line 1778, in check_add_steps
RuntimeError: check add_steps: illegal reinforcement
Traceback (most recent call last):
File "uoc.py", line 151, in <module>
File "widgets\app.pyo", line 33, in Run
File "widgets\root.pyo", line 691, in Mainloop
File "dispatch\dispatcher.pyo", line 349, in send
File "dispatch\robustapply.pyo", line 47, in robustApply
File "widgets\app.pyo", line 83, in Slot_ANIMATE_cr
File "coroutine.pyo", line 55, in switch
File "game\app.pyo", line 1421, in _cr_observer_ai
File "ai\ai.pyo", line 278, in real_tick
File "ai\ai.pyo", line 299, in play_move
File "ai\sequence.pyo", line 102, in play_move
File "game\state.pyo", line 48, in wrapper
File "game\state.pyo", line 1769, in AddSteps
File "game\state.pyo", line 557, in apply_action_record
File "game\state.pyo", line 1778, in check_add_steps
RuntimeError: check add_steps: illegal reinforcement
Horgan 13. sep 2013 kl. 8:19am 
Norton 360 Premier Edition reports an "Suspicious.Cloud.7.F"-infection in the "uoc.exe".
tomislav.uzelac  [udvikler] 13. sep 2013 kl. 8:25am 
Hi guys,

the Norton issue is well known. Every time we issue an update, Norton thinks it's a virus (actually it's Steam DRM that trips it up). It's safe to ignore this:

http://unityofcommand.net/wiki/FAQ#Antivirus_alert_on_uoc.exe_file

As for the AI crash... sigh. We'll look into it some more next week. If there are any other community scenarios affected, please report.


Thanks,

Tomislav
rim6o 14. sep 2013 kl. 1:53pm 
I still don't have sound on Linux. Fedora 19 x86_64. I reverted 2 of 3 workarounds I used to get the sound 'working' previously which were http://steamcommunity.com/app/218090/discussions/0/810924133956658243/ (the original post, moving libs) and http://unityofcommand.net/forums/viewtopic.php?p=6337#p6337 (the cfg file). I don't know how to revert the http://steamcommunity.com/app/218090/discussions/0/810924133956658243/#c810924133956725135 (export SDL_AUDIODRIVER=alsa).

Then I tried to set different launch parameters in Steam options for UoC:
(no parameter at all)
--audiodriver alsa
--audiodriver pulse

Nothing worked.
RangerX3X 20. sep 2013 kl. 5:43pm 
Oprindeligt skrevet af Horgan:
Norton 360 Premier Edition reports an "Suspicious.Cloud.7.F"-infection in the "uoc.exe".
I had the “Suspicious.Cloud.7.F” issue as well, and as I am too lazy to figure out my AV settings, I just waited a couple of days and then did a “Verify Integrity of Game Cache” which restored one file and now I can play the game again.
Spooner 21. sep 2013 kl. 3:18am 
@rim6o: Sorry, we were unable to replicate the error here, so tried to implement the community suggested workarounds as best we could (I tried in a Mageia3 x64 VM). Did you have the sound working via the existing workarounds or has it never worked for you?

Hopefully it will work for some people or at least make the existing, manual, workarounds easier for people.
Spooner 21. sep 2013 kl. 6:02am 
Oops, I misspoke there. I actually was able to replicate the error, but was NOT able to fix it with the workarounds found in these forums. Thus, I wasn't able to check if my fixes were actually effective...
rim6o 22. sep 2013 kl. 12:19pm 
@Spooner
Hi! Thanks for responding.

My post #4 provides all the possible details, but to answer your question from post #6 directly:
The following alone makes sound appear in UoC on my system http://unityofcommand.net/forums/viewtopic.php?p=6337#p6337 (the post by karryall).

You should develop something better than this because it's a very intrusive workaround, AFAIK basically killing pulse audio component system-wide.
Spooner 22. sep 2013 kl. 12:47pm 
Yes, I absolutely couldn't implement that sort of intrusive fix for UoC, so I had very limited options (and not really pinning down the root cause, any more than the players who made suggestions).
tomislav.uzelac  [udvikler] 25. sep 2013 kl. 11:21am 
@danielreader: I am trying to reproduce your issue with no luck.

I'm thinking perhaps the update didn't go through as intended on your machine.

Can you please check this by going to Main Menu > Credits. At the bottom of that page, it should say at least 1.04c.


Thanks,

Tomislav

cjsilvester1 29. sep 2013 kl. 12:14am 
No problems here on my mac - still can't work out how to acheive brilliant victory in leningrad scenario - Turn 3 objective for one city seems impossible.
danielreader 7. okt 2013 kl. 1:08pm 
Oprindeligt skrevet af tomislav.uzelac:
@danielreader: I am trying to reproduce your issue with no luck.

I'm thinking perhaps the update didn't go through as intended on your machine.

Can you please check this by going to Main Menu > Credits. At the bottom of that page, it should say at least 1.04c.


Thanks,

Tomislav

Sorry for the delay in response; it is showing 1.04c. I made sure of that before reporting the bug. Note that I have been able to play through that scenario a few times, but I just recreated the bug again today (I would say that the issue happens about 60% of the time, and always during the Russian's first turn reinforcement phase). I have not noticed it on any other scenario, so it may be a specific unit that causes the crash.
tomislav.uzelac  [udvikler] 8. okt 2013 kl. 11:17am 
Alright, thanks, I guess I'll give it a few more tries.

It would be a great help if I could get a savegame from right before the AI moves. That is: complete your turn, save the game and only then click End Turn.

Then if it crashes, please post both the savegame and the log here.

If I cannot get it to crash on any of my machines (seem to be a rare thing to happen), then this is our only hope of nailing this.

Thanks!
danielreader 9. okt 2013 kl. 8:31am 
I have created this save file and crash log; how do I post this on this forum?
tomislav.uzelac  [udvikler] 9. okt 2013 kl. 10:17am 
Oh, sorry, I forgot you cannot post files on this forum.

Please email the files to support at unityofcommand.net.

Thanks for helping, it's much appreciated!
Viser 1-15 af 22 kommentarer
< >
Per side: 15 30 50