Unity of Command

Unity of Command

İstatistiklere Bak:
tomislav.uzelac  [geliştirici] 27 Oca 2013 @ 10:20am
Linux Font Issue
Hi all,

we've had a look at the font issue with Linux and re-compiled Pango (font library) to work correctly on all Linux systems. We've tested this successfully on Fedora 16 x86, but would appreciate your help in testing on your own operating systems if you have had font problems with the game. The faster we get feedback on this, the faster we can push a fixed version. Thank you for your help!

http://dl.dropbox.com/u/33370854/uoc/uoc_font_fix_2013_01_27.tgz

Included are some re-compiled versions of the Pango libraries shipped with Unity of Command, switching to these should hopefully solve this issue.

libpango-1.0.so.0
libpangoft2-1.0.so.0
libpangocairo-1.0.so.0

Copy these files over the original versions in 'Unity Of Command/bin'.

For the Steam beta installation, this will be:
'~/.steam/steam/SteamApps/common/Unity Of Command/bin'
< >
46 yorumdan 1 ile 15 arası gösteriliyor
Works perfectly on Fedora 18 x86_64, Thanks!
The font-fix works on Fedora 17 x86_64 as well.
works Fedora 18 x86_64 as well. thanks a lot.
Did not work under openSUSE 12.3 RC1 64bit
Hello. This does not work on Archlinux x86_64, but removing bin/libpangoft2-1.0.so.0 (as suggested in your forum) worked for me.
Did not work on Linux Mint 13 x86_64.
ArchLinux x86_64, the game won't start.
Made it worse for me on Archlinuxx86_64. It used to load with screwed up fonts, now it won't even load. If I ldd on libpango:

libpango-1.0.so.0:
linux-gate.so.1 (0xf76f5000)
libgobject-2.0.so.0 (0xf765a000)
libgmodule-2.0.so.0 (0xf7655000)
libglib-2.0.so.0 (0xf755c000)
libm.so.6 => /usr/lib32/libm.so.6 (0xf74ce000)
libthai.so.0 => not found
libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf74b2000)
libc.so.6 => /usr/lib32/libc.so.6 (0xf7301000)
libffi.so.6 (0xf72fa000)
libdl.so.2 => /usr/lib32/libdl.so.2 (0xf72f5000)
libpcre.so.3 (0xf72b8000)
librt.so.1 => /usr/lib32/librt.so.1 (0xf72af000)
/usr/lib/ld-linux.so.2 (0xf76f6000)

Note the "not found" for libthai of all things.

Removing libpangoft2 didn't help.
For those people who found this fix didn't work, could you please try just replacing libpangoft2-1.0.so.0 (but not replacing the original libpango and libpangocairo files). Someone reported that that worked on Archlinux and I have to be hopeful that it will work for everyone.

I only managed to test the fix on Fedora and Ubuntu (Ubuntu, of course, worked out of the box as well) before asking people to test it, so thanks for the feedback!
Spooner tarafından gönderilen ileti:
For those people who found this fix didn't work, could you please try just replacing libpangoft2-1.0.so.0 ...

Yay!!!, works great. Archlinux x86_64
Yup, that worked for me on Archlinux x86_64
Ralgo & Headwound Harry: Thanks for testing again. Glad it worked this time ;)
What an excellent installation bug…
Steam aka Developers should use the native libraries of the linux distribution (if they insist in a lib in the game dir via symlink) or should build a fork of these libs working with all distributions…
like firefox with e.g. xulrunner

at least there should be a listing what libs are used …
without ldd

You are lost

besides _Not_ all Tunixers know about ldd and how to do fixes on their Installation

Yours humble
Kubuntu (updated to 12.10)
pre-fix game CTD with no error after the font-bugged splash screen (assume it's the CD-key screen).
Post-fix game CTD immediately with no error.
Just replacing libpangoft2-1.0.so.0 solved the issue on Mageia 3 as well...
< >
46 yorumdan 1 ile 15 arası gösteriliyor
Sayfa başına: 15 30 50