Unity of Command > Algemene discussies > Details van topic
Casp 23 dec 2012 om 1:37vm
Linux here--nice looking game but no sound...
I am playing this on Ubuntu and the game installed and plays well w/ the notable exception of no sound. I have done the superficial check in the game options to ensure that the settings are set for music and sound effects.

If anyone else has experienced this problem and solved it I would appreicate knowing how you did that.

Thanks so much...
1-11 van 11 reacties weergegeven
< >
Devi710 23 dec 2012 om 9:31nm 
I've run this on two different Linux computers (Ubuntu 12.04, Ubuntu Gnome Remix 12.10) without any problems.

Have you tried checking your settings in Ubuntu: System Setttings => Sound ?
Casp 28 dec 2012 om 12:31vm 

I apologize for the late reply--it's the season...

I haven't played the game as such, but my system sound is perfect (w/ the exception of rough-edged WINE) for virtually anything else--streams, pods. videos, games, Google Voice, DOSBox, CDs, DVDs, etc....

I am using the KDE evironment, but, still, it works for everything else.

I am at a loss about this--it just flat out doesn't work... :(

nilac 17 feb 2013 om 12:15nm 
I also had no sound (on Arch64). The console error was:

ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so

This fixed the problem for me, hope it helps:
pacman -S lib32-alsa-plugins
mkdir -p /usr/lib/i386-linux-gnu/alsa-lib/
ln -s /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so /usr/lib/i386-linux-gnu/alsa-lib/
otto_struve 19 feb 2013 om 2:34nm 
I had the same error message as nilac. I tried his solution and now I get another error:
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Does anybody know what to do?
[HS]=>Brice 25 feb 2013 om 11:25vm 
I get this issue too on Mageia 3 64 bits...
OzFalcon 25 feb 2013 om 3:06nm 
Something to do with 32 bit libs not found on 64 bit system?
To tell the truth, Ubuntu has MANY MANY MANY bugs like this.
Other distros have a fair share too. ie where libraries are not linked etc.
With the availablility of steam/games, this problem should be more noticable.
And hopefully some of the people at Ubuntu will spend more time ensuring
they are done. Rather than focusing on the next release - Which still has the same
problems because they never fixed them 1st time round.
The never ending lack of quality distro model!
perrylea 6 apr 2013 om 9:29vm 
Ugh. I too am experiencing the audio issues.....
PulseAudio was on my system but in the wrong directory for UOC.
I created a symbolic link to the library as noted above and now I am also getting:
PulseAudio: Unable to connect: Connection refused.

Developers??? Any workaround?
guberart 11 apr 2013 om 12:47vm 
I've got the same situation on chakra (on mint 13-14 works perfect), tried fix by nilac, but sound doesn't appear.
Now it works!
In my case solution was to stop music playback in browser.
2Ben 8 mei 2013 om 10:03vm 
Any news on this ? I really don't like to play without sound, so basically I can't play UoC, which is a shame.
Migrus 12 mei 2013 om 12:42nm 
Also had sound issues on Fedora 18, 64-bit

First had the problem with libasound_module_pcm_pulse.so not being found, so installed 32bit versions of that:
yum install alsa-plugins-pulseaudio.i686

But the paths are different from what UoC expects, so added:
ln -s /usr/lib /usr/lib/i386-linux-gnu

This then produces the "Unable to connect" error. Found a tip on a forum to use pulse as a server.
load-module module-native-protocol-tcp auth-ip-acl=

default-server =

Restart pulseaudio and then sound worked. There is still some output but that seems harmless:
"there is no soundcard"

Sound works fine without this magic for other games or videos. It worked out of the box on a recent Ubuntu so maybe something with distribution defaults that are different or library versions since UoC includes a whole bunch of normally shared libraries.

For debugging I found it easier to launch "bin/uoc" directly from:
~/.steam/steam/SteamApps/common/Unity of Command
2Ben 1 jun 2013 om 7:05vm 
I posted another solution in another thread, but since this one has more activity, here it is again:

The fix is just to replace UoC's libSDL-1.2.so.0 by your system one, via a symlink:

cd [UoC path]/bin
mkdir backup
mv libSDL-1.2.so.0 backup (just in case)
ln -s /usr/lib/libSDL-1.2.so.0 libSDL-1.2.so.0

Depending on your distro your system lib can be ion another folder. This is for OpenSuse. Do a locate libSDL to find yours, and choose the 32bits one (i.e. NOT in something like /usr/lib64/)

By the way, you also have to set SDL_AUDIODRIVER to alsa:

Launch UoC, enjoy !
1-11 van 11 reacties weergegeven
< >
Per pagina: 15 30 50