2Ben May 8, 2013 @ 5:53pm
[FIX] No sound in Linux
Hi all, after checking around and comparing to other games that had the same issue, it appears that UoC was built with a broken SDL lib, or at least one that doesn't support Alsa correctly.
The fix is just to replace UoC's libSDL-1.2.so.0 by your system one, via a symlink:

cd [UoC path]/bin
mkdir backup
mv libSDL-1.2.so.0 backup (just in case)
ln -s /usr/lib/libSDL-1.2.so.0 libSDL-1.2.so.0

Depending on your distro your system lib can be ion another folder. This is for OpenSuse. Do a locate libSDL to find yours, and choose the 32bits one (i.e. NOT in something like /usr/lib64/)

Launch UoC, enjoy !
Showing 1-7 of 7 comments
< >
2Ben May 8, 2013 @ 5:58pm 
By the way, you also have to set SDL_AUDIODRIVER to alsa:
export SDL_AUDIODRIVER=alsa
rim6o Jul 18, 2013 @ 10:16am 
Thanks for the tip but it didn't work on my system.
~$ locate libSDL
/usr/lib/libSDL-1.2.so.0
/usr/lib/libSDL-1.2.so.0.11.4
/usr/lib/libSDL2-2.0.so.0
/usr/lib/libSDL2-2.0.so.0.0.0
/usr/lib64/libSDL-1.2.so.0
/usr/lib64/libSDL-1.2.so.0.11.4
/usr/lib64/libSDL_image-1.2.so.0
/usr/lib64/libSDL_image-1.2.so.0.8.4
/usr/lib64/libSDL_ttf-2.0.so.0
/usr/lib64/libSDL_ttf-2.0.so.0.10.1
~$ cd '/mnt/sdfsadxc/Steam/SteamApps/common/Unity of Command/bin'
bin$ mkdir backup
bin$ mv libSDL-1.2.so.0 backup
bin$ ln -s /usr/lib/libSDL-1.2.so.0 libSDL-1.2.so.0
bin$ export SDL_AUDIODRIVER=alsa
bin$
2Ben Jul 19, 2013 @ 9:24am 
OK I will probably sound stupid but did you actually run UoC after ?
2Ben Jul 19, 2013 @ 9:28am 
also, check your alsa volume levels with alsamixer, and make sure no other program plays music or sound at the same time
rim6o Jul 19, 2013 @ 9:54am 
Thanks for your response!

Yes, I ran UoC after that. After reboot in fact. No other application is was using sound then (checked in the gnome mixer/applications). Alsa mixer levels were up.
rim6o Jul 26, 2013 @ 1:14pm 
rim6o Sep 11, 2013 @ 9:15am 
The problem is the one that worked (from post #6) is a tedious workaround! It basically disables pulseaudio system-wide!

The devs should fix this! This is ridiculous.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50