BIT.TRIP Presents... Runner2: Future Legend of Rhythm Alien
Prower Feb 26, 2013 @ 11:14pm
Occasional Crashing on Linux
Every couple hours the game crashes on me.

I am currently on Nvidia 304.64-0ubuntu0.2 drivers on my GTX 570. Any help would be appreciated.
Showing 1-15 of 21 comments
< >
polomi Feb 26, 2013 @ 11:54pm 
I have crashed to every 30 minutes or so.

I am on Lubuntu 12.10, have a Nvidia GTX 460, using drivers version 310.14.

The game crashes when I collide with an obstacle (not always, it's rare, but it always happen during a collision). The character gets stuck and the sound of the collision then repeats over and over. I can press start, and I hear the sound of the pause menu popping up, but it doesn't show up on the screen.

I am not sure if you have the same kind of crashes, since you didn't describe yours, but voilà, that's what is happening to me.
Nevon Feb 27, 2013 @ 8:50am 
I also experienced a crash, although it was unrelated to colliding with an obstacle. I believe it happened when Steam created a "Steam news" window in the background, but I can't be sure. What I do know is that the music and sound effects kept playing as normal, but the display froze completely and runner2 started taking up 98.9% of my CPU until I killed it.

I would very much like to know where to file a bug report and how I can collect the necessary information for debugging.
Prower Feb 27, 2013 @ 10:53am 
Originally posted by skedar:
I have crashed to every 30 minutes or so.

I am on Lubuntu 12.10, have a Nvidia GTX 460, using drivers version 310.14.

The game crashes when I collide with an obstacle (not always, it's rare, but it always happen during a collision). The character gets stuck and the sound of the collision then repeats over and over. I can press start, and I hear the sound of the pause menu popping up, but it doesn't show up on the screen.

I am not sure if you have the same kind of crashes, since you didn't describe yours, but voilà, that's what is happening to me.

That is exactly what I'm experiencing. Hopefully it gets fixed soon.
fac3l3ss Feb 27, 2013 @ 11:56am 
First congrats to the devs. Great game. Thank you for bringing the game for linux in day 1. I also get a crash from time to time. Another issue: i'm playing the game with the xbox 360 gamepad, and the game pauses automatically from time to time, this is annoying and I hope it gets fix soon.
Last edited by fac3l3ss; Feb 27, 2013 @ 1:10pm
Prower Feb 27, 2013 @ 12:09pm 
Originally posted by fac3l3ss:
First congrats to the devs. Great game. Thank you for bringing the game for linux in day 1. I also get a crash but in a specific level in world 1. Another issue: i'm playing the game with the xbox 360 gamepad, and the game pauses automatically from time to time, this is annoying and I hope it gets fix soon.

I had the same problem, but I just assumed my batteries were low on my controller so I switched to Keyboard. Don't have any batteries on me at the moment, so I don't know if this is the case or not.
wombat marx  [developer] Feb 27, 2013 @ 12:44pm 
crash: next time anyone gets this crash, please email us a log file (instructions here[support.gaijingames.com]) to help us debug it

auto-pause: can someone who's getting this give me some more info? how often does it happen, can you unpause and continue playing, what version of libSDL do you have?

thanks!
fac3l3ss Feb 27, 2013 @ 1:15pm 
Originally posted by wombat marx:
crash: next time anyone gets this crash, please email us a log file (instructions here[support.gaijingames.com]) to help us debug it

auto-pause: can someone who's getting this give me some more info? how often does it happen, can you unpause and continue playing, what version of libSDL do you have?

thanks!

I think it happens roughly every 5 minutes or less, I can definitely unpause and continue playing...

I'm using Ubuntu 12.04 LTS with 3.5 kernel, and the version of libSDL is 1.2.14-6.4ubuntu3 from ubuntu repository
Last edited by fac3l3ss; Feb 27, 2013 @ 1:17pm
Prower Feb 27, 2013 @ 1:22pm 
Originally posted by wombat marx:
crash: next time anyone gets this crash, please email us a log file (instructions here[support.gaijingames.com]) to help us debug it

auto-pause: can someone who's getting this give me some more info? how often does it happen, can you unpause and continue playing, what version of libSDL do you have?

thanks!

How exactly do I obtain a log file? Is it automatically generated somewhere?
wombat marx  [developer] Feb 27, 2013 @ 3:33pm 
the game's log file on linux can be found in ~/.local/share/gaijin_games/runner2/ (unless you have XDG_DATA_HOME set, in which case it's $XDG_DATA_HOME/gaijin_games/runner2/). those folders are typically hidden, so if you can't find them and you are comfortable with the command line, you can "cp ~/.local/share/gaijin_games/runner2/log.txt ~/runner2.log" to copy the log to your home directory.
fac3l3ss Feb 27, 2013 @ 3:44pm 
AUTO-PAUSE issue: i think I found out what triggers the pause menu, the screensaver. In my case I use xscreensaver instead of gnome-screensaver since I'm addicted to electricsheep.

Anyway, I disabled the screensaver with caffeine, (also need to do this for other games I play with a gamepad) (ppa: https://launchpad.net/~caffeine-developers/+archive/ppa), and it seems that I don't have the auto-pause issue anymore. Nonetheless, it would be nice if the game could disable the screensaver by itself.
Last edited by fac3l3ss; Feb 27, 2013 @ 4:01pm
Prower Feb 27, 2013 @ 5:00pm 
Originally posted by fac3l3ss:
AUTO-PAUSE issue: i think I found out what triggers the pause menu, the screensaver. In my case I use xscreensaver instead of gnome-screensaver since I'm addicted to electricsheep.

Anyway, I disabled the screensaver with caffeine, (also need to do this for other games I play with a gamepad) (ppa: https://launchpad.net/~caffeine-developers/+archive/ppa), and it seems that I don't have the auto-pause issue anymore. Nonetheless, it would be nice if the game could disable the screensaver by itself.

I have my screen set to turn off after two minutes of inactivity. I changed that to never turn off my screen and now it works perfectly! Thanks!
ash Feb 27, 2013 @ 6:09pm 
The auto-pause is definitely caused by the screensaver. I use caffeine as fac3l3ss described and haven't had any problem since.

I've also had the freeze/crash happen a couple of times, as others reported. The screen freezes during play and the same short sound plays over and over. I can drop into a console and attach gdb to the process, and the program appears to be running through its loop - it's in different functions each time I attach. I'm emailing the log file.

Oh, and great effing game. Thanks for the checkpoints. I can't go through the pain Runner 1 caused me again.
ash Feb 27, 2013 @ 6:35pm 
Just had another lock-up, this time in the world screen. This time the music played for a few seconds then stopped completely, and the game wouldn't respond to any input, and the process seemed to be hung in the kernel in some libc call.
wombat marx  [developer] Feb 27, 2013 @ 6:48pm 
ok, the game has been updated and should now suspend the screensaver (via xdg-screensaver), so hopefully the auto-pause and screensaver crash are fixed. will keep hunting for the other one(s). thanks for your patience.
fac3l3ss Feb 28, 2013 @ 2:39am 
Originally posted by wombat marx:
ok, the game has been updated and should now suspend the screensaver (via xdg-screensaver), so hopefully the auto-pause and screensaver crash are fixed. will keep hunting for the other one(s). thanks for your patience.

Thanks! :D
Showing 1-15 of 21 comments
< >
Per page: 15 30 50