BIT.TRIP Presents... Runner2: Future Legend of Rhythm Alien
Canta Dec 1, 2013 @ 9:55am
[GNU/Linux] - Unplayable game: screensaver AND pause every 5 seconds
Last night i've bought the Runner2+ost+dlc1 pack.

I'm on a Ubuntu 12.04 x64 system, with nVidia 319 drivers for a 9800 GT GPU.

When i try to play runner2, it constantly fires a screensaver every ~5 secs. This is noticeable in windowed mode. If the game is in fullscreen mode, the screensaver does not trigger in front of the game, but it starts to auto-pause itself, making it unplayable. Also on fullscreen, when the game ends, there's about 2 or 3 tries of running a screensaver.

It's interesting to note that the game does not fires the screensaver i've set on my system. I'm using glmatrix with xscreensaver, as i do from 2008 or so. The game, however, fires some random 3D screensavers, like tentacles or flying toasters.

I've checked the list of processes involved in this problem, and i can see there's two instances of xgd-screensaver disabling the same window id. Also, theres a "sleep 50" command running.

Checking discussions about this, i saw some people pointing to caffeine in order to disable screensaver. I've installed it, and added "~/Steam/SteamApps/common/bittriprunner2/runner2" to the list of processes to watch for, all without success: it starts a third instance of xdg-screensaver for the same window id.


Is there anything i can do?
Thanks in advance.