BIT.TRIP Presents... Runner2: Future Legend of Rhythm Alien

BIT.TRIP Presents... Runner2: Future Legend of Rhythm Alien

View Stats:
Arteista Jan 11, 2014 @ 4:59pm
Xbox 360 controller won't work.
I've just got my brand spanking new controller called Afterglow and after many attempts looking up on internet, I cannot seem to find a solution for my controller to work. Of course, I've tried everything and I mean everything. Uninstall drivers, install that new driver, edit that file, drag it over to the other app, put your password in twice. And not to mention, input the ID numbers as well.

Nothing seems to be working so it looks like I won't be able to play this game unless I get help :c

Anyone can help me on this?

Thanks!

EDIT: It's on Mac.
Last edited by Arteista; Jan 15, 2014 @ 5:28am
< >
Showing 1-13 of 13 comments
Arteista Jan 15, 2014 @ 5:28am 
♥♥♥♥, forgot to mention it's on mac.
issue Jan 15, 2014 @ 10:51am 
Same for me on linux. Controller works in other games (super meat boy, joe danger) but not in Runner 2
Is it only in runner2 for you or other games aswell? you could try configuring your controller in steam big picture mode
Arteista Jan 15, 2014 @ 11:30am 
I've just installed other games onto my Mac. Nothing works. Had to look online for driver. Did everything from youtube. Still not working. :/
Segata Sanshiro Jan 19, 2014 @ 6:38am 
I have the same problem, same controller but on Linux. Works on every other game out of the box, but for this game it just doesn't pick it up.

Also tried installing drivers and did nothing. Tried big picture mode configuration and nothing. I can only conclude that this is a problem with the game on Mac and Linux. Would like an answer too.
ODDity Jan 19, 2014 @ 2:49pm 
same here, PS2 dualshock controller though with USB converter on linux, works for super meat boy and lots of others, not so here :s

One option is configuring QJoypad for to emulate the keyboard...
Segata Sanshiro Jan 20, 2014 @ 1:25am 
Originally posted by ODDity:
same here, PS2 dualshock controller though with USB converter on linux, works for super meat boy and lots of others, not so here :s

This is a different issue though. This is a Xbox360 controller which should (and does) work out of the box on games with controller support. You shouldn't have to map buttons or anything for this, it should just work.
issue Jan 20, 2014 @ 2:13am 
If you are on Linux or Mac and your controller works normal everywhere but not in Runner 2, try this tip. Solved the issue for me. http://steamcommunity.com/app/218060/discussions/0/864975632474746130/#c810938082731049471
Segata Sanshiro Jan 20, 2014 @ 3:38am 
This looks like the exact fix needed for this!

Thing is, when I put in the second line, it throws out a syntax error:

bash: syntax error near unexpected token `newline'

And then the "runner2.new" gives an unknown command, but I'm guessing it's not a command, but a file.

Do you know why that is? Not familiar with perl, so don't know where to begin. I'll post on the link you sent to see if I get an answer there.
issue Jan 20, 2014 @ 7:58am 
perl -pi -e 's/Xbox 360 Wireless /Generic X-Box pad\0/' < runner2 > runner2.new
this should be the command you are running. it inputs runner2 searches and replaces a string and outputs runner2.new. make sure you enter this in one line
Segata Sanshiro Jan 20, 2014 @ 12:03pm 
Ah, feel so stupid haha. Thanks a lot, works flawlessly now.

Now just need to figure out how to make it less blurry so I can play more than 30 mins at a time without my eyes commiting suicide.
theblackkamikaze Jan 21, 2014 @ 1:26am 
http://www.motioninjoy.com/ Have you tried this program... I don´t know if it is also usable on mac (will check it out) but it is usable with windows.
pecosdave Jan 22, 2014 @ 8:26pm 
The QJoypad fix just worked for me!
< >
Showing 1-13 of 13 comments
Per page: 15 30 50