Democracy 2 > General Discussions > Topic Details
Gnostici Jul 27, 2013 @ 6:10pm
Windows 8: full screen hides the interface
This game worked properly in Windows 7. In Windows 8, when it is run full screen, it still has the top bar for a window (that shows maximize, minimize, close), and that bar hides the game's interface. In the actual game, all the buttons at the top right part of the screen are drawn behind the UI element. I have found no mention of this anywhere online, and running in compatibility mode does not resolve the issue.
Showing 1-13 of 13 comments
< >
MajorMajorx2 Jul 27, 2013 @ 10:04pm 
I'm having the same problem on my widescreen laptop as well. The same thing happens when I run Kudos 2. Can't seem to find a specific fix for this online other than the developer saying Windows should do a forced re-size (which it isn't).
jesse9o3 Jul 27, 2013 @ 11:23pm 
Play the game in windowed mode to fix this. Not ideal but it works.
MajorMajorx2 Jul 28, 2013 @ 6:28pm 
I wish it was as easy as that. Even if I toggle to Windowed mode, the top of the screen is still cut off and I can only see half of the icons.
Gnostici Jul 28, 2013 @ 11:29pm 
In windowed mode, I can't get the window to a high enough resolution to be comfortably legible on my screen. The interface works, but it's not as enjoyable.
Burger King Sex 79 Jul 29, 2013 @ 6:09pm 
I want to play but the windowed and cut off fullscreen drives me nuts.
Mercenary X Aug 10, 2013 @ 6:08pm 
To fix this, uninstall Windows 8, find an oem of Windows 7Pro, install windows 7 pro, enjoy game.
MajorMajorx2 Aug 14, 2013 @ 7:57pm 
What helpful advice.
Xykon Oct 4, 2013 @ 7:56am 
I got this Working in Windows 8 and here is what I did:

1) Right click on Democracy 2 in steam, click properties. Then click on the "Local Files" tab, and click "Browse Local Files". This will open your Democracy 2 game directory in Windows Explorer.
2) Right click on Democracy2.exe and select "Troubleshoot Compatibility".
3) Windows will scan the executable and determine a compatibility level. Click "Try Recommended Settings".
4) Windows will now tell you it's guessed Windows XP Service Pack 3 Compatibility would be best, and you must click "Test the Program".
5) This may prompt you for administrative privlidges, if so click okay.
6) Now the game will run. Go into Options and Un-select Full Screen Mode. This should immediately pop the game into Windowed Mode.
7) now start a new game, and click next until you get to the screen with the buttons across the top. If you can see ALL of those buttons, you're fixed! If you only see half of those buttons, then I'm sorry, you'll need to debug further.

I hope this helps!
Jessica Oct 7, 2013 @ 12:10pm 
I have the same problem in windows 8. I tried your solution, Xykon, but it didn't work for me. I also tried running it in windows 7 mode...still top of screen is cut off.
Xykon Oct 7, 2013 @ 4:34pm 
OH darn, Sorry. Not sure what else it could be.
Jessica Oct 8, 2013 @ 1:01pm 
It's okay. Thanks for your help, anyway.
DogSlobba Jun 20 @ 4:15pm 
Originally posted by Gnostici:
This game worked properly in Windows 7. In Windows 8, when it is run full screen, it still has the top bar for a window (that shows maximize, minimize, close), and that bar hides the game's interface. In the actual game, all the buttons at the top right part of the screen are drawn behind the UI element. I have found no mention of this anywhere online, and running in compatibility mode does not resolve the issue.

lol Windows 8. Nothing works properly in Windows 8.
CivlDX Jul 6 @ 4:25pm 
This issue stil hasn't been resolved. Hopefully people with Windows 8 see this before buying the game.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50