Democracy 2 > General Discussions > Topic Details
ShadyKiller Nov 30, 2012 @ 5:44pm
Game crashes as soon as i click the play button on steam
game opens black screen comes on then closes and says "Game is not working" and Windows tried to find a solution but it just closed and said it couldnt find a problem any help?
Showing 1-12 of 12 comments
< >
mghop Dec 31, 2012 @ 10:29pm 
It crashed first time I played to. But just try again and it works also do not hit escape at menu.
ShadyKiller Jan 1, 2013 @ 12:01am 
yea it was wierd because a couple of days later i played it and it worked but maybe just glitchy
OkiDokiDa Jan 3, 2013 @ 11:09am 
I got mine to work, but when i come to the main menu i cannot procced. non of the buttons on the bottom works... Anyone have the same problem or know how to fix this?
iamakingprawn Jan 7, 2013 @ 4:57pm 
Game keeps crashing on me to and I'm not pressing anything bar the start new game. Is there a way to get a refund on Steam as I've only just installed it and it's just unplayable?
iamakingprawn Jan 7, 2013 @ 5:02pm 
Just found this under the Support details.

Originally posted by steamsupport:
Issues and Fixes


Secondary Installers

If you're encountering issues with launching Democracy 2, make sure everything installed smoothly.

Aside from verifying your game cache and checking your connection with Steam, you may also need to manually run secondary installers required by this game.

Exit Steam entirely.

Browse to your Democracy 2 installation folder (Usually C:\Program files\Steam\Steamapps\common\Democracy 2\)

Run the following installers:
...\Steamapps\common\Democracy 2\directx\dxsetup.exe

Reboot your computer and test any issues again.


OS Specific Troubleshooting

If the above does not resolve the issue and you are running Windows 7 or Windows Vista, please complete the instructions in our Windows 7 and Vista Troubleshooting FAQ.

If you are running in Windows XP, take the following steps:
1.Exit Steam.
2.Go to the Start menu, select Run, type regedit and click OK.
3.Navigate to the following registry key: HKEY_CURRENT_USER\SOFTWARE\VALVE
4.Right click and select Permissions
5.Check the Allow boxes for Admin and System for both Full control and Read.


I'll give it a try and report back if it works.
red_celtic Jan 8, 2013 @ 9:32am 
I had this same issue at first... tried deleting the game and downloading it a couple of times then went to the website for the game and downloaded the demo from there and oddly enough the version I purchased from Steam worked. Not sure exactly why that worked.
dahlaj08 Jan 8, 2013 @ 2:13pm 
I am having the same problem. Tried reinstalling but it didn't do the trick. Tells me to contact the publisher and "[SetDisplayMode]. I am all out of answers
OkiDokiDa Jan 10, 2013 @ 11:10am 
Originally posted by red_celtic:
I had this same issue at first... tried deleting the game and downloading it a couple of times then went to the website for the game and downloaded the demo from there and oddly enough the version I purchased from Steam worked. Not sure exactly why that worked.

So do you mean that u have deleted the game u bought from steam, downloaded the demo version from there homepage, downloaded the steam version again and it worked?
iamakingprawn Jan 10, 2013 @ 1:56pm 
Well I followed the instructions and it didn't work. Really wished I read this discussion before purchasing the game as it's £15 I've just thrown away.
Raafje Jan 13, 2013 @ 1:19pm 
Having the same person, if i lose the election and wanna start again and press play it crashes than i need to start again. When i lose again and wanna start again it crashes again. So i can play 1 more time before an crash.
shane Jul 25, 2013 @ 5:16pm 
Color depth change worked for me.

1) Open the file 'config.muf' inside the 'data' directory in the games installation folder. You can edit this file using windows notepad (it's just a text file).

2) Change the line that says ColorDepth=32 to ColorDepth=16 then save, and try the game again

3) Change the line that says IsWindowed=0 to IsWindowed=1 then save, and try the game again

4) Add a new line to the [prefs] section saying SafeMode=1 then save, and try the game again
Kemoras Sep 26, 2013 @ 4:33pm 
Sir, may god bless you till death. (cause he wont bless when he's killin)

Originally posted by shane:
Color depth change worked for me.

1) Open the file 'config.muf' inside the 'data' directory in the games installation folder. You can edit this file using windows notepad (it's just a text file).

2) Change the line that says ColorDepth=32 to ColorDepth=16 then save, and try the game again

3) Change the line that says IsWindowed=0 to IsWindowed=1 then save, and try the game again

4) Add a new line to the [prefs] section saying SafeMode=1 then save, and try the game again
Showing 1-12 of 12 comments
< >
Per page: 15 30 50