Democracy 2 > General Discussions > Topic Details
dragoon8011 May 1, 2013 @ 10:46am
Game is not working
When I start my game either from explorer or from steam hub, it crashes with an error for display type. I went to their website which was hard to find anyway, but they don't give any advice in support and forms were of little help. I tried changing config file in data folder. The closest I got was the main menu coming up and now I can't click on anything (new game settings etc) I have tried running it as windows Xp and regular 7 but nothing works. And everything on my computer is up to date
Showing 1-5 of 5 comments
< >
Hammered-Bazman Jul 13, 2013 @ 5:24pm 
Have you tried lowering your resolution? It often seems to fix games on Steam, especially for older titles.
Toecutter PDX Jul 25, 2013 @ 7:12pm 
Are you getting the D3D Error? If so, I may have the solution: right-click the shortcut (make one on the desktop), click on "Properties". Next click on the "Compatibility" tab. Check the box that says "Disable display scaling on high DPI settings". That worked for me. Good luck!
snake.sven Jul 26, 2013 @ 3:47am 
Had the same problem. Starting as an admin fixed it for me....
desolation0 Jul 31, 2013 @ 7:22am 
Having same problem. I'm sure the demo from http://www.positech.co.uk/democracy2/demo.html worked perfectly for me. The only Config.muf option that seemed to matter was running in "safe mode", as far as getting it to work. Changed all three options as suggested at http://www.positech.co.uk/support/index.shtml in different ways but either doesn't load with the Display error, or loads in small window with no ability to click the menu buttons. Going to try some compatibility options to see if something works now.
desolation0 Jul 31, 2013 @ 7:28am 
Very interesting, set the desktop display from 720p to 1080p (I run 720 normally to reduce load on high graphic games) and seems to work properly now. Apparently the game defaults to 1024x768 fullscreen. Having a lower vertical resolution than 768 may be what causes the error.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50